Hello all, sharing a first time experience.

Here you can discuss every aspect of Debian. Note: not for support requests!

Hello all, sharing a first time experience.

Postby DrakeekarD » 2017-02-10 02:05

I am new to this forum, and to Linux in general. The past week has been a giant headache for me. I've installed Linux on a few devices the past couple years, an original xbox, and a ps2. Wasn't impressed however using a game console as a computer isn't the best of ideas. So never really played with it.

However a friend of mine found an old Mac Xserve G4 1.33ghz single core processor with 2 gb of ram. A 2003 model, yes I know way outdated piece of hardware. It can run MacOS X 10.5 Leopard which is like trying to play with windows 98 essentially. Not supported by anything really, so not much use. In looking to find server software with out spending money isn't easy, until I came across Linux. Debian Linux I found in my research to be the best route to go for my server. This is where the headache began.

I installed ubuntu first, and got stuck in a login loop without a real fix, so I then found a copy of ubuntu Xenial, and installing Xubuntu on it worked, but really pushed the hardware. That and I couldn't run more then 1 or 2 tasks without it getting laggy. Old hardware limitations are a nightmare. However, it ran. Then I found a Debian. I downloaded the newest one, jessie, and installed it. Then the headache really kicked in. I ran into an issue everytime with yaboot. I made sure I had the powerpc version, I had the newest stable build, but no matter what I tried, I couldn't get yaboot to install, thus having an unbootable machine. So after 3 days of trial and error, I finally found the workaround to this issue.

Now, this may be completely irrevelent to some, sorry for the terrible spelling, never was that good at it, but for anyone who has ran into this issue, unlikely, but since I did, it is possible.

What I ended up doing was installing debian jessie without the boot loader. Then I reinstalled xubuntu 16.04 on a second hard drive, having 4 of them in the system is nice, then after it was installed, I used its terminal to edit the yaboot.conf file to include the drive and partition of the debian installation. After running the ybin -v in terminal to save the changes, it worked. I now have both operating systems, and a copy of mac os x leopard installed on this old blade server. Going to do something with it, however, that will be another project down the road. It may be old, but its not dead yet.

Sorry if I rambled on a bit, but with the help of google, and a few forums, I was finally able to get Debian up and running. Now comes the decision of what to do, thinking of making a file server with it, so I can take my tools wherever and download them from my server as needed.
If anyone else has this issue with this old of hardware, I can walk you through what I did, albiet a shorter route now that I know what to do. I would also like any advice or ideas what can be done with this old server, as I've never played with one before, but for under 30 dollars, who could say no to that lol.

Anyways, gonna end this right here,
Thanks all in advance, hope this may help someone in the future with older hardware, and just letting people know the mac xserve is all but dead, but is still kicking in some aspect, and with this operating system, hopefully for a good while longer.


*In reading this, I realize it is terribly written and is a total butchering of the english language, however, I am a bit sleep deprived, so I do appologize for that.
Posts: 2
Joined: 2017-02-10 01:46

Re: Hello all, sharing a first time experience.

Postby pendrachken » 2017-02-10 03:56

PPC is a nightmare these days. At least you don't seem to have the problem hardware I have...

Powermac Dual G5 tower with the Radeon 9600.

I could install stable on it, but the workarounds for X.org properly running the buggy graphics card don't work with KMS ( kernel mode switching for video, required for the radeon driver in Jessie / stable ) enabled, meaning on every boot I would have to move the DVI cable from port 1 to port 2 while booting, and then after the machine is fully up move the cable back to port one to actually see the monitor.

So, I have to install oldstable. Except that the kernel in oldstable has a bug that means WIFI cards don't work if more than 1GB of RAM is installed.... so I have to grab the kernel from stable. Then there seems to be some kind of change in the way the new kernel names disks by UUID since the disk UUIDs the kernel sees are different than the UUIDs in openboot / yaboot and the system won't boot until after I boot the liveCD and manually rebuild yaboot after chrooting into the installed system.

Great, it boots, and I can apply the X.org XServer hacks that make it so everything works as it should on boot.... except that the web browsers available are older than dirt. And can't be upgraded since the new ones have dependencies on a higher version compiler and C libraries. Look at backporting the tools I need, but would mean compiling new versions of damn near half the system: not going to happen on these old G5's. Looked at the whole dependency chain for the build toolchain and said "screw it, I'm just going to manually install these since they should be backwards compatible anyway" and shoe-horned the stable "Jessie" entire compiler and build chain into the oldstable install. Next step is manually compiling Firefox ESR - takes like 6 hours if I recall.

Great, I have a working machine with an up to date browser now. Oh wait, it can't even play youtube videos higher than 480P without falling on its face ( to be fair on MacOS 10.5 it couldn't either, without a plugin that opened the video stream in quicktime ). It can barely play 720P videos from the drives. About the only thing that was somewhat impressive was the radeon 9600 could actually push my 1080P display on webpages and general navigation without stuttering.

TL;DR: Old Apple hardware is a real bitch and you either know Linux pretty damn well before installing on it these days, OR you learn Linux pretty damn well by the time you get a working install .
fortune -o
Your love life will be... interesting.
:twisted: How did it know?

The U.S. uses the metric system too, we have tenths, hundredths and thousandths of inches :-P
Posts: 1317
Joined: 2007-03-04 21:10
Location: U.S.A. - WI.

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests