chromium now depends on gconf + wtf is payment methods?

Here you can discuss every aspect of Debian. Note: not for support requests!

chromium now depends on gconf + wtf is payment methods?

Postby bw123 » 2018-11-04 02:25

wtf, this is getting out of hand? Why do I need gconf to use chromium? Isn't gconf deprecated? Why is this not mentioned in the changelog?

Security upgrades are great, enabling new crap under the radar like 'payment methods' is not cool.
Code: Select all
$ apt policy chromium
chromium:
  Installed: 70.0.3538.67-1~deb9u1
  Candidate: 70.0.3538.67-1~deb9u1
  Version table:
 *** 70.0.3538.67-1~deb9u1 500
        500 http://security.debian.org stretch/updates/main amd64 Packages
        100 /var/lib/dpkg/status
     63.0.3239.84-1~deb9u1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages


p.s. I caught the other thing too, you bastard.
User avatar
bw123
 
Posts: 3678
Joined: 2011-05-09 06:02
Location: TN_USA

Re: chromium now depends on gconf + wtf is payment methods?

Postby Head_on_a_Stick » 2018-11-04 06:14

bw123 wrote:Why do I need gconf to use chromium?

No idea but my buster box doesn't seem to need it:
Code: Select all
empty@buster:~ $ apt policy gconf-service chromium                                 
gconf-service:
  Installed: (none)
  Candidate: 3.2.6-5
  Version table:
     3.2.6-5 500
        100 https://cdn-aws.deb.debian.org/debian sid/main amd64 Packages
        500 https://cdn-aws.deb.debian.org/debian buster/main amd64 Packages
chromium:
  Installed: 70.0.3538.67-2
  Candidate: 70.0.3538.67-2
  Version table:
 *** 70.0.3538.67-2 500
        100 https://cdn-aws.deb.debian.org/debian sid/main amd64 Packages
        500 https://cdn-aws.deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
empty@buster:~ $

I think FF (esr) is better supported in Debian though, it seems to receive updates quicker than the chromium package.

bw123 wrote:p.s. I caught the other thing too, you bastard.

D00d you are a class act. :lol:
"French riots get results! U lot are instagram zzzombies" — graffiti over Euston underpass
User avatar
Head_on_a_Stick
 
Posts: 8590
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: chromium now depends on gconf + wtf is payment methods?

Postby stevepusser » 2018-11-04 19:11

Apparently that dependency was removed in the -2 rebuild.
Code: Select all
chromium-browser (70.0.3538.67-2) unstable; urgency=medium

  * Restore support for building with gtk2.

 -- Michael Gilbert <mgilbert@debian.org>  Tue, 23 Oct 2018 01:11:35 +0000

chromium-browser (70.0.3538.67-1) unstable; urgency=medium
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.13 kernel, wine-staging 4.0~rc4, Stellarium 0.18.3, VLC 3.0.5, Midori 7.0
User avatar
stevepusser
 
Posts: 10433
Joined: 2009-10-06 05:53


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable