Page 1 of 1

KVM guest - kernel panic when running from P9 share root

PostPosted: 2019-07-03 03:32
by romankqsok
Hello,

I am trying to boot a Linux guest on the KVM host and guest root file system is outside of guest on the host and passed through into the guest via P9 share as described at:

https://serverfault.com/questions/67364 ... t-and-qemu

QEMU Arguments in AQEMU:

Code: Select all
/usr/bin/qemu-system-x86_64 \
    -monitor stdio \
    -k en-us \
    -machine accel=kvm \
    -m 1024 \
    -cdrom /download/sysresccd-5.2.0_zfs_0.7.9.iso \
    -virtfs local,id=shared_folder_dev_0,path=/mnt/ascii64,security_model=none,mount_tag=shared0 \
    -boot once=d,menu=off \
    -net nic,vlan=0,model=e1000 \
    -net user,vlan=0 \
    -kernel /boot/vmlinuz-4.9.0-9-amd64 \
    -initrd /boot/initrd.img-4.9.0-9-amd64 \
    -append root=root9p rw rootfstype=9p rootflags=trans=virtio vga=0x31b \
    -rtc base=utc \
    -name "Brave" \
    -fsdev local,id=root9p,path=/mnt/ascii64,security_model=mapped \
    -device virtio-9p-pci,fsdev=root9p,mount_tag=root9p


Screenshot:
https://ibin.co/4mbruKyIIoAl.jpg

I tried to change guest kernels, but it does not help.
Please suggest, what shall be tried for a fix?

Re: KVM guest - kernel panic when running from P9 share root

PostPosted: 2019-07-03 19:12
by Head_on_a_Stick
romankqsok wrote: -append root=root9p rw rootfstype=9p rootflags=trans=virtio vga=0x31b \

Try adding init=/lib/systemd/systemd to the end of that line.

Re: KVM guest - kernel panic when running from P9 share root

PostPosted: 2019-07-04 00:18
by romankqsok
It is a Devuan guest and host.

Shall I try to add some other init, starting just with a bash would already be good for me for a first try of working guest.

Can I specify just:

init=/bin/bash

?

Re: KVM guest - kernel panic when running from P9 share root

PostPosted: 2019-07-05 17:11
by Head_on_a_Stick
romankqsok wrote:It is a Devuan guest and host.

Then why are you posting here?

Go to dev1galaxy.org and open a thread there instead.

Re: KVM guest - kernel panic when running from P9 share root

PostPosted: 2019-07-05 17:54
by romankqsok
Head_on_a_Stick wrote:Then why are you posting here?


I thought it is not a distribution specific problem, may be I miss or have incorrect some kernel or QEMU arguments.