How do I update Ruby from 2.3.3 to 2.5.0?

Here you can discuss every aspect of Debian. Note: not for support requests!

How do I update Ruby from 2.3.3 to 2.5.0?

Postby jaytelford » 2019-07-18 20:34

I am trying to update my ruby gems on Debian 9.9, but every time I do attempt to, I get the following error.

Code: Select all
Updating installed gems
Updating did_you_mean
ERROR:  Error installing did_you_mean:
   There are no versions of did_you_mean (= 1.3.0) compatible with your Ruby & RubyGems
   did_you_mean requires Ruby version >= 2.5.0. The current ruby version is 2.3.3.222.
Gems updated: did_you_mean


I have tried to install the latest ruby version by doing sudo apt install ruby but the latest version (2.3.3) is already installed. I have tried to specify the version, but that didn't work either. is there any way at all that I can get the latest ruby version, without using version managers or 3rd party PPAs?
jaytelford
 
Posts: 33
Joined: 2018-05-09 10:56
Location: United KIngdom

Re: How do I update Ruby from 2.3.3 to 2.5.0?

Postby ruwolf » 2019-07-18 20:45

Debian 10 (currently stable) has Ruby 2.5.1...
User avatar
ruwolf
 
Posts: 392
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: How do I update Ruby from 2.3.3 to 2.5.0?

Postby jaytelford » 2019-07-18 22:59

ruwolf wrote:Debian 10 (currently stable) has Ruby 2.5.1...


Thanks, I have updated and everything is working again.
jaytelford
 
Posts: 33
Joined: 2018-05-09 10:56
Location: United KIngdom


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable