Page 1 of 1

[Solved] Toshiba laptop booted to grub prompt

PostPosted: 2019-09-25 21:59
by kedaha
This is just to report an "issue" I solved today when installing Debian Buster on a friend's laptop that previously had Ubuntu, but no Windows. I'm not particularly fond of dealing with, or writing about, broken grub issues but I hope it may be of interest to someone with a similar grub problem.
The installation went fine but when I rebooted, in spite of keeping my fingers crossed, I was greeted with:

Code: Select all
                               GNU GRUB version 2.02~bet2-38ubuntu3.22
Minimal BASH-like line editing is supported. For the first word, TAB lists possible command command completions. Anywhere else TAB lists possible device or file completions.

I haven't looked at this grub prompt thing for a very long time but I was lucky to find what I was looking in a post here so I continued:
Code: Select all
grub> initrd (hd0,01)/boot/initrd

but this resulted, not very promisingly, in:
Code: Select all
alloc magic is broken at 0x72433460: 0
Aborted. press any key to escape.

So I pressed some random key and the screen was momentarily plunged into darkness. The alloc magic seemed to be irrelevant since up came a BIOS Boot Manager screen with:
Boot Options Menu

ubuntu (TOSHIBA MQQ1abf050)
debian (TOSHIBA MQQ1abf050)
Boot From EFI File
and to change option, ENTER to select an option.
press F10 to BIOS Setup Options, ESC to exit.

Whereupon I was able to select & boot Debian. I didn't know what the old ubuntu entry was doing there, but little did I know that it was causing the problem. I used a Grub Rescue disk called "RESCATUX" but after it reported that Grub had been fixed, back came the same grub prompt. Then it occurred to me to get rid of the ubuntu entry and after
Code: Select all
# cd /boot/efi/EFI

where both entries were shown I removed ubuntu with
Code: Select all
# rm -rf ubuntu

And Buster now boots OK from the usual grub menu. Job done.

Re: [Solved] Toshiba laptop booted to grub prompt

PostPosted: 2019-09-26 06:14
by Dai_trying
In addition to this you might also need to remove the entry from the UEFI (BIOS) settings, the entry might still be there but as it is not resolvable it gets skipped to the next (Debian) entry. This would not really make a lot of difference to the user but would keep your UEFI entries tidy and maybe save a few ms's on boot-up. You might also be able to remove it using efibootmgr from the command line if your UEFI is not too buggy.

Re: [Solved] Toshiba laptop booted to grub prompt

PostPosted: 2019-09-28 13:24
by kedaha
Thanks Dai_trying for the comments; I removed all the previous entries.
One thing I might mention is that I disabled the "secure boot" but forgot to re-enable it, but since there's no Windows I don't think that matters.
Off-topic: I made what was for me a mistake of installing the ·default Debian desktop, Gnome and immediately regretted; I use mate myself, but, since it's for someone else, I'll have to wait and see how he gets on with it.
I must say booting with EFI bioses seems to have improved a lot in the last few years but if something goes wrong it is a bit annoying if, like myself, you find troubleshooting boot problems on machines made for Windows a bit on the irksome side.

Re: [Solved] Toshiba laptop booted to grub prompt

PostPosted: 2019-09-28 15:44
by Dai_trying
I have to say when I first used a UEFI system I made a few mistakes and after a few re-installs got to grips with some basics and now I much prefer it when I dual (multi) boot as I can (and usually do) have many OS's on a machine and they all have their own version of grub (or other bootloader) and I can add/remove them without having any of the issues I used to have with MBR systems, where removing the system that was controlling grub prevented me booting into any OS until I got it fixed (Live-Cd, chroot, install grub), thankfully those days are gone for me :D
As regards secure boot, it can be either on or off as Debian now works either way, I have mine off and remove the grub signed packages to allow me more flexibility with boot options.