Page 1 of 1

OpenCV compiled with Qt ?

PostPosted: 2020-03-15 10:20
by Stemmo
Hi all,
Debian 10 x64.

I'm starting to develope with OpenCV using the default opencv package (3.2.0).
If I try to use the highgui features like createButton() the program is correctly compiled but when I run it I receive an exception:

Code: Select all
OpenCV Error: The function/feature is not implemented (The library is compiled without QT support) in createButton, file /build/opencv-ytxPbe/opencv-3.2.0+dfsg/modules/highgui/src/window.cpp, line 526
terminate called after throwing an instance of 'cv::Exception'
  what():  /build/opencv-ytxPbe/opencv-3.2.0+dfsg/modules/highgui/src/window.cpp:526: error: (-213) The library is compiled without QT support in function createButton


I'd like to know if this is correct (???) :?:
Do I need some extra packages or do I need to recompile the entire library from the scratch ?

Thanks

Re: OpenCV compiled with Qt ?

PostPosted: 2020-03-15 10:43
by Stemmo
Printing the output of I can confirm that the library is compiled without QT:

Code: Select all
  GUI:
    QT:                          NO
    GTK+ 3.x:                    YES (ver 3.24.5)
    GThread :                    YES (ver 2.58.3)
    GtkGlExt:                    NO
    OpenGL support:              NO
    VTK support:                 YES (ver 6.3.0)


Is there a way to point to GTK for GUI objects?