I will try stable this time and will write about here.

Here you can discuss every aspect of Debian. Note: not for support requests!

I will try stable this time and will write about here.

Postby night » 2021-02-11 09:18

Hello. I am Linux user since 2007.
Last week i tried Debian unstable and got strange and bad result: after using it for some hours, Debian unstable started to hang, with mouse being able to move very slowly and it can be told even, that system stopped working.
I used official and latest Debian testing netinst and when had testing, changed sources.list to point to unstable, not to testing, then upgraded all packages, restarted computer.
Many years before, i did it and that worked well - i had Debian unstable, which worked without errors.
Now i want to know where the reason is, and, i am going to install Debian stable and will write how and where it goes.
While i am installing, i want to ask a question: ...maybe this system freeze, or hang, i do not know how to say, is already known? If yes, what it might be? Free space was enough - about 200 GB free, no prioprietary software installed, nor nvidia drivers (i have nvidia), nor proprietary browsers, none.
I use system, which is now UEFI and i installed all this in UEFI mode and booted so. Maybe i should try BIOS mode?..
Posts: 3
Joined: 2021-02-11 08:55

Re: I will try stable this time and will write about here.

Postby Head_on_a_Stick » 2021-02-11 09:58

Did you install the CPU µcode and firmware-misc-nonfree packages? Intel CPUs in particular need the µcode fixes and the nouveau driver won't work properly without firmware for some NVIDIA cards.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: I will try stable this time and will write about here.

Postby night » 2021-02-11 11:13

Thank you, i will write this to my technical notebook for future to find and to do.
This time i did this: in UEFI i disabled all boot options with UEFI, that only BIOS mode would be left;
then, i booted Debian Stable amd64 netinst in Expert Install and installed Debian choosing to use all hard drive and one partition for all, default packages configuration - Debian Desktop, Printing, System Utilities; no customizations.
After install successfully booted into now, BIOS, system.
All works still: thunderbird, firefox, youtube, i installed many various packages which i needed, including vlc, gparted, gnome-multi-writer and so on.
Being stable version and being installed in BIOS and booted in BIOS mode again it works now... :) ...i would report in the forum and after in bug tracking system if something would be wrong, but it seems, all works now.
I did not installed those firmware packages at first installs, even when in UEFI mode, so, it could be a reason. For now it still works without aditional firmware, so i will test it as it is.
Thank You for fast response and for information, i will know about firmware now, if i will have similar dificulties with system again.
Debian is Great! :)
Posts: 3
Joined: 2021-02-11 08:55

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 8 guests