CTRL-ALT-Fn ???

Here you can discuss every aspect of Debian. Note: not for support requests!

CTRL-ALT-Fn ???

Postby ed_po » 2006-05-09 09:30

Hello, i have a newbie question:
ctrl-alt-fn stopped working, don't know what part of the system is responsible for it- X or KDE?
any suggestions about fixing the problem?

THANKS :roll:
ed_po
 
Posts: 12
Joined: 2006-05-08 10:47

Postby anon » 2006-05-09 13:43

Good question, if kde is anything like gnome (and it may not be, I'm a gnome user) then it will happily override a perfectly working keyboard setup with it's own broken config. I don't think ctrl-alt-fn is "hardwired" but I might be misstaken. What you can do is check your x log under /var/log. If you're running sid make sure you have he xkb-data package, I've seen reports that under some circumstance it isn't pulled in resulting in broken configs (6.9->7.0 transition). You could also add a new user and log in to that and see if it works there (wich would indicate a kde problem), adduser username then deluser username when you're done, you might have to remove the /home/username directory manually. I you ca't resolve this yourself follow up with additional info such as distro (sarge/stable etch/testing sid/unstable) and kernel (uname -a).
anon
 

Postby lacek » 2006-05-09 14:29

The ctrl+alt+Fx key behavior is controlled by the "DontVTSwitch" option in the X config. Look for a line similar to this in your /etc/X11/XF86Config-4:
Code: Select all
Option "DontVTSwitch" "true"

Change the "true" to "false" or remove the line entirely to make it work again. You have to restart X, of course.
lacek
Moderator Team Member
 
Posts: 769
Joined: 2004-03-11 18:49
Location: Budapest, Hungary

Postby ed_po » 2006-05-09 23:19

Ok, with other user and under Gnome tty switching works fine, so here is my config:
distro: sarge\stable
uname -r : 2.6.8-3-k7
ed_po
 
Posts: 12
Joined: 2006-05-08 10:47

Postby anon » 2006-05-10 13:14

It's a kde problem specific to your user (you've ruled out other possibilites), see what you can find in KDE Control Center, I'm on etch here so It might be a little diffrent for you (and I'm really not a KDE user) the relevant settings can be found under "Regional & Accessability" /Keyboard Layout and /Keyboard Shortcuts I can't find anything specific to your situation here, so try ctrl and alt separatly with other combinations to see if one of them has been remapped to something else (using kde apps just to make sure) and then look for the settings involving that key. If this fails to produce anything you have shown that you can reate a user that has a working config. In linux personal user settings are stored in your home directory. Open Konqueror and select show hidden files under View and you'll see a hole bunch of new files all beginning with a "." these are all config files, just ordinary textfiles so you can open them in any tet editor. KDE seems to store all its settings under the .kde folder. So which files to look at, well the names should provide a guess and perhaps the date of last modified will help you figure it out. Now you can compare the file to a known working user, make a backup copy so you can revert the changes should you have made a mistake and copy the file (this may require a subsequent logout/login for the changes to take effect).[/quote]
anon
 

Postby ed_po » 2006-05-13 20:17

anon wrote:It's a kde problem specific to your user (you've ruled out other possibilites), see what you can find in KDE Control Center, I'm on etch here so It might be a little diffrent for you (and I'm really not a KDE user) the relevant settings can be found under "Regional & Accessability" /Keyboard Layout and /Keyboard Shortcuts I can't find anything specific to your situation here, so try ctrl and alt separatly with other combinations to see if one of them has been remapped to something else (using kde apps just to make sure) and then look for the settings involving that key. If this fails to produce anything you have shown that you can reate a user that has a working config. In linux personal user settings are stored in your home directory. Open Konqueror and select show hidden files under View and you'll see a hole bunch of new files all beginning with a "." these are all config files, just ordinary textfiles so you can open them in any tet editor. KDE seems to store all its settings under the .kde folder. So which files to look at, well the names should provide a guess and perhaps the date of last modified will help you figure it out. Now you can compare the file to a known working user, make a backup copy so you can revert the changes should you have made a mistake and copy the file (this may require a subsequent logout/login for the changes to take effect).
[/quote]

i will continue my research but until now i didn't manage to find any configuration file by its name in .kde or anywhere else. Probably stupid folks like me must work hard to make their linux work. If there wasn't a chance that some smart guys may help from time to time i wouldn't consider using linux at all. :wink:
ed_po
 
Posts: 12
Joined: 2006-05-08 10:47


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable