Page 3 of 6

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-22 11:24
by gradinaruvasile
For the ones who want to shutdown/suspend/hibernate from slim/xdm:

There is a very simple solution: add a launcher to the panel the has "gksudo bash pm-suspend" or "gksudo bash pm-hibernate" in it.
Edit: sorry, i forgot that you have to call bash scriptname with gksudo.
And the power-manager functions too are disabled because of the lack of policykit authentication.

Muhv wrote:Hey! Just upgraded testing branch and no problems what so ever. But why is it that distrowatch refers to version 4.8.0 in red, but not 4.8.1? Also why is ver 4.6.2 still in the about xfce option?


You are using Testing - you have 4.6. The xfce 4.8 stuff is in Unstable/Sid. You have to wait a few weeks for it or install it from unstable but that is a bit complicated.

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-22 11:30
by Muhv
:) Yeah, one can always download stuff from sid repos to testing, without waiting. Thats what i did. And it was a piece of cake, no complications.

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-22 12:03
by gradinaruvasile
Muhv wrote::) Yeah, one can always download stuff from sid repos to testing, without waiting. Thats what i did. And it was a piece of cake, no complications.


Well it wasnt for me. Some packages had dependency issues (maybe an apt mirror thing). So i went to xfce site, downloaded all the sources (including xfce applications) and compiled + installed from source.
BTW did you make sure that you have ALL important packages to 4.8 version? Because you may end up with a mix of 4.8 and 4.6 if you dont explicitly specify every single installed packages version.

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-22 12:30
by Muhv
For some reason, few xfce 4.8 related packages, such as libxfce4util4, libxfce4util4-dbg, libxfce4util-bin did not get downloaded when i upgraded. Perhaps i just didn't have them. So those packages solved later the ver nr issue. I tried also, as soons as it hit unstable repos, to install on testing, but some dependency problems occured. Few days later they were gone, and now it looks stable enough to hit testing. No point waiting.

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-22 17:26
by bohu
gradinaruvasile wrote:For the ones who want to shutdown/suspend/hibernate from slim/xdm:

There is a very simple solution: add a launcher to the panel the has "gksudo bash pm-suspend" or "gksudo bash pm-hibernate" in it.
Edit: sorry, i forgot that you have to call bash scriptname with gksudo.
And the power-manager functions too are disabled because of the lack of policykit authentication.



gksudo bash pm-shutdown ?

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-22 17:30
by bohu
I see that thunar, thunar-data, and xfce4-settings just got upgraded in Sid. That may smooth out the upgrade for some folks.

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-22 22:17
by gradinaruvasile
bohu wrote:
gradinaruvasile wrote:For the ones who want to shutdown/suspend/hibernate from slim/xdm:

There is a very simple solution: add a launcher to the panel the has "gksudo bash pm-suspend" or "gksudo bash pm-hibernate" in it.
Edit: sorry, i forgot that you have to call bash scriptname with gksudo.
And the power-manager functions too are disabled because of the lack of policykit authentication.



gksudo bash pm-shutdown ?


no.

"gksudo bash poweroff"

for shutdown.

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-23 00:04
by Muhv
In order to manage trash in 4.8 desktop, you have to install gvfs? And by the looks of it, the gvfs package has some serious bug.

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-23 00:16
by gradinaruvasile
Muhv wrote:In order to manage trash in 4.8 desktop, you have to install gvfs? And by the looks of it, the gvfs package has some serious bug.


Gfvs works just fine with xfce.

What bug are you referring to?

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-23 07:02
by Muhv
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=615728

Looks like the problem is related to amd64 install process. So i guess it's safe to install it on 686?

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-23 08:22
by bugsbunny
It should even be safe to install on a 64 bit system. The problem is with the build process, so you should only have an issue if you're actually compiling it yourself. Also according to the report it's fixed in version 1.7.2-1 which was apparently released in January (to experimental, which currently has 1.8.0-1)

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-23 08:40
by Muhv
Yeah, it's ok. Just installed it and trash icon is back on desk. Although, i still don't like the idea that even in 4.8 ver, i have gnome related package. gvfs just brouht in libgnome-keyring0.

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-23 10:44
by kc1di
Just installed 4.8 form sid repositories and all seems to be working fine here. menu was there everything I would normally use seems to be working.
so far am enjoying it very much.
:D

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-23 16:27
by emariz
This ConsoleKit issue could be related to the authentication problem in Xfce:
viewtopic.php?p=350677#p350677

Re: WOO HOO !!! Xfce 4.8 just landed in Sid.

PostPosted: 2011-04-24 06:56
by bohu
emariz is right. Consolekit is the culprit.

1) Using synaptic, remove consolekit. On my system this also removed policykit-1, policykit-1-gnome, gconf-editor, and hplip. I don't know what would happen if you reboot while these files are missing so don't reboot!

2) Switch to Debian Stable (squeeze) repository and reinstall consolekit and then lock it at that version. In the synaptic menu, Package>Lock_Version.

3) Switch to wheezy repo and reinstall policykit-1 and policykit-1-gnome.

4) Go back to sid repo and then reboot.