gpg-agent now forced upon users of GnuPG

If it doesn't relate to Debian, but you still want to share it, please do it here

gpg-agent now forced upon users of GnuPG

Postby timbgo » 2014-05-13 16:41

I just spent hours because I don't want to add graphical overlay to my signing and/or encrypting things.
Pls. see on top of my fresh post:
viewtopic.php?f=16&t=110503&p=540691#p540691
It's signing in git that I stumbled upon, because I don't want to use gpg-agent and they seem to be forcing it upon users.

And that was short explanation.
Longer here:
http://www.gossamer-threads.com/lists/gnupg/users/58785
[[ still looks like having been cut short, because there are issues that cry so loud in there, so loud, they break from in between the lines very forcefully, if you have enough alert on the right side of the privacy/freedom/surveillance issues ]]
[[ No, I don't claim anything, I suspect only. Strongly ]]
[[ Because.. read on... ]]
Because, do you see any more, or much less of that thread on the original list? Tell me, somebody, pls.:

the thread is on this page (search for "pipe passphrase to unlock key"):
http://lists.gnupg.org/pipermail/gnupg- ... hread.html

and the message is here:
http://lists.gnupg.org/pipermail/gnupg- ... 44881.html
and it has no links to any replies there on that page, only other topics..

And now, praise to people from Debian, thanks to whom, I still don't have to use gpg-agent in Debian.
(or is is just not moving so fast as Gentoo moves? I hope it's not just that. I use Testing in Debian and Testing in Gentoo... )

Namely, in my new Gentoo installation, for gentle readers' perusal:
Air-Gapped Gentoo Install, Tentative
https://forums.gentoo.org/viewtopic-t-987268.html
and I suffer from same gpg-agent inposition, can't sign nothing with GnuPG unless I enable it... Which I don't want to do.

Why not? Do I have to say? Are there people willing to discuss it?
It's in the mailing list on Gossamer's and not on the original GnuPG list (sic!), the why. No, not blatantly obvious, but it is there.

But let me see, if there are people interested in this topic.

I do need the GnuPG, and no program forced upon me for just feeding passwords that I type to GnuPG. Really, really I don't see why I would need that.

Miroslav Rovis
http://www.CroatiaFidelis.hr
timbgo
 
Posts: 265
Joined: 2013-04-14 12:17

Re: gpg-agent now forced upon users of GnuPG

Postby dasein » 2014-05-13 17:00

Moved to Offtpic, because it's... well... off-topic.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: gpg-agent now forced upon users of GnuPG

Postby timbgo » 2014-05-13 17:06

timbgo wrote:I just spent hours because I don't want to add graphical overlay to my signing and/or encrypting things.
Pls. see on top of my fresh post:
viewtopic.php?f=16&t=110503&p=540691#p540691
It's signing in git that I stumbled upon, because I don't want to use gpg-agent and they seem to be forcing it upon users.

And that was short explanation.
Longer here:
http://www.gossamer-threads.com/lists/gnupg/users/58785
[[ still looks like having been cut short, because there are issues that cry so loud in there, so loud, they break from in between the lines very forcefully, if you have enough alert on the right side of the privacy/freedom/surveillance issues ]]
[[ No, I don't claim anything, I suspect only. Strongly ]]
[[ Because.. read on... ]]
Because, do you see any more, or much less of that thread on the original list? Tell me, somebody, pls.:

the thread is on this page (search for "pipe passphrase to unlock key"):
http://lists.gnupg.org/pipermail/gnupg- ... hread.html

and the message is here:
http://lists.gnupg.org/pipermail/gnupg- ... 44881.html
and it has no links to any replies there on that page, only other topics..

And now, praise to people from Debian, thanks to whom, I still don't have to use gpg-agent in Debian.
(or is is just not moving so fast as Gentoo moves? I hope it's not just that. I use Testing in Debian and Testing in Gentoo... )

Namely, in my new Gentoo installation, for gentle readers' perusal:
Air-Gapped Gentoo Install, Tentative
https://forums.gentoo.org/viewtopic-t-987268.html
and I suffer from same gpg-agent inposition, can't sign nothing with GnuPG unless I enable it... Which I don't want to do.

Why not? Do I have to say? Are there people willing to discuss it?
It's in the mailing list on Gossamer's and not on the original GnuPG list (sic!), the why. No, not blatantly obvious, but it is there.

But let me see, if there are people interested in this topic.

I do need the GnuPG, and no program forced upon me for just feeding passwords that I type to GnuPG. Really, really I don't see why I would need that.

Miroslav Rovis
http://www.CroatiaFidelis.hr

Let me try and explain in some practical details the cause here. Technically, but in such way that non-advanced,users can understand as well, although beginners may not.
Here is what I did with my previous post.
I just clicked on "Quote" button of the previous post, of the first post in this thread that I just started.
And I selected it with the mouse or in other way, I don't remember, that's near-subcounscious mosty work, and right-clicked to copy that selection.
Then I opened a file in my terminal like this:
Code: Select all
$ cat > Deb_gpg-agent_20140512_POSTED-QUOTED.txt

and skim-checked if that was fine:
Code: Select all
$ cat Deb_gpg-agent_20140512_POSTED-QUOTED.txt

Now with this command I get the output shown:
Code: Select all
$ gpg --output Deb_gpg-agent_20140512_POSTED-QUOTED.txt.sig -s -a -b Deb_gpg-agent_20140512_POSTED-QUOTED.txt
You need a passphrase to unlock the secret key for
user: "Miroslav Rovis (consecrated to Heart of Jesus) <miro.rovis@croatiafidelis.hr>"
4096-bit RSA key, ID 4FBAF0AE, created 2014-01-16

gpg: problem with the agent - disabling agent use
Enter passphrase:
$

And here I enter my password and I don't have to worry about a surplus program that has many other functions, but don't allow the good old GnuPG to retain just this plain and simple checking of passwords.
Isn't that insanity?
Upon typing in my password here, the commend prompt returns, and the signature for the file is written just as I gave to command that it be.
And here's what I got, so you can check that the text is verifiable, I mean you can click quote (I won't be touching that first post in this topic ever, and no user is allowed either, so it shoud be that you can check that what I am talking is sensible.

$ cat Deb_gpg-agent_20140512_POSTED-QUOTED.txt.sig
Code: Select all
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAABCgAGBQJTckvhAAoJEOqYhIhPuvCua24P/2dVFoidWMPtCRMEgU2RuNXK
tyXI80VE3BypFiYyCPO3zE2l47KRw/BacE8aU1r7HMcJDYKTbOSmihcZZ9yldnH+
11lFUgeeToGz8F7vKC43P55S002QNjOYSWh/aKszKGJ8hLDcsF+Bv7hpZ7iHWCt7
hVIebwFsCVKymSNYKb6sBgMskpeOMxZMjAtN+DMLYdQtMuyqNsNP1kyWGElKb0fW
pXH1814n4lbE5i3Lytpq4K8HO7ZmEzlmIUi6SAODpMlYjmqzui/ir3ANklhQr+0z
ZjCpAj28TGk246D2bZo0vPA+50XG/a0Pyka8zyx3r1PUsuXk8KGYjt+nqsQqQRY5
/xG5njiaojfzDP4Okp5lfZlXDvqpk0vgnlzIvT+PS7mOUMeVB/BXwbawRriBncv/
5jcYVcLw8VYJIrxtg+jqK9GPg8c0vf8LvsOPQ9oZPstzyQucsqh0YhMBrO8wDvTy
HLBde2j1BUZH8ZIydsgpfjD01FeA6VBixcxK3yJEaf8uxeYUB12Wftx6A+LkhXWe
irZVBi6nr4Zj9nmhV33LtTS+8d+o2NUM/qaxPj40wx/adl34MDx02egiboQhqHVP
jdDvg0fUJq4V6QToYXkWuw4uDaLgTLw/jn9FwtWI7zkYM3FQIODHcG8yLvnUKIA6
99+HpxTN7cWS1WOK1DMX
=eGGT
-----END PGP SIGNATURE-----
timbgo
 
Posts: 265
Joined: 2013-04-14 12:17


Return to Offtopic

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable