Segate personal cloud cannot adjust transmission settings

If it doesn't relate to Debian, but you still want to share it, please do it here

Segate personal cloud cannot adjust transmission settings

Postby qwertyjjj » 2017-10-18 22:26

I logged in as admin but I am unable to see any transmission settings. Any ideas how I can access?
This is probably a stripped down version of debian on a NAS OS device.

admin@PersonalCloud:/$ pidof transmission-daemon
5205
admin@PersonalCloud:/$sudo systemctl stop transmission-daemon
-bash: sudo: command not found
admin@PersonalCloud:/$systemctl stop transmission-daemon
Failed to get D-Bus connection: Unkown error -1
admin@PersonalCloud:/$ apt install systemd-sysv
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
qwertyjjj
 
Posts: 13
Joined: 2008-06-05 14:16

Re: Segate personal cloud cannot adjust transmission setting

Postby Clivetimmins » 2017-10-19 00:20

Is sudo installed? And transmission settings are in a file that ends .json. ($HOME/.config/transmission-daemon/settings.json? I cant remember) can be in a few places depending on the version you have. Is transmission installed as a service

1. Check if sudo installed
2. Make sure transmission is installed correctly
3. Run sudo service transmission-daemon stop
4. Find and check your settings.json
5. Run sudo service transmission-daemon start
6. If this helped you in anyway give me a high 5 :D
Clivetimmins
 
Posts: 7
Joined: 2017-07-24 01:06

Re: Segate personal cloud cannot adjust transmission setting

Postby qwertyjjj » 2017-10-19 01:02

Hmm...seems odd

admin@PersonalCloud:/$ apt-get install sudo
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
admin@PersonalCloud:/$ sudo apt-get install sudo
-bash: sudo: command not found
qwertyjjj
 
Posts: 13
Joined: 2008-06-05 14:16

Re: Segate personal cloud cannot adjust transmission setting

Postby GarryRicketson » 2017-10-19 01:13

Not really odd at all:
Code: Select all
 admin@PersonalCloud:/$ apt-get install sudo

You must be logged in as root to install a package.
The $ shows are just a normal user. Try using 'su' then the root password.
bash: sudo: command not found

Indicates sudo is not installed, usually if it is installed, but you are not in the sudoers file, it will say so.
What do you get if you type ?:
Code: Select all
man sudo
"What we expect you have already Done"

Before doing anything, read the Debian documentation:
Debian Documentation
How to ask the smart way
Debian Foro Español
======================
For the Birds
User avatar
GarryRicketson
 
Posts: 4356
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Segate personal cloud cannot adjust transmission setting

Postby debiman » 2017-10-19 16:56

it would seem the term 'admin' is meaningless here.
you need root privileges.
try
Code: Select all
su -
this should make you root.
do you have your root password?
if that doesn't work, only the makers of this mysterious "stripped down debian" can help you.
User avatar
debiman
 
Posts: 1528
Joined: 2013-03-12 07:18

Re: Segate personal cloud cannot adjust transmission setting

Postby GarryRicketson » 2017-10-19 17:57

Yes apparently "admin" is just the user name, for example I could create a user
called "admin", but if I don't give user "admin" root privileges, and make admin
a member of the appropriate groups, Mr. admin is just a normal user. But any way, the user name "admin", is impressive.

To confirm or check if sudo is installed or not see:
https://wiki.debian.org/ListInstalledPackages
for details.
Code: Select all
$ dpkg -s sudo

Should show if it is installed or not.
============ edited============
Something that strikes me as really odd,
Postby qwertyjjj » 2017-10-18 16:26
I logged in as admin but I am unable to see any transmission settings. Any ideas how I can access?
This is probably a stripped down version of debian on a NAS OS device.

Is the OP really the administrator ? I mean it seems to me like if they were,
they would at least know , definitely , what OS it is and how to login as root. . And what it is on.
Just guessing, that is probably a stripped down version of debian , makes me
wonder.
Last edited by GarryRicketson on 2017-10-19 18:13, edited 1 time in total.
User avatar
GarryRicketson
 
Posts: 4356
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Segate personal cloud cannot adjust transmission setting

Postby acewiza » 2017-10-19 18:07

debiman wrote:...mysterious "stripped down debian" ..

I've fancied getting one of these myself. :wink:

Where might such a digital temptress be found?
Nobody would ever ask questions If everyone possessed encyclopedic knowledge of the man pages.
User avatar
acewiza
 
Posts: 267
Joined: 2013-05-28 12:38
Location: Out West

Re: Segate personal cloud cannot adjust transmission setting

Postby debiman » 2017-10-19 18:20

debiman wrote:if that doesn't work, only the makers of this mysterious "stripped down debian" can help you.
that was fancytalk for RTFM.
and we cannot even tell you which effing manual to read because we know nothing about your distro.
User avatar
debiman
 
Posts: 1528
Joined: 2013-03-12 07:18

Re: Segate personal cloud cannot adjust transmission setting

Postby qwertyjjj » 2017-10-19 22:15

GarryRicketson wrote:Not really odd at all:
Code: Select all
 admin@PersonalCloud:/$ apt-get install sudo

You must be logged in as root to install a package.
The $ shows are just a normal user. Try using 'su' then the root password.
bash: sudo: command not found

Indicates sudo is not installed, usually if it is installed, but you are not in the sudoers file, it will say so.
What do you get if you type ?:
Code: Select all
man sudo


Gives
No manual entry for sudo
qwertyjjj
 
Posts: 13
Joined: 2008-06-05 14:16

Re: Segate personal cloud cannot adjust transmission setting

Postby qwertyjjj » 2017-10-19 22:18

debiman wrote:
debiman wrote:if that doesn't work, only the makers of this mysterious "stripped down debian" can help you.
that was fancytalk for RTFM.
and we cannot even tell you which effing manual to read because we know nothing about your distro.


cat /proc/version gives

Linux version 3.10.72-svn18863 (root@baae5b92d3dc) (gcc version 4.6.4 (Marvell GCC release 20160226-c4af733b 64K MAXPAGESIZE ALIGN) ) #1 Wed Jun 14 09:22:18 UTC 2017
qwertyjjj
 
Posts: 13
Joined: 2008-06-05 14:16

Re: Segate personal cloud cannot adjust transmission setting

Postby qwertyjjj » 2017-10-19 22:20

GarryRicketson wrote:Yes apparently "admin" is just the user name, for example I could create a user
called "admin", but if I don't give user "admin" root privileges, and make admin
a member of the appropriate groups, Mr. admin is just a normal user. But any way, the user name "admin", is impressive.

To confirm or check if sudo is installed or not see:
https://wiki.debian.org/ListInstalledPackages
for details.
Code: Select all
$ dpkg -s sudo

Should show if it is installed or not.
============ edited============
Something that strikes me as really odd,
Postby qwertyjjj » 2017-10-18 16:26
I logged in as admin but I am unable to see any transmission settings. Any ideas how I can access?
This is probably a stripped down version of debian on a NAS OS device.

Is the OP really the administrator ? I mean it seems to me like if they were,
they would at least know , definitely , what OS it is and how to login as root. . And what it is on.
Just guessing, that is probably a stripped down version of debian , makes me
wonder.


As per title, it's a Segate Personal Cloud hard drive NAS OS

dpkg sudo gives

package sudo is not installed and no information is available

If I su - I get a password prompt but I cannot find the root password anywhere. I assume it is a default but no manual tells me. I did not set it up, it comes with everything installed OOTB.
qwertyjjj
 
Posts: 13
Joined: 2008-06-05 14:16

Re: Segate personal cloud cannot adjust transmission setting

Postby Clivetimmins » 2017-10-19 23:17

Try the password for the web interface as the root password. Also check arround the web gui for settings and options. Can you not install a torrent client with the gui I'm sure that it's like a app or something. Trying to help. Limited abilities when your on your phone at :lol:
Clivetimmins
 
Posts: 7
Joined: 2017-07-24 01:06

Re: Segate personal cloud cannot adjust transmission setting

Postby qwertyjjj » 2017-10-19 23:34

Clivetimmins wrote:Try the password for the web interface as the root password. Also check arround the web gui for settings and options. Can you not install a torrent client with the gui I'm sure that it's like a app or something. Trying to help. Limited abilities when your on your phone at :lol:

It has a torrent client, which I suspect is transmission.
When I go to http://192.168.0.120:9091/ I get the following meanding transmission is running.
I ran top and saw transmission-daemon there
but they've changed the web interface so I can only select upload and download bandwidth.
What I need to do is restrict times and it's not available in the web ui.
403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.
qwertyjjj
 
Posts: 13
Joined: 2008-06-05 14:16

Re: Segate personal cloud cannot adjust transmission setting

Postby GarryRicketson » 2017-10-20 00:33

Does this "Segate Personal Cloud" not have any kind of support ?
Seems like they would be the ones to ask about this.
http://www.seagate.com/support.

Recovering the administrator password

To have full access to the NAS, the administrator signs in with the domain’s administrator password. If you forget the administrator’s password, you can use a password reset disk to create a new one. As an important backup measure, Seagate recommends that you create a password reset disk when you initially create your password.
Create a password reset disk

To create a reset disk, you need a USB key or flash drive.

In the Control Panel, select User Account.
Select the administrator account.
Select Create a password reset disk.
Follow the on-screen instructions.

Keep the USB key or flash drive in a safe location.


From what I can see , Debian does not come pre-installed on this Seagate device, some body had to install it , they also would be the one that has the password, etc.
https://wiki.debian.org/InstallingDebianOn/Seagate/PersonalCloud
The Personal Cloud devices come with the Seagate NAS firmware pre-installed and there is no easy way to re-install the Seagate NAS firmware after you install Debian. We therefore suggest you create a disk image before you install Debian. This warning does not apply to the Seagate NAS (2-Bay and 4-Bay) on which the original Seagate software can be re-installed with a web interface even after you format the disk.


Post by qwertyjjj » I did not set it up, it comes with everything installed OOT

Who ever set it up for you should have the password info, they also would , or should have the original "disk image"
We therefore suggest you create a disk image before you install Debian.


If they did not make one, then they also did not know what they were doing, so you may have all sorts of unexpected problems.

This is probably a stripped down version of debian on a NAS OS device.

You don't seem to know much about the device, are you sure it is yours ? Or where did you get it ?

If it is a NAS 2 Bay and/or 4-Bay, there is another option:

Also from the Debian wiki :

This warning does not apply to the Seagate NAS (2-Bay and 4-Bay) on which the original Seagate software can be re-installed with a web interface even after you format the disk.



https://www.seagate.com/manuals/network-storage/seagate-personal-cloud/passwords/

There are many other models, of the Segate personal cloud NAS devices,
the password recovery varies, and you don't seem to know what model it
is,... in any event some search foo, could find the solution, with enough details.
I am sure the previous owner, or system owner/admin, has those details as well. Maybe contact them.
Last edited by GarryRicketson on 2017-10-20 00:36, edited 1 time in total.
"What we expect you have already Done"

Before doing anything, read the Debian documentation:
Debian Documentation
How to ask the smart way
Debian Foro Español
======================
For the Birds
User avatar
GarryRicketson
 
Posts: 4356
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Segate personal cloud cannot adjust transmission setting

Postby qwertyjjj » 2017-10-20 00:36

I bought it, I installed it, the software was factory installed already. When I said I did not set it up that was a bit misleading, I meant I did not install the ootb software. All you do is turn it in then setup a web login password and then go. It's not the same as any of the Linux passwords or logins available through cat /etc/passwd
Their support offers nothing for ssh access unfortunately
qwertyjjj
 
Posts: 13
Joined: 2008-06-05 14:16

Next

Return to Offtopic

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable