Any trouble by using DD's for V2P (Virtualbox)?

If it doesn't relate to Debian, but you still want to share it, please do it here

Any trouble by using DD's for V2P (Virtualbox)?

Postby bester69 » 2017-11-26 01:18

Someone recommend me Installing a virtual, and then moving to physicall with DD.

I did it , and it worked, I was wondering if it can come up or give into any trouble eventually with using just a "dd" comand as a method V2P.
I followed theses steps with success to get a V2P in virtualbox:

0 - Install System in a Virtualbox
1- Make available the virtual system disk in linux devices.

Code: Select all
sudo apt-get install qemu
sudo modprobe nbd max_part=16
sudo qemu-nbd -c /dev/nbd0 drive.vdi

2- Move virtual system to physical.
Code: Select all
sudo dd if=/dev/nbd0p1 |pv| sudo dd of=/dev/sda8  bs=4M

3- Made system bootable
Code: Select all
sudo mount -t ext4 /dev/sda8 /mnt
sudo mount --bind /dev /mn/dev
sudo mount --bind /proc /mn/proc
sudo mount --bind /sys /mn/sys
sudo chroot /mnt
grub-install /dev/sda

It worked very well my V2P test :roll:
bester69 wrote:You wont change my mind when I know Im right, Im not an ...
User avatar
Posts: 1643
Joined: 2015-04-02 13:15

Return to Offtopic

Who is online

Users browsing this forum: No registered users and 11 guests