Can't run Emulationstation! Please help!!!

If it doesn't relate to Debian, but you still want to share it, please do it here

Can't run Emulationstation! Please help!!!

Postby Awesomegamer656 » 2018-06-30 02:31

It keeps saying
Code: Select all
/opt/retropie/supplementary/emulationstation/emulationstation: error while loading shared libraries: libboost_date_time.so.1.55.0: cannot open shared object file: No such file or directory
can somebody figure out whats wrong?
My OS is Debian Stretch.
Should i just reinstall? :(
Last edited by Awesomegamer656 on 2018-07-02 16:31, edited 1 time in total.
my life sucks, so does my computer :.(
Awesomegamer656
 
Posts: 10
Joined: 2018-06-29 23:52

Re: Can't run Emulationstation! Please help!!!

Postby Awesomegamer656 » 2018-06-30 02:53

If somebody can help, please do!
my life sucks, so does my computer :.(
Awesomegamer656
 
Posts: 10
Joined: 2018-06-29 23:52

Re: Can't run Emulationstation! Please help!!!

Postby bw123 » 2018-06-30 10:33

try this, there are several good emulators in the repo.
https://wiki.debian.org/Emulator

...
My OS is Debian Stretch


If you add things from outside the repo, then at some point it stops being debian stretch.

https://wiki.debian.org/DontBreakDebian
User avatar
bw123
 
Posts: 3532
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Can't run Emulationstation! Please help!!!

Postby sunrat » 2018-06-30 22:19

I suspect you are using a Raspberry Pi. The Debian version on the Emulationstation website is not for that. Try the Pi version and try the Pi forums for assistance. I doubt anyone here has any experience with Emulationstation.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2473
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Can't run Emulationstation! Please help!!!

Postby stevepusser » 2018-06-30 22:57

You neglected to let us know how you installed it, anyway. A brief search at packages.debian.org will let you know what package has your missing Boost library, too.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Cinnamon 3.8, Midori 6.0
User avatar
stevepusser
 
Posts: 10136
Joined: 2009-10-06 05:53

Re: Can't run Emulationstation! Please help!!!

Postby Awesomegamer656 » 2018-07-02 16:27

but it says "Your keyword was too generic, for optimizing reasons some results might have been suppressed. Please consider using a longer keyword or more keywords." And yes i am using raspberry pi
my life sucks, so does my computer :.(
Awesomegamer656
 
Posts: 10
Joined: 2018-06-29 23:52

Re: Can't run Emulationstation! Please help!!!

Postby stevepusser » 2018-07-02 17:34

https://packages.debian.org/search?sear ... e&arch=any

Hmmm--it's compiled on Jessie or an Ubuntu version that used Boost 1.55. Stretch has 1.62. They really need to recompile it against the current releases to make it compatible, or you can do it yourself if you have the emulationstation sources...or you can "forwardport" (rebuild and install the Jessie sources) Boost 1.55 on your current system...but that might be pretty hard on a Pi. Let me see if I can build the armhf (pi) packages in the cloud on the openSUSE build service.

Edit: OBS packages are cooking https://build.opensuse.org/package/show ... time1.55.0 armv71 gets translated to armhf packages for Debian.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Cinnamon 3.8, Midori 6.0
User avatar
stevepusser
 
Posts: 10136
Joined: 2009-10-06 05:53

Re: Can't run Emulationstation! Please help!!!

Postby Awesomegamer656 » 2018-07-02 18:09

i went to synaptic package manager and it said i had broken packages, so i tried to fix them but it said
Code: Select all
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies
my life sucks, so does my computer :.(
Awesomegamer656
 
Posts: 10
Joined: 2018-06-29 23:52

Re: Can't run Emulationstation! Please help!!!

Postby stevepusser » 2018-07-02 18:10

Aaaand the 1.55 builds fail with the newer gcc 6 compiler in Stretch. I could add a repo for the Jessie vintage gcc-4.9 compiler to that one and tweak the build to use that one instead, but now you're talking a lot more time. Perhaps you can add the Jessie repo and install the 1.55 packages from it...I think other people have been successful doing that.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Cinnamon 3.8, Midori 6.0
User avatar
stevepusser
 
Posts: 10136
Joined: 2009-10-06 05:53

Re: Can't run Emulationstation! Please help!!!

Postby stevepusser » 2018-07-02 18:11

Awesomegamer656 wrote:i went to synaptic package manager and it said i had broken packages, so i tried to fix them but it said
Code: Select all
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies


I already asked how you installed Emulationstation, which has a direct bearing on this message...
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Cinnamon 3.8, Midori 6.0
User avatar
stevepusser
 
Posts: 10136
Joined: 2009-10-06 05:53

Re: Can't run Emulationstation! Please help!!!

Postby Awesomegamer656 » 2018-07-02 18:14

my life sucks, so does my computer :.(
Awesomegamer656
 
Posts: 10
Joined: 2018-06-29 23:52

Re: Can't run Emulationstation! Please help!!!

Postby debiman » 2018-07-02 19:30

This is a guide for everything you need to install EmulationStation on a fresh Raspbian Wheezy install.
so, are you doing this on a raspbian wheezy install?
otherwise it might break your system...

please show us:
Code: Select all
cat /etc/*release*
cat /etc/*issue*
apt-get update
User avatar
debiman
 
Posts: 3027
Joined: 2013-03-12 07:18

Re: Can't run Emulationstation! Please help!!!

Postby Awesomegamer656 » 2018-07-02 20:26

debiman wrote:
This is a guide for everything you need to install EmulationStation on a fresh Raspbian Wheezy install.
so, are you doing this on a raspbian wheezy install?
otherwise it might break your system...

please show us:
Code: Select all
cat /etc/*release*
cat /etc/*issue*
apt-get update


PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
NAME="Debian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
my life sucks, so does my computer :.(
Awesomegamer656
 
Posts: 10
Joined: 2018-06-29 23:52

Re: Can't run Emulationstation! Please help!!!

Postby stevepusser » 2018-07-02 21:18

Some more research shows that site you referenced is old, abandoned, and broken, and Emulationstation development has been forked and updated by the RetroPie project. So if you convert your install to RetroPie per their instructions, or do a fresh install, you should get the program by default.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Cinnamon 3.8, Midori 6.0
User avatar
stevepusser
 
Posts: 10136
Joined: 2009-10-06 05:53


Return to Offtopic

Who is online

Users browsing this forum: Starborn and 4 guests

fashionable