aptitude kaput at my end

If it doesn't relate to Debian, but you still want to share it, please do it here

aptitude kaput at my end

Postby Job » 2018-10-05 13:22

aptitude for updating/upgrading gives me the following:

Code: Select all
dpkg: warning: 'ldconfig' not found in PATH or not executable

and
Code: Select all
dpkg: warning: 'start-stop-daemon' not found in PATH or executable


path should usually contain /usr/local/sbin, /usr/sbin, and /sbin

I have followed some guides from other people who had/have similar issues, particularly people using ubuntu. I have not been able to fix my issue. My troubles are most likely sitting with "libc6" and "libc-bin". My next try is to grab those from experimental but I am hesitating waiting to see if something will change. After all I am using buster. Has anyone else experienced this issue?

Merci.
#aptitude install life
--------------------------------------------------------------------------------------------------------------
Stretch - Devuan - Jessie (Media Center, yes, believe it)
User avatar
Job
 
Posts: 786
Joined: 2006-12-30 20:20
Location: no clue

Re: aptitude kaput at my end

Postby stevepusser » 2018-10-05 17:20

Sounds like you have created your very own FrankenDebian. We can't help you if you don't let us know exactly what you did following the Ubuntu advice, though.

The easiest way to fix this would be to restore from your backup of the last known sane working state of your system.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kdenlive 18.08.1, Pale Moon 28.1.0, wine-staging 3.17, qBittorrent 4.1.3, Liquorix kernel 4.18-13, Audacity 2.3.0
User avatar
stevepusser
 
Posts: 10004
Joined: 2009-10-06 05:53

Re: aptitude kaput at my end

Postby 4D696B65 » 2018-10-05 17:27

Code: Select all
su
changed to
Code: Select all
su -
else you will get those path errors
User avatar
4D696B65
 
Posts: 2200
Joined: 2009-06-28 06:09

Re: aptitude kaput at my end

Postby debiman » 2018-10-05 19:19

obviously, you should try to install the packages conteining these executables, and/or check your path and/or check permissions (you are running dpkg with elevated privileges?).

also, these are just warnings.
something actually not working?

Job wrote:My troubles are most likely sitting with "libc6" and "libc-bin".

if you know this already, then you also know that you likely broke your system. or so i'm told: libc problems are hard to fix.
User avatar
debiman
 
Posts: 2900
Joined: 2013-03-12 07:18

Re: aptitude kaput at my end

Postby Job » 2018-10-14 04:07

debiman wrote:obviously, you should try to install the packages conteining these executables, and/or check your path and/or check permissions (you are running dpkg with elevated privileges?).

also, these are just warnings.
something actually not working?

Job wrote:My troubles are most likely sitting with "libc6" and "libc-bin".

if you know this already, then you also know that you likely broke your system. or so i'm told: libc problems are hard to fix.


:cry:

Steve, I did not add any Ubuntu stuff on my machine. I follow the guide without going outside of Debian packages.
#aptitude install life
--------------------------------------------------------------------------------------------------------------
Stretch - Devuan - Jessie (Media Center, yes, believe it)
User avatar
Job
 
Posts: 786
Joined: 2006-12-30 20:20
Location: no clue

Re: aptitude kaput at my end

Postby Job » 2018-10-14 04:13

4D696B65 wrote:
Code: Select all
su
changed to
Code: Select all
su -
else you will get those path errors


Code: Select all
su -
set me straight. Thanks a bunch.
#aptitude install life
--------------------------------------------------------------------------------------------------------------
Stretch - Devuan - Jessie (Media Center, yes, believe it)
User avatar
Job
 
Posts: 786
Joined: 2006-12-30 20:20
Location: no clue

Re: aptitude kaput at my end

Postby debiman » 2018-10-14 13:07

Job wrote:
Code: Select all
su -
set me straight. Thanks a bunch.

oh!
so that was the solution?
fwiw, i have long since set an alias for su:
Code: Select all
alias su='su -'
User avatar
debiman
 
Posts: 2900
Joined: 2013-03-12 07:18

Re: aptitude kaput at my end

Postby Job » 2018-10-14 17:29

My solution is to stick with
Code: Select all
su -
. I re-installed guilty packages but that did not work.
#aptitude install life
--------------------------------------------------------------------------------------------------------------
Stretch - Devuan - Jessie (Media Center, yes, believe it)
User avatar
Job
 
Posts: 786
Joined: 2006-12-30 20:20
Location: no clue

Re: aptitude kaput at my end

Postby stevepusser » 2018-10-14 18:06

Since everyone else that's running Stretch doesn't have your problem, I find it very hard to believe that you don't have a broken system. You installed packages from Debian testing or Sid on Stretch--is that true or not?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kdenlive 18.08.1, Pale Moon 28.1.0, wine-staging 3.17, qBittorrent 4.1.3, Liquorix kernel 4.18-13, Audacity 2.3.0
User avatar
stevepusser
 
Posts: 10004
Joined: 2009-10-06 05:53

Re: aptitude kaput at my end

Postby llivv » 2018-10-14 20:03

4D696B65 wrote:
Code: Select all
su
changed to
Code: Select all
su -
else you will get those path errors

Thanks 4D696B65
su -
worked for me as well in the situation I posted here viewtopic.php?f=19&t=138837

if you can link to or point to and explaination of why su - finds the command paths or why su -c'command' no longer finds them?
I can see some of my bash scripts possibly failing in the near future.
in the kitchen with Julia
The Past, Christmas Present and Future
Get on the Dbus to Bcan
User avatar
llivv
 
Posts: 5617
Joined: 2007-02-14 18:10
Location: cold storage

Re: aptitude kaput at my end

Postby 4D696B65 » 2018-10-14 21:21

llivv wrote:Thanks 4D696B65
su -
worked for me as well in the situation I posted here viewtopic.php?f=19&t=138837

if you can link to or point to and explaination of why su - finds the command paths or why su -c'command' no longer finds them?
I can see some of my bash scripts possibly failing in the near future.


http://forums.debian.net/viewtopic.php?f=5&t=138290&p=678703#p678703
User avatar
4D696B65
 
Posts: 2200
Joined: 2009-06-28 06:09

Re: aptitude kaput at my end

Postby Job » 2018-10-15 16:45

stevepusser wrote:Since everyone else that's running Stretch doesn't have your problem, I find it very hard to believe that you don't have a broken system. You installed packages from Debian testing or Sid on Stretch--is that true or not?


Sorry to disappoint but since I upgraded from Stretch to Buster I haven't played such games. I really don't need any package that requires downstream or upstream.
#aptitude install life
--------------------------------------------------------------------------------------------------------------
Stretch - Devuan - Jessie (Media Center, yes, believe it)
User avatar
Job
 
Posts: 786
Joined: 2006-12-30 20:20
Location: no clue

Re: aptitude kaput at my end

Postby stevepusser » 2018-10-15 16:56

if you're running Debian testing instead of a release, you should make that clear in the first sentence or title of your first post; not leave it to be discovered ten posts in. I assume you're running a released version in the absence of that information. Not everyone is going to have read every single post of yours where you started using testing, either.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kdenlive 18.08.1, Pale Moon 28.1.0, wine-staging 3.17, qBittorrent 4.1.3, Liquorix kernel 4.18-13, Audacity 2.3.0
User avatar
stevepusser
 
Posts: 10004
Joined: 2009-10-06 05:53

Re: aptitude kaput at my end

Postby Job » 2018-10-16 15:54

stevepusser wrote:if you're running Debian testing instead of a release, you should make that clear in the first sentence or title of your first post; not leave it to be discovered ten posts in. I assume you're running a released version in the absence of that information. Not everyone is going to have read every single post of yours where you started using testing, either.


Steve, I did but I am guessing like all of us you read too fast. Check the last line of my original post.
#aptitude install life
--------------------------------------------------------------------------------------------------------------
Stretch - Devuan - Jessie (Media Center, yes, believe it)
User avatar
Job
 
Posts: 786
Joined: 2006-12-30 20:20
Location: no clue

Re: aptitude kaput at my end

Postby stevepusser » 2018-10-16 17:48

OK, I missed that, but really, you should make it clear in the thread title or in the first line of the post that you're running a development version, not a released version.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kdenlive 18.08.1, Pale Moon 28.1.0, wine-staging 3.17, qBittorrent 4.1.3, Liquorix kernel 4.18-13, Audacity 2.3.0
User avatar
stevepusser
 
Posts: 10004
Joined: 2009-10-06 05:53

Next

Return to Offtopic

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable