devuan upgrade error

If it doesn't relate to Debian, but you still want to share it, please do it here

devuan upgrade error

Postby arabianights » 2019-01-02 18:38

hi,

i've run into this error when i tried to upgrade from devuan jessice to ascii a while ago (March 24th):

Code: Select all
root@debian:/home/erdos# apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
initscripts : Depends: sysv-rc or file-rc but it is not installable libncurses5
: Depends: libtinfo5 (= 5.9+20140913-1+b1) but 6.0+20161126-1+deb9u1 is installed sysvinit-core
: Depends: sysv-rc or file-rc but it is not installable sysvinit-utils
: Depends: init-system-helpers (>= 1.25~) but 1.24+devuan1.0 is installed E: Unmet dependencies. Try using -f.


after reboot the system, i can only log into command line, but my home directory is not mounted, wifi is not working.

my laptop is thinkpad t60 with wifi built in.

this seems to be some init messed up when Devuan ascii was still in beta testing, now that ASCII has been released. is there a way to recover the system without reinstallation?
arabianights
 
Posts: 52
Joined: 2011-02-07 06:15

Re: devuan upgrade error

Postby golinux » 2019-01-02 19:07

Have you read the ASCII release notes? Are you using deb.devuan.org in your sources.list? This is not really the place for troubleshooting Devuan. Please come to the Devuan forum or irc channels.
May the FORK be with you!
User avatar
golinux
 
Posts: 1432
Joined: 2010-12-09 00:56
Location: not a 'buntard!


Return to Offtopic

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable