How to turn off desktop timeout

If it doesn't relate to Debian, but you still want to share it, please do it here

How to turn off desktop timeout

Postby jjanderson5 » 2020-02-07 22:59

I'm running Crunchbang Helium, a derivative of Debian, on a home computer. I often work at my desk, yes pencil and paper, and on the computer at the same time. My session keeps timing out. I did a search on the internet and found documentation that said to add the lines:

export TMOUT=0
typeset -r TMOUT

to the file /etc/profile.

I have done this and re-booted, and have also tried setting my login session TMOUT environment variable to 0. No luck, it keeps timing out. Can someone help me to turnoff the timeout? BTW, I am the only one with access to the computer, so security is not an issue.

Jim A.
jjanderson5
 
Posts: 16
Joined: 2014-09-10 01:58

Re: How to turn off desktop timeout

Postby Chrisdb » 2020-02-08 10:25

Are you talking about Shell or session timeout?
For the latter (X Window System) turn blanking off:
Code: Select all
xset s off

https://wiki.debian.org/Openbox#Screen_locking
Chrisdb
 
Posts: 273
Joined: 2018-04-10 07:16

Re: How to turn off desktop timeout

Postby Head_on_a_Stick » 2020-02-08 10:36

jjanderson5 wrote:I'm running Crunchbang Helium, a derivative of Debian

Go ask on their forums then, you have been told this seven times now and yet you still pollute these boards with your crap.

Please **** off.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12823
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: How to turn off desktop timeout

Postby trinidad » 2020-02-08 13:58

Thank you HoaS ! Got my morning chuckle.

TC
You can't believe your eyes if your imagination is out of focus.
trinidad
 
Posts: 142
Joined: 2016-08-04 14:58

Re: How to turn off desktop timeout

Postby jjanderson5 » 2020-02-10 02:41

After reviewing this issue again, I respectfully submit to you that this thread is not off topic. At its root, the problem is that I do not know, and it is not well documented, how a desktop session times out in Debian/Linux. I submit to you that this is an issue for ANY desktop running on top of the Debian/Linux operating system. It is not limited to Crunchbang and openbox.

The one guy claims that I should be posting at Crunchbang. Maybe he is correct. I have seen him post many times and I'm grateful that he has answered my questions and others in the past. But he is very rude! Instead of complaining about my posting to the wrong forum, he might do better to ask me why I posted at Debian and not at Crunchbang. Maybe I have a valid reason for posting here! Or maybe I am wrong and I need to be educated.

My participation in the UNIX/Linux community goes back a long way and my experience has been very positive. I hope my friend will take a step back and think about his last response to me. I'm here because I love working on Linux and I like that the vast majority of those I meet are trying to help each other. He mentions that he has advised me in the past about where to post. In some of those cases, he may have been correct, I don't remember. But I do know, that is some of the cases, just like this one, I disagree.

I am happy to explain my thinking.

I suspect the source of the problem is that the kernel is sending a signal that a session timeout has occurred. If I am correct, I need to know how to turn off the signal. Since this is kernel territory, the post belongs at the Debian User Forum, probably in the kernel forum, but the desktop forum is arguably also appropriate because the desktop is generally the receiver of the signal.

@tinidad
I would appreciate if you would move this thread back into at area where you think that it is on topic. I would still go with the desktop forum, but I am fine if it is in the kernel topic. In either case, I have not solved the problem yet, and I would appreciated any help that I can get.

If you disagree, please explain why.
jjanderson5
 
Posts: 16
Joined: 2014-09-10 01:58

Re: How to turn off desktop timeout

Postby jjanderson5 » 2020-02-10 02:47

@chrisdb

First, in my opinion, I would call the timeout a 'session timeout'. Technically, the session does not end, but the view of the session changes to a login page when the timeout occurs.

Thank you for the suggestion regarding "xset s off". I tried that, but no luck. My session still returned to the login screen after a period of time.

I saw your link to some documentation. I have not read it yet, but I will be reading it as soon as I get a chance.

Regards,
Jim A.
jjanderson5
 
Posts: 16
Joined: 2014-09-10 01:58

Re: How to turn off desktop timeout

Postby dilberts_left_nut » 2020-02-10 05:31

You are running a derivative, not Debian, your support questions should go there.

Locked.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 5082
Joined: 2009-10-05 07:54
Location: enzed


Return to Offtopic

Who is online

Users browsing this forum: No registered users and 17 guests

fashionable