dpkg not found problem (SOLVED>

If it doesn't relate to Debian, but you still want to share it, please do it here

dpkg not found problem (SOLVED>

Postby Rick B. » 2020-03-17 13:40

I am running a distro based on Debian 9 Stretch and trying to install an archived version of Libre Office ( Can anyone tell me what is wrong here:

Code: Select all
$ sudo dpkg‭ ‬-i‭ *‬.deb
sudo: dpkg‭: command not found

I have checked through Synaptic and dpkg is installed. I have installed LibreOffice many times before without a problem in Ubuntu and Debian based distros.I simply don't get it. Any ideas? Thanks.

Code: Select all
  Host: rick-testing Kernel: 4.19.0-5-amd64 x86_64
  bits: 64 Desktop: MATE 1.16.2
  Distro: MX-18.3_x64 Continuum May 26  2019
  Type: Laptop System: LENOVO product: 41786UU
  v: ThinkPad T420 serial: <root required>
  Mobo: LENOVO model: 41786UU serial: <root required>
  UEFI [Legacy]: LENOVO v: 83ET57WW (1.27 )
  date: 05/17/2011
  ID-1: BAT0 charge: 42.2 Wh
  condition: 42.6/44.0 Wh (97%)
  Topology: Dual Core model: Intel Core i5-2520M
  bits: 64 type: MT MCP L2 cache: 3072 KiB
  Speed: 1641 MHz min/max: 800/3200 MHz
  Core speeds (MHz): 1: 797 2: 797 3: 797 4: 797
  Device-1: Intel 2nd Generation Core Processor Family
  Integrated Graphics
  driver: i915 v: kernel
  Display: x11 server: X.Org 1.19.2
  driver: modesetting unloaded: fbdev,vesa
  resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile
  v: 3.3 Mesa 18.2.6
  Device-1: Intel 6 Series/C200 Series Family High
  Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k4.19.0-5-amd64
  Device-1: Intel 82579LM Gigabit Network
  driver: e1000e
  IF: eth0 state: up speed: 100 Mbps duplex: full
  mac: 00:21:cc:63:69:98
  Device-2: Intel Centrino Advanced-N 6205 [Taylor
  driver: iwlwifi
  IF: wlan0 state: down mac: 06:dc:81:8d:45:e5
  Local Storage: total: 465.76 GiB
  used: 27.30 GiB (5.9%)
  ID-1: /dev/sda vendor: Toshiba model: MK5075GSX
  size: 465.76 GiB
  ID-1: / size: 114.11 GiB used: 27.30 GiB (23.9%)
  fs: ext4 dev: /dev/sda4
  System Temperatures: cpu: 37.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 3238
  Processes: 191 Uptime: 47m Memory: 3.74 GiB
  used: 1.18 GiB (31.4%) Shell: bash inxi: 3.0.33
Last edited by Rick B. on 2020-07-02 15:02, edited 1 time in total.
Rick B.
Posts: 35
Joined: 2011-11-09 20:30
Location: Central Florida, USA

Re: dpkg not found problem

Postby milomak » 2020-03-29 20:31

apt-cache policy dpkg
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
Posts: 2081
Joined: 2009-06-09 22:20

Re: dpkg not found problem

Postby Head_on_a_Stick » 2020-03-29 20:40

@milomak: the OP is using MX Linux and they haven't bothered answering the questions on the thread they started there so they're unlikely to reply here.

Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Return to Offtopic

Who is online

Users browsing this forum: No registered users and 8 guests