wget and Windows OS problem.

If it doesn't relate to Debian, but you still want to share it, please do it here

wget and Windows OS problem.

Postby hack3rcon » 2020-08-27 09:45

Hello,
I used below command to download a whole website for reading it as oofline:
Code: Select all
$ wget --level=inf --recursive --page-requisites --user-agent=Mozilla --no-parent --convert-links --adjust-extension --no-clobber -e robots=off "URL"

But, some the files contain forbidden printable ASCII characters like "?", ":", "*" and Windows can't open them. How can I solve it?

Thank you.
hack3rcon
 
Posts: 471
Joined: 2015-02-16 09:54

Re: wget and Windows OS problem.

Postby sickpig » 2020-08-27 11:21

hack3rcon wrote:How can I solve it?

Human sacrifice.
User avatar
sickpig
 
Posts: 589
Joined: 2019-01-23 10:34

Re: wget and Windows OS problem.

Postby cuckooflew » 2020-08-27 17:10

Ask Bill Gates, or one of his fan boys at a MS windows forum.
Use some logic, maybe the website you are scraping does not want bots scraping it and has some parts protected, to keep the bots from scraping it and using the material else where.
The OP is not even willing to try searching, they are a broken bot , using a broken OS, so they probably will never know:
Warning: some antivirus tools recognise wget-1.20.3-win32.zip as potentially dangerous. The file that triggers the warning is wget.exe.debug, which contains debugging symbols for wget.exe, and isn't even executable. If your AV is giving you trouble, and you don't need the documentation or debug symbols, you can download wget.exe directly, or switch to a less broken security product.

The only bot that really does good searches is the google bot, it can solve anything that has a solution.
Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
and
Just say NO to help vampires!
cuckooflew
 
Posts: 683
Joined: 2018-05-10 19:34
Location: Some where out west

Re: wget and Windows OS problem.

Postby Head_on_a_Stick » 2020-08-27 17:33

sickpig wrote:Human sacrifice.

I vote we sacrifice the OP :mrgreen:
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12770
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: wget and Windows OS problem.

Postby RU55EL » 2020-08-28 15:55

hack3rcon wrote:Hello,
I used below command to download a whole website for reading it as oofline:
Code: Select all
$ wget --level=inf --recursive --page-requisites --user-agent=Mozilla --no-parent --convert-links --adjust-extension --no-clobber -e robots=off "URL"

But, some the files contain forbidden printable ASCII characters like "?", ":", "*" and Windows can't open them. How can I solve it?


1) Delete the Windows operating system.

2) Install Debian

Problem solved.
User avatar
RU55EL
 
Posts: 498
Joined: 2014-04-07 03:42
Location: /home/russel

Re: wget and Windows OS problem.

Postby reinob » 2020-08-28 17:42

hack3rcon wrote:Hello,
I used below command to download a whole website for reading it as oofline:
Code: Select all
$ wget --level=inf --recursive --page-requisites --user-agent=Mozilla --no-parent --convert-links --adjust-extension --no-clobber -e robots=off "URL"

But, some the files contain forbidden printable ASCII characters like "?", ":", "*" and Windows can't open them. How can I solve it?

Thank you.


You really don't read any manuals do you?

Check with "man wget". I promise you will find the necessary option, if you can read at all.
If you REALLY can't find it in the manual page, then ask again, but really, it IS there.
reinob
 
Posts: 857
Joined: 2014-06-30 11:42


Return to Offtopic

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable