iwd install error

If it doesn't relate to Debian, but you still want to share it, please do it here

iwd install error

Postby eiger3970 » 2021-01-14 04:17

Code: Select all
root@proxmox:/home# dpkg -i /var/cache/apt/archives/iwd_0.14-2_amd64.deb
(Reading database ... 44237 files and directories currently installed.)
Preparing to unpack .../archives/iwd_0.14-2_amd64.deb ...
Unpacking iwd (0.14-2) over (0.14-2) ...
Setting up iwd (0.14-2) ...
Job for iwd.service failed because the control process exited with error code.
See "systemctl status iwd.service" and "journalctl -xe" for details.
Processing triggers for dbus (1.12.20-0+deb10u1) ...
root@proxmox:/home# systemctl status iwd.service
● iwd.service - Wireless service
   Loaded: loaded (/lib/systemd/system/iwd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2021-01-14 14:41:45 AEST; 3min 2s ago
  Process: 19722 ExecStart=/usr/libexec/iwd (code=exited, status=127)
 Main PID: 19722 (code=exited, status=127)

Jan 14 14:41:45 proxmox systemd[1]: iwd.service: Service RestartSec=100ms expired, scheduling restart.
Jan 14 14:41:45 proxmox systemd[1]: iwd.service: Scheduled restart job, restart counter is at 5.
Jan 14 14:41:45 proxmox systemd[1]: Stopped Wireless service.
Jan 14 14:41:45 proxmox systemd[1]: iwd.service: Start request repeated too quickly.
Jan 14 14:41:45 proxmox systemd[1]: iwd.service: Failed with result 'exit-code'.
Jan 14 14:41:45 proxmox systemd[1]: Failed to start Wireless service.
root@proxmox:/home# journalctl -xe
--
-- A start job for unit pvesr.service has begun execution.
--
-- The job identifier is 5103.
Jan 14 14:44:00 proxmox systemd[1]: pvesr.service: Succeeded.
-- Subject: Unit succeeded
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The unit pvesr.service has successfully entered the 'dead' state.
Jan 14 14:44:00 proxmox systemd[1]: Started Proxmox VE replication runner.
-- Subject: A start job for unit pvesr.service has finished successfully
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit pvesr.service has finished successfully.
--
-- The job identifier is 5103.
Jan 14 14:45:00 proxmox systemd[1]: Starting Proxmox VE replication runner...
-- Subject: A start job for unit pvesr.service has begun execution
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit pvesr.service has begun execution.
--
-- The job identifier is 5158.
Jan 14 14:45:00 proxmox systemd[1]: pvesr.service: Succeeded.
-- Subject: Unit succeeded
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The unit pvesr.service has successfully entered the 'dead' state.
Jan 14 14:45:00 proxmox systemd[1]: Started Proxmox VE replication runner.
-- Subject: A start job for unit pvesr.service has finished successfully
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit pvesr.service has finished successfully.
--
-- The job identifier is 5158.
eiger3970
 
Posts: 10
Joined: 2021-01-14 04:16

Re: iwd install error

Postby eiger3970 » 2021-01-14 04:52

I purged the iwd package and configuration files and tried a fresh install, however error:
Code: Select all
root@proxmox:/var/cache/apt/archives# systemctl status iwd.service
● iwd.service - Wireless service
   Loaded: loaded (/lib/systemd/system/iwd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2021-01-14 15:29:34 AEST; 1min 15s ago
  Process: 25184 ExecStart=/usr/libexec/iwd (code=exited, status=127)
 Main PID: 25184 (code=exited, status=127)

Jan 14 15:29:34 proxmox systemd[1]: iwd.service: Service RestartSec=100ms expired, scheduling restart.
Jan 14 15:29:34 proxmox systemd[1]: iwd.service: Scheduled restart job, restart counter is at 5.
Jan 14 15:29:34 proxmox systemd[1]: Stopped Wireless service.
Jan 14 15:29:34 proxmox systemd[1]: iwd.service: Start request repeated too quickly.
Jan 14 15:29:34 proxmox systemd[1]: iwd.service: Failed with result 'exit-code'.
Jan 14 15:29:34 proxmox systemd[1]: Failed to start Wireless service.
root@proxmox:/var/cache/apt/archives# journalctl -xe
--
-- A start job for unit pvesr.service has begun execution.
--
-- The job identifier is 7970.
Jan 14 15:30:00 proxmox systemd[1]: pvesr.service: Succeeded.
-- Subject: Unit succeeded
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The unit pvesr.service has successfully entered the 'dead' state.
Jan 14 15:30:00 proxmox systemd[1]: Started Proxmox VE replication runner.
-- Subject: A start job for unit pvesr.service has finished successfully
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit pvesr.service has finished successfully.
--
-- The job identifier is 7970.
Jan 14 15:31:00 proxmox systemd[1]: Starting Proxmox VE replication runner...
-- Subject: A start job for unit pvesr.service has begun execution
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit pvesr.service has begun execution.
--
-- The job identifier is 8025.
Jan 14 15:31:00 proxmox systemd[1]: pvesr.service: Succeeded.
-- Subject: Unit succeeded
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The unit pvesr.service has successfully entered the 'dead' state.
Jan 14 15:31:00 proxmox systemd[1]: Started Proxmox VE replication runner.
-- Subject: A start job for unit pvesr.service has finished successfully
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit pvesr.service has finished successfully.
--
-- The job identifier is 8025.
eiger3970
 
Posts: 10
Joined: 2021-01-14 04:16

Re: iwd install error

Postby eiger3970 » 2021-01-14 09:08

I have purged iwd_0.14-2_amd64.deb libell0_0.35-1_amd64.deb wpasupplicant_2.7+git20190128+0c1e29f-6+deb10u2_amd64.deb, however unlike 1st install, there are no error prompts for the missing libraries?
Code: Select all
root@proxmox:/var/cache/apt/archives# ls
iwd_0.14-2_amd64.deb  libell0_0.35-1_amd64.deb   wpasupplicant_2.7+git20190128+0c1e29f-6+deb10u2_amd64.deb

I think I will try just wpasupplicant as an install.
eiger3970
 
Posts: 10
Joined: 2021-01-14 04:16

Re: iwd install error

Postby Head_on_a_Stick » 2021-01-14 11:34

The iwd version in buster is pre-release so you probably shouldn't use it but it will install for me in buster. You should ask Proxmox why their system is broken.

Thread moved to Offtopic, Proxmox is not supported here.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13241
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: iwd install error

Postby eiger3970 » 2021-01-15 08:21

Thank you.
I came here as per the error message pointing me to debian support.
No response on the Proxmox forum.
I'll try wpa_supplicant as a work around.
eiger3970
 
Posts: 10
Joined: 2021-01-14 04:16

Re: iwd install error

Postby Head_on_a_Stick » 2021-01-15 18:32

eiger3970 wrote:I came here as per the error message pointing me to debian support.

Bastards... :x
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13241
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: iwd install error

Postby eiger3970 » 2021-01-17 03:08

Gave up on Wi-Fi NIC on Debian based Proxmox.
Trying a bridge now.
If that fails, I'll install a Debian OS on machine1 and probably be back.
eiger3970
 
Posts: 10
Joined: 2021-01-14 04:16


Return to Offtopic

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable