update VSCodium on a Linux-System - doing on console

If it doesn't relate to Debian, but you still want to share it, please do it here

update VSCodium on a Linux-System - doing on console

Postby say_hello » 2021-01-15 00:23

dear community


i am running MX-Linux 19.2 - and i have installed VSCodium

currently i run: vscodium: 1.47.3

the newest vscodium ist : 1.52.1


i want to update to the newest version of vscodium: found a manual - here:


https://www.google.com/search?ei=Y9MAYM ... kgXFnZFQ13

i guess that i can run the following steps:

1. add gpg-key of the repository

2. add the repository

3. update then install vscodium
Code: Select all
bash: get-pip.py: Kommando nicht gefunden.
root@mx:/home/martin#
root@mx:/home/martin# wget -qO - https://gitlab.com/paulcarroty/vscodium-deb-rpm-repo/raw/master/pub.gpg | sudo apt-key add -
OK
root@mx:/home/martin# echo 'deb https://gitlab.com/paulcarroty/vscodium-deb-rpm-repo/raw/repos/debs/ vscodium main' | sudo tee --append /etc/apt/sources.list.d/
tee: /etc/apt/sources.list.d/: Ist ein Verzeichnis
deb https://gitlab.com/paulcarroty/vscodium-deb-rpm-repo/raw/repos/debs/ vscodium main
root@mx:/home/martin# sudo apt update && sudo apt install codium
Holen:1 http://deb.debian.org/debian buster-updates InRelease [51,9 kB]
Holen:2 http://ftp.halifax.rwth-aachen.de/mxlinux/packages/mx/repo buster InRelease [19,8 kB]
OK:3 http://dl.google.com/linux/chrome/deb stable InRelease
OK:4 http://deb.debian.org/debian buster InRelease
Holen:5 http://deb.debian.org/debian-security buster/updates InRelease [65,4 kB]
OK:6 https://packages.microsoft.com/repos/vscode stable InRelease
Fehl:7 https://gitlab.com/paulcarroty/vscodium-deb-rpm-repo/raw/repos/debs vscodium InRelease
429  Too Many Requests [IP: 172.65.251.78 443]
Holen:8 https://packagecloud.io/AtomEditor/atom/any any InRelease [23,2 kB]
Holen:9 http://deb.debian.org/debian-security buster/updates/main amd64 Packages [261 kB]
Holen:10 http://ftp.halifax.rwth-aachen.de/mxlinux/packages/mx/repo buster/main amd64 Packages [423 kB]
Holen:11 http://deb.debian.org/debian-security buster/updates/main i386 Packages [260 kB]
Holen:12 http://deb.debian.org/debian-security buster/updates/main Translation-en [143 kB]
Holen:13 http://ftp.halifax.rwth-aachen.de/mxlinux/packages/mx/repo buster/main i386 Packages [416 kB]
Holen:14 https://packagecloud.io/AtomEditor/atom/any any/main amd64 Packages [41,7 kB]
Es wurden 1.704 kB in 4 s geholt (415 kB/s).
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Aktualisierung für 3 Pakete verfügbar. Führen Sie »apt list --upgradable« aus, um sie anzuzeigen.
W: Fehlschlag beim Holen von https://gitlab.com/paulcarroty/vscodium-deb-rpm-repo/raw/repos/debs/dists/vscodium/InRelease 429  Too Many Requests [IP: 172.65.251.78 443]
W: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
codium ist schon die neueste Version (1.47.3-1595933476).
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
gir1.2-gstreamer-1.0 gir1.2-javascriptcoregtk-4.0 gir1.2-soup-2.4 libdbusmenu-qt5-2 libfam0
libgssdp-1.0-3 libgstreamer-plugins-bad1.0-0 libgupnp-1.0-4 libgupnp-igd-1.0-4 libicu67
libjavascriptcoregtk-4.0-18 libkf5activities5 libkf5archive5 libkf5attica5 libkf5auth-data
libkf5auth5 libkf5bookmarks-data libkf5bookmarks5 libkf5codecs-data libkf5codecs5
libkf5completion-data libkf5completion5 libkf5config-data libkf5configcore5 libkf5configgui5
    libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5
libkf5crash5 libkf5dbusaddons-data libkf5dbusaddons5 libkf5doctools5 libkf5globalaccel-bin
libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5
libkf5i18n-data libkf5i18n5 libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data
libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5js5 libkf5jsapi5
libkf5kexiv2-15.0.0 libkf5kiocore5 libkf5kiontlm5 libkf5kiowidgets5 libkf5notifications-data
libkf5parts-data libkf5pty-data libkf5pty5 libkf5service-bin libkf5service-data libkf5service5
libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5
libkf5textwidgets-data libkf5textwidgets5 libkf5threadweaver5 libkf5wallet-data
libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5
libkf5xmlgui-data libkf5xmlgui5 libmicrodns0 libmjpegutils-2.1-0 libmms0 libmodplug1
libmpeg2encpp-2.1-0 libmplex2-2.1-0 libmwaw-0.3-3 libnice10 libnumbertext-1.0-0
libnumbertext-data libofa0 liborcus-0.14-0 libphonon4qt5-4 libpolkit-qt5-1-1 libqca-qt5-2
libqmobipocket2 libqt5script5 libqt5texttospeech5 libreoffice-avmedia-backend-gstreamer
libspandsp2 libsrtp2-1 libvo-aacenc0 libvo-amrwbenc0 libwildmidi2 libxmlsec1 libxmlsec1-nss
libzbar0 python3-distro python3-pypdf2 xsel yelp-xsl
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 3 nicht aktualisiert.
root@mx:/home/martin#

User avatar
say_hello
 
Posts: 26
Joined: 2019-10-13 09:58

Return to Offtopic

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable