Update libjpeg?

New to Debian (Or Linux in general)? Ask your questions here!

Update libjpeg?

Postby Swedish_newbie » 2013-03-06 11:43

I have problems with converting jpeg-images with ImageMagick, and i noticed that i have an old version of libjpeg (6.2).
It seems that there aren't any new version for Debian, yet? Am i right?

If not, how can i update/upgrade the library?
Thanks in advance!
Swedish_newbie
 
Posts: 36
Joined: 2012-06-08 12:33
Location: Orebro, Sweden

Re: Update libjpeg?

Postby roseway » 2013-03-06 15:18

Eric

Debian Testing, KDE
User avatar
roseway
 
Posts: 1301
Joined: 2007-12-31 22:50
Location: Kent, UK

Sv: Update libjpeg?

Postby Swedish_newbie » 2013-03-06 18:27


I tried that, but it still says that i have version 6.

Skickat från min GT-I9300 via Tapatalk 2
Swedish_newbie
 
Posts: 36
Joined: 2012-06-08 12:33
Location: Orebro, Sweden

Re: Update libjpeg?

Postby Swedish_newbie » 2013-03-06 21:02

I tried to remove libjpeg62, and then install libjpeg8, but it seems that i stil have both. :shock:
root@jupiter:~# find /usr | grep "libjpeg"
/usr/lib/libjpeg.so.8
/usr/lib/libjpeg.so.8.0.2
/usr/lib/libjpeg.so.62
/usr/lib/libjpeg.so.62.0.0
/usr/share/doc/libjpeg62
/usr/share/doc/libjpeg62/copyright
/usr/share/doc/libjpeg62/changelog.gz
/usr/share/doc/libjpeg62/README.gz
/usr/share/doc/libjpeg62/changelog.Debian.gz
/usr/share/doc/libjpeg8
/usr/share/doc/libjpeg8/copyright
/usr/share/doc/libjpeg8/changelog.gz
/usr/share/doc/libjpeg8/README.gz
/usr/share/doc/libjpeg8/changelog.Debian.gz
Swedish_newbie
 
Posts: 36
Joined: 2012-06-08 12:33
Location: Orebro, Sweden

Re: Update libjpeg?

Postby stevepusser » 2013-03-07 03:37

It's normal to have both versions in Squeeze. Some packages depend on the older version, and some the newer libjpeg8.

In Squeeze, the 62 version supplies the default "libjpeg-dev", but it's provided by libjpeg8-dev in Wheezy.
stevepusser
 
Posts: 3508
Joined: 2009-10-06 05:53

Re: Update libjpeg?

Postby Swedish_newbie » 2013-03-07 10:34

stevepusser wrote:It's normal to have both versions in Squeeze. Some packages depend on the older version, and some the newer libjpeg8.

In Squeeze, the 62 version supplies the default "libjpeg-dev", but it's provided by libjpeg8-dev in Wheezy.

Ok! But "convert -list format" says that i´m still using the old version instead of version 8.
How to fix that?

JPEG* JPEG rw- Joint Photographic Experts Group JFIF format (62)
JPG* JPEG rw- Joint Photographic Experts Group JFIF format (62)
Swedish_newbie
 
Posts: 36
Joined: 2012-06-08 12:33
Location: Orebro, Sweden

Re: Update libjpeg?

Postby stevepusser » 2013-03-07 16:08

I guess that the Squeeze version of Imagemagick was compiled against the older version's headers (the -dev package), so it uses that. Possibly rebuilding the packages against libjpeg8-dev would get it to use the newer version. The alternative is to upgrade to Wheezy and use the program there.

Let me know if you're running 32 or 64-bit, and I'll rebuild the imagemagick packages against the newer libjpeg for you, and see if that works.
stevepusser
 
Posts: 3508
Joined: 2009-10-06 05:53

Sv: Update libjpeg?

Postby Swedish_newbie » 2013-03-07 17:07

My server runs with 64 bit.

Is there any SAFE way to upgrade to wheezy?

Skickat från min GT-I9300 via Tapatalk 2
Swedish_newbie
 
Posts: 36
Joined: 2012-06-08 12:33
Location: Orebro, Sweden

Re: Update libjpeg?

Postby stevepusser » 2013-03-08 02:44

It turns out that many of the -dev packages needed to build imagemagick also depend on libjpeg62-dev, and we can't have both that and libjpeg8-dev installed (the apt system has them conflict with each other).

Exactly what problem are you having with converting jpeg images? It seems to me this might be solved without changing any packages, since I think it would be a big bug that would have popped up before, since Squeeze has been out so long.
stevepusser
 
Posts: 3508
Joined: 2009-10-06 05:53

Sv: Update libjpeg?

Postby Swedish_newbie » 2013-03-08 10:47

I have problem with smeard lines on most of my jpeg-files.

Skickat från min GT-I9300 via Tapatalk 2
Swedish_newbie
 
Posts: 36
Joined: 2012-06-08 12:33
Location: Orebro, Sweden

Sv: Update libjpeg?

Postby Swedish_newbie » 2013-03-08 22:54

Any suggestions?

Skickat från min GT-I9300 via Tapatalk 2
Swedish_newbie
 
Posts: 36
Joined: 2012-06-08 12:33
Location: Orebro, Sweden

Re: Update libjpeg?

Postby stevepusser » 2013-03-09 01:51

Well, I'm stumped, unless you can provide a sample of a file that gives the trouble and the convert command used on it. Then someone running wheezy can check to see it the problem is gone there.

Anyone else have any ideas?
stevepusser
 
Posts: 3508
Joined: 2009-10-06 05:53


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable