[Solved|workaround]Broken dependencies wheezy upgrade

New to Debian (Or Linux in general)? Ask your questions here!

[Solved|workaround]Broken dependencies wheezy upgrade

Postby use_another_name » 2013-05-06 09:25

Hi,

today i broke my system.

In my progress to upgrade|destroy my squeeze system to wheezy i did the following steps:
1. update to the latest squeeze updates
2. change my sources.list to:
#mozilla
deb http://mozilla.debian.net/ squeeze-backports iceweasel-release icedove-esr
deb http://www.deb-multimedia.org wheezy main non-free
#backports
deb http://backports.debian.org/debian-backports squeeze-backports main non-free


#wheezy
deb http://ftp.us.debian.org/debian/ wheezy main contrib non-free
deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb http://ftp.debian.org/debian/ wheezy-backports main contrib non-free

3.apt-get update & apt-get upgrade
4.apt-get dist-upgrade
and thats where the errors beginn:
apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
brasero : Depends: libbrasero-media3-1 (= 3.4.1-4) but it is not installed
Depends: libnautilus-extension1a (>= 2.91) but it is not installed
Depends: libtracker-sparql-0.14-0 (>= 0.10.0) but it is not installed
cheese : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
Depends: libgnome-desktop-3-2 (>= 3.2.0) but it is not installed
Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.30-1 is installed
empathy : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.30-1 is installed
Depends: libwebkitgtk-3.0-0 (>= 1.3.10) but it is not installed
Recommends: telepathy-haze but it is not installed
Recommends: sound-theme-freedesktop but it is not installed
epiphany-browser : Depends: libseed-gtk3-0 but it is not installed
Depends: libwebkitgtk-3.0-0 (>= 1.7.92) but it is not installed
epiphany-extensions : Depends: libwebkitgtk-3.0-0 (>= 1.3.10) but it is not installed
evince : Depends: libevdocument3-4 (= 3.4.0-3.1) but it is not installed
Depends: libevview3-3 (= 3.4.0-3.1) but it is not installed
Depends: libnautilus-extension1a (>= 2.91) but it is not installed
Depends: evince-common (>= 3.4) but 2.30.3-2+squeeze1 is installed
file-roller : Depends: libnautilus-extension1a (>= 2.91) but it is not installed
Depends: nautilus-data (>= 3.0) but 2.30.1-2squeeze2 is installed
gdm3 : Depends: libaccountsservice0 (>= 0.6.8) but it is not installed
Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
Depends: gir1.2-glib-2.0 but it is not installed
Depends: gnome-session-bin (>= 3.4.2.1-4~) but 2.30.2-3 is installed
Depends: metacity (>= 1:2.34.2) but 1:2.30.1-3 is installed
Depends: accountsservice (>= 0.6.12) but it is not installed
Depends: libglib2.0-bin (>= 2.26) but it is not installed
Depends: dconf-tools (>= 0.12.1-2) but it is not installed
Recommends: at-spi2-core but it is not installed
Recommends: gnome-icon-theme-symbolic but it is not installed
gir1.2-atk-1.0 : Depends: gir1.2-glib-2.0 but it is not installed
gir1.2-freedesktop : Depends: gir1.2-glib-2.0 (= 1.32.1-1) but it is not installed
gir1.2-gdkpixbuf-2.0 : Depends: gir1.2-glib-2.0 but it is not installed
gir1.2-gnomebluetooth-1.0 : Depends: gir1.2-glib-2.0 but it is not installed
gir1.2-gtk-3.0 : Depends: gir1.2-glib-2.0 but it is not installed
gir1.2-pango-1.0 : Depends: gir1.2-glib-2.0 but it is not installed
gnome-applets : Depends: libgucharmap-2-90-7 (>= 1:3.0.0) but it is not installed
Depends: gnome-applets-data (>= 3.4) but 2.30.0-3 is installed
Depends: gir1.2-gconf-2.0 but it is not installed
Depends: gir1.2-panelapplet-4.0 but it is not installed
gnome-bluetooth : Depends: gir1.2-glib-2.0 but it is not installed
gnome-control-center : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
Depends: libgnome-desktop-3-2 (>= 3.2.0) but it is not installed
Depends: libgnomekbd7 (>= 2.91.91) but it is not installed
Depends: libpolkit-gobject-1-0 (>= 0.99) but 0.96-4+squeeze2 is installed
Depends: libsocialweb-client2 (>= 0.25.3) but it is not installed
Depends: libwacom2 (>= 0.6) but it is not installed
Depends: accountsservice but it is not installed
Depends: apg but it is not installed
Depends: gnome-control-center-data (< 1:3.5) but it is not installed
Depends: gnome-control-center-data (>= 1:3.4.3.1-2) but it is not installed
Depends: gnome-desktop3-data but it is not installed
Depends: gnome-icon-theme-symbolic but it is not installed
Depends: gnome-menus (>= 3.0) but 2.30.3-1 is installed
Recommends: gnome-online-accounts but it is not installed
gnome-dictionary : Depends: libgdict-1.0-6 (= 3.4.0-2) but 2.30.0-2 is installed
gnome-disk-utility : Depends: libavahi-ui-gtk3-0 (>= 0.6.30) but it is not installed
Depends: libgdu-gtk0 (>= 3.0.0) but 2.30.1-2 is installed
Depends: libnautilus-extension1a (>= 2.91) but it is not installed
Depends: libunique-3.0-0 (>= 2.90.1) but it is not installed
gnome-keyring : Depends: libgck-1-0 (>= 3.3.90) but it is not installed
gnome-orca : Depends: gir1.2-wnck-3.0 but it is not installed
Depends: python-pyatspi2 but it is not installed
Depends: python-speechd but it is not installed
Depends: speech-dispatcher but it is not installed
Recommends: xbrlapi but it is not installed
gnome-panel : Depends: libedataserverui-3.0-1 (>= 3.4.4) but it is not installed
Depends: libgnome-desktop-3-2 (>= 3.2.0) but it is not installed
Depends: gnome-icon-theme-symbolic (>= 3.0.0) but it is not installed
Depends: gnome-panel-data (= 3.4.2.1-4) but 2.30.2-2 is installed
Depends: gnome-menus (>= 3.1.4) but 2.30.3-1 is installed
Recommends: gnome-session-fallback but it is not installed
gnome-session : Depends: gnome-shell (>= 3.0) but it is not installed
Depends: gnome-session-bin (>= 3.4.2.1-4) but 2.30.2-3 is installed
Recommends: gnome-session-fallback but it is not installed
gnome-settings-daemon : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
Depends: libgnome-desktop-3-2 (>= 3.4.0) but it is not installed
Depends: libgnomekbd7 (>= 2.91.90) but it is not installed
Depends: libpackagekit-glib2-14 but it is not installed
Depends: libpolkit-gobject-1-0 (>= 0.99) but 0.96-4+squeeze2 is installed
Depends: libwacom2 (>= 0.6) but it is not installed
Depends: nautilus-data (>= 2.91.3-1) but 2.30.1-2squeeze2 is installed
Recommends: pulseaudio but it is not installed
gnome-user-share : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
Depends: libnautilus-extension1a (>= 2.91) but it is not installed
grub2-common : Depends: grub-common (= 1.99-27+deb7u1) but 1.98+20100804-14+squeeze1 is installed
gstreamer0.10-gconf : Depends: libgstreamer0.10-0 (>= 0.10.36) but 0.10.30-1 is installed
gstreamer0.10-nice : Depends: libgstreamer0.10-0 (>= 0.10.35.2-2) but 0.10.30-1 is installed
gstreamer0.10-plugins-bad : Depends: libgstreamer0.10-0 (>= 0.10.36) but 0.10.30-1 is installed
gstreamer0.10-plugins-base : Depends: libgstreamer0.10-0 (>= 0.10.36) but 0.10.30-1 is installed
gstreamer0.10-plugins-good : Depends: libgstreamer0.10-0 (>= 0.10.36) but 0.10.30-1 is installed
gstreamer0.10-x : Depends: libgstreamer0.10-0 (>= 0.10.36) but 0.10.30-1 is installed
hamster-applet : Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
krb5-multidev : Depends: libgssrpc4 (= 1.10.1+dfsg-5) but 1.8.3+dfsg-4squeeze6 is installed
Depends: libkadm5srv-mit8 (= 1.10.1+dfsg-5) but it is not installed
Depends: libkadm5clnt-mit8 (= 1.10.1+dfsg-5) but it is not installed
libalgorithm-diff-xs-perl : Depends: perl (>= 5.14.2-3) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libavcodec54 : Depends: libva1 (> 1.0.15~) but 1.0.7-0.0 is installed
libcairo-perl : Depends: perl (>= 5.14.2-9) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libcheese-gtk21 : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
libcheese3 : Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.30-1 is installed
libdatetime-perl : Depends: perl (>= 5.14.2-11) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libfarstream-0.1-0 : Depends: libgstreamer0.10-0 (>= 0.10.33) but 0.10.30-1 is installed
libgcr-3-1 : Depends: libgck-1-0 (>= 3.3.90) but it is not installed
libgl1-mesa-dri : Depends: libdrm-nouveau1a (>= 2.4.23) but it is not installed
libglib-perl : Depends: perl (>= 5.14.2-10) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libgoa-1.0-0 : Depends: libwebkitgtk-3.0-0 (>= 1.3.10) but it is not installed
libgstreamer-plugins-bad0.10-0 : Depends: libgstreamer0.10-0 (>= 0.10.36) but 0.10.30-1 is installed
libgstreamer-plugins-base0.10-0 : Depends: libgstreamer0.10-0 (>= 0.10.36) but 0.10.30-1 is installed
libgtk2-perl : Depends: perl (>= 5.14.2-11) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libhtml-parser-perl : Depends: perl (>= 5.14.2-9) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
liblist-moreutils-perl : Depends: perl (>= 5.14.2-3) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libnet-dbus-perl : Depends: perl (>= 5.14.2-3) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libpango-perl : Depends: perl (>= 5.14.2-3) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libparams-classify-perl : Depends: perl (>= 5.14.2-4) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libparams-util-perl : Depends: perl (>= 5.14.2-9) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libparams-validate-perl : Depends: perl (>= 5.14.2-7) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libperl5.14 : Depends: perl-base (= 5.14.2-21) but 5.10.1-17squeeze6 is installed
libpolkit-agent-1-0 : Depends: libpolkit-gobject-1-0 (>= 0.105) but 0.96-4+squeeze2 is installed
libpolkit-backend-1-0 : Depends: libpolkit-gobject-1-0 (>= 0.104) but 0.96-4+squeeze2 is installed
libpurple0 : Depends: perl-base (>= 5.14.2-18) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
libpython2.6 : Depends: python2.6 (= 2.6.8-1.1) but 2.6.6-8+b1 is installed
librhythmbox-core6 : Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.30-1 is installed
Depends: libpeas-1.0-0 (>= 1.0.0) but it is not installed
Depends: libwebkitgtk-3.0-0 (>= 1.3.10) but it is not installed
libuuid-perl : Depends: perl-base (>= 5.14.2-14) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
nautilus : Depends: libgnome-desktop-3-2 (>= 3.2.0) but it is not installed
Depends: libnautilus-extension1a (>= 2.91) but it is not installed
Depends: libtracker-sparql-0.14-0 (>= 0.10.0) but it is not installed
Depends: nautilus-data (>= 3.4) but 2.30.1-2squeeze2 is installed
Recommends: gnome-sushi but it is not installed
nautilus-sendto : Depends: libedataserverui-3.0-1 (>= 3.4.3) but it is not installed
nautilus-sendto-empathy : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
Depends: libgck-1-0 (>= 2.91.1) but it is not installed
Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.30-1 is installed
Depends: libwebkitgtk-3.0-0 (>= 1.3.10) but it is not installed
network-manager : Depends: libpolkit-gobject-1-0 (>= 0.99) but 0.96-4+squeeze2 is installed
Recommends: crda but it is not installed
notification-daemon : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
perl-modules : Depends: perl (>= 5.14.2-1) but 5.10.1-17squeeze6 is installed
perlmagick : Depends: perl (>= 5.14.2-15) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
pidgin : Depends: perl-base (>= 5.14.2-18) but 5.10.1-17squeeze6 is installed
Depends: perlapi-5.14.2
policykit-1 : Depends: libpolkit-gobject-1-0 (>= 0.101) but 0.96-4+squeeze2 is installed
policykit-1-gnome : Depends: libpolkit-gobject-1-0 (>= 0.99) but 0.96-4+squeeze2 is installed
python-dbus : Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
python-gi : Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
Depends: gir1.2-glib-2.0 (>= 1.31.0) but it is not installed
python-gnome2 : Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
python-gobject-2 : Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
python-gtk2 : Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
python-gtkglext1 : Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
python-opengl : Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
rhythmbox : Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.30-1 is installed
Depends: libpeas-1.0-0 (>= 1.0.0) but it is not installed
Recommends: gstreamer0.10-pulseaudio but it is not installed
rhythmbox-plugin-cdrecorder : Depends: libbrasero-media3-1 (>= 3.0.0) but it is not installed
rhythmbox-plugins : Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.30-1 is installed
Depends: libmtp9 (>= 1.1.0) but it is not installed
Depends: libpeas-1.0-0 (>= 1.0.0) but it is not installed
Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
Depends: gir1.2-rb-3.0 (= 2.97-2.1) but it is not installed
Depends: gir1.2-glib-2.0 but it is not installed
Depends: gir1.2-webkit-3.0 but it is not installed
Depends: gir1.2-gconf-2.0 but it is not installed
Depends: gir1.2-peas-1.0 but it is not installed
Depends: gir1.2-gnomekeyring-1.0 but it is not installed
Depends: gir1.2-gstreamer-0.10 but it is not installed
Depends: zeitgeist-core but it is not installed
samba : Depends: samba-common (= 2:3.6.6-6) but 2:3.5.6~dfsg-3squeeze9 is installed
Recommends: tdb-tools but it is not installed
sound-juicer : Depends: libbrasero-media3-1 (>= 2.91.91) but it is not installed
Depends: libcanberra-gtk3-0 (>= 0.25) but it is not installed
Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.30-1 is installed
tomboy : Depends: libdbus-glib1.0-cil (>= 0.5) but it is not installed
Depends: libdbus1.0-cil (>= 0.7) but it is not installed
Depends: libglib2.0-cil (>= 2.12.10-1ubuntu1) but 2.12.10-1 is installed
Depends: libgmime2.6-cil (>= 2.6.0) but it is not installed
Depends: libgtk2.0-cil (>= 2.12.10-1ubuntu1) but 2.12.10-1 is installed
Depends: libmono-addins-gui0.2-cil (>= 0.6) but 0.4-8 is installed
Depends: libmono-addins0.2-cil (>= 0.6) but 0.4-8 is installed
Depends: libmono-cairo4.0-cil (>= 2.10.1) but it is not installed
Depends: libmono-posix4.0-cil (>= 2.10.1) but it is not installed
Depends: libmono-system-core4.0-cil (>= 2.10.3) but it is not installed
totem : Depends: libnautilus-extension1a (>= 2.91) but it is not installed
Depends: libpeas-1.0-0 (>= 1.0.0) but it is not installed
Depends: libtotem0 (>= 3.0.1-8) but it is not installed
Depends: libtotem0 (< 3.1) but it is not installed
Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
Depends: gnome-icon-theme-symbolic but it is not installed
Depends: totem-common (= 3.0.1-8) but 2.30.2-6 is installed
Recommends: gstreamer0.10-pulseaudio but it is not installed
totem-plugins : Depends: libepc-1.0-3 (>= 0.4.2) but it is not installed
Depends: libepc-ui-1.0-3 (>= 0.4.2) but it is not installed
Depends: libgdata13 (>= 0.8.1) but it is not installed
Depends: libtotem0 (>= 3.0.1-8) but it is not installed
Depends: libtotem0 (< 3.1) but it is not installed
Depends: libtracker-sparql-0.14-0 (>= 0.10.0) but it is not installed
Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
Depends: gir1.2-totem-1.0 (= 3.0.1-8) but it is not installed
Depends: gir1.2-glib-2.0 but it is not installed
Depends: gir1.2-peas-1.0 but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies


any help?
Thank you all
Last edited by use_another_name on 2013-05-06 13:48, edited 1 time in total.
use_another_name
 
Posts: 2
Joined: 2013-05-06 08:58

Re: Broken dependencies wheezy upgrade

Postby kiyop » 2013-05-06 12:21

First of all, comment out
use_another_name wrote:
deb http://backports.debian.org/debian-backports squeeze-backports main non-free

and
Code: Select all
apt-get update
dpkg --configure -a
apt-get -f install
apt-get -f dist-upgrade


use_another_name wrote:
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Have you set some packages as held?

Have you read the following (Wheezy Release Note: 4.2. Checking system status) before starting upgrade?
http://www.debian.org/releases/wheezy/i ... tem-status (for i386)

The following (4.5. Possible issues during upgrade) may help you.
http://www.debian.org/releases/wheezy/i ... ml#trouble (for i386)
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: Broken dependencies wheezy upgrade

Postby use_another_name » 2013-05-06 13:46

it is too late now ..
first at all i made a backup
then i installed a clean new debian,
after all its a desktop so most of my configuartions are in /home/
use_another_name
 
Posts: 2
Joined: 2013-05-06 08:58

Re: [Solved|workaround]Broken dependencies wheezy upgrade

Postby kiyop » 2013-05-06 14:18

Congratulations! :)
It is nice that you made a back-up before upgrading. :)

Clean install takes shorter time than recovering after wrong operation for newbies.
I hope that nobody starts upgrading from squeeze to wheezy before reading the release note of Wheezy.
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: [Solved|workaround]Broken dependencies wheezy upgrade

Postby Praxis » 2013-05-07 09:42

Warning: The following is more of a rant fueled by a lot of frustration than a useful comment. Read it only if you are having trouble sleeping or enjoy flame-bait.

I am not sure reinstalling really counts as "Solved."

I did pretty much everything mentioned in the release notes, updated Squeeze, removed cruft, did an 'apt-get upgrade' followed by an 'apt-get dist-upgrade' from init 3, and my system broke badly. I mean, it broke so badly that even vim wouldn't work, I had to fall back on nano. It seemed like the system wouldn't upgrade because of previously installed versions were still there, a sample line of output:

Depends: empathy-common (= 3.4.2.3-2) but 2.30.3-1 is installed

When I tried to use The Force (apt-get -f install) apt practically laughed at me. I enabled the Squeeze repos again, as well, as suggested. Nothing. ' dpkg --configure --pending' kicked the ball down the road a bit, but failed to get it significantly closer to the goal. Adding the poorly explained "-o APT::Force-LoopBreak=1" to the apt-get didn't do squat. At this point it was getting early & I was getting desperate so I tried a bunch of "dpkg -r --force-depends package_name" working my way through a BUNCH of Gnome packages from the bottom, up, but still didn't get too far. I had used some official Backports in Squeeze and the mozilla.debian.net iceweasel packages. I guess there is still no wheezy-backports, so those repositories didn't update when I ran my "apt-get update" before upgrading. Anyway, I disabled wheezy-backports & mozilla-debian and removed the Squeeze repositories again and tried The Force again and apt churned away, apparently actually replacing some Squeeze packages with Wheezy ones. When it ended I tried another round of "apt-get upgrade" (which completed without complaining the first time). I have no idea when or if it will throw up its "hands" again and choke. It is removing compiz, a fairly bog-standard package. I guess if the upgrade comes out the other end without severely wedging apt/dpkg I can reinstall the purged packages. Its not like I actually WANT Gnome3 anyway. At least "cat /etc/debian_version" is reporting I now have Debian 7.0.

And I think how comparatively smoothly my Ubuntu Lucid to Precise LTS upgrades went. And how much easier the CLI-fu that I was expected to use to upgrade. With Ubuntu increasing LTS support from 3 years to 5 years the charm of Debian Stable is starting to be lost on me. With testing at least you have a rolling release. And you expect occasional breakage, especially after the thaw.

Of course, it is my fault for upgrading to the next stable version within a week of Wheezy going gold. Ubuntu recommends that you wait until the X.X.1 release before upgrading LTS versions. Let someone else be the Guinea Pig.

EDIT: I stayed up until stupid in the morning, but the last update churned through. I did a "ls /boot" and found that the system only had the old 2.6 kernel so I had to hand-install the 3.2.0.4 kernel and headers with apt. I rebooted and mostly the system was OK, even the nvidia driver was installed, and Gnome seemed to be "working" (whatever that is for Gnome3) with nautilus despite me having removed it. Sound is dead. Initially in KDE it only offered me the option of using the digital HDMI hardware and seemed to have forgotten the analog stuff that I actually use. I played around a bit and rebooted and now just get Dummy Output in the mixers in Gnome, XFCE & KDE. I'm sure I can sort it out eventually, I've had many, many sound issues with Debian, both stable and testing, far, far more than with Ubuntu. I mean, stable is supposed to be just that, and I've had sound die for no apparent reason, perhaps after a routine "apt-get update" or something. And I had to Google my butt off to get it working again.

My take-away:
Debian, please don't release until it is ready! That means not just that there are only few unsquashed mission-critical bugs in a fresh server install. It also should mean enough testing has been done so that someone without extremely specialized technical skills can upgrade a crufty old system that started as Lenny and was upgraded to Squeeze and has multiple desktop environments, proprietary drivers and multimedia packages (folks want to be able to use their hardware and consume media). And for Dog's sake, if some cluster-embrace like Secure Boot comes along, don't release until you can handle it reliably. A date is just a number, release dates doubly so. Of course, if Debian is really just a server OS then ignore all that. Let people who use their computers as desktop PCs look elsewhere, Ubuntu, opensuse, etc.

I have to say, since Ubuntu increased its support period for LTS releases to 5 years I have not installed Debian on anything that I could get Ubuntu working on (except for a a new machine install for a friend who really wanted testing). But I have several machines that are still running Debian. I'm going to wait at least 8 months before I try to upgrade my home server from Squeeze to Wheezy. The last round of upgrades went much more smoothly because I loved Lenny (and KDE 3.5) and didn't upgrade until almost a year after Squeeze came along and support for Lenny was ending. Still, as I recall, it was almost always a flail. Linux can be hard to upgrade if you go much beyond the default package set. But it can be done. I've upgraded a half dozen or so Lucid systems to Precise with hardly a problem (after I borked the first one by trying to use the Debian method to upgrade with apt-get rather than the approved Ubuntu "do-release-upgrade"). And all of those systems have continued to be rock-stable for the non-technical users who are using them, not suddenly forgetting their sound settings.

I love that fact that Debian is around, but I may be pretty much done with stable as a desktop OS except for legacy installs, we'll have to see how the next couple of upgrade go. Sure, I've been using Linux almost exclusively for 8 years so I can get it to work, probably, it is just upgrading Debian stable more trouble than it is worth on the desktop if you stray too far from the default set of applications. It is not that I mind the stodgy packages. Part of the reason I installed stable on multiple boxen was that it held on to familiar desktop environmnets like KDE3.5 and Gnome2 so long. But if every 2 years I have to face a grueling ordeal upgrading it just isn't worth it. I've abandoned many distros in the past because they just wouldn't upgrade reliably and the idea of doing a fresh install sticks in my craw even if it is easier and less crufty than upgrading. Still, I like the idea of a rolling release, so I'll probably stick with testing and endure its quirks, at least until Ubuntu introduces a rolling release channel.
User avatar
Praxis
 
Posts: 78
Joined: 2006-12-19 00:00


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable