failed to load module

New to Debian (Or Linux in general)? Ask your questions here!

failed to load module

Postby lucas » 2015-06-23 11:47

I'vd a problem with loading modules.
Booting gives the this error:
Code: Select all
lucas@debian8-1:~$ systemctl --failed
  UNIT                         LOAD   ACTIVE SUB    DESCRIPTION
● systemd-modules-load.service loaded failed failed Load Kernel Modules

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

1 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.
lucas@debian8-1:~$
ucas@debian8-1:~$ systemctl --failed
  UNIT                         LOAD   ACTIVE SUB    DESCRIPTION
● systemd-modules-load.service loaded failed failed Load Kernel Modules

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

1 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.
lucas@debian8-1:~$ systemdctl status systemd-modules-load.service
bash: systemdctl: command not found
lucas@debian8-1:~$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Tue 2015-06-23 12:53:00 CEST; 11min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 409 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 409 (code=exited, status=1/FAILURE)
lucas@debian8-1:~$


Always the same error when booting. After a period of time, (Graphical User Interface) the mouse click no longer operates, also text input isn't possible.
I had no access to the system at all, even crt alt F1 stopped working, also text input was no't possible. so reinstall was the only option.
Maybe there is a connection with this two errors.

I've reinstalled Debian 8 several times. Still, both errors stay.

The same happend again (in the GUI) is nothing possible, no txt input, no mouse click), but now I have access to the system, ctr/alt F1 is working.

thanks,
Lucas
You'll see it once you get it
lucas
 
Posts: 27
Joined: 2014-09-27 10:56
Location: Amsterdam

Re: failed to load module

Postby Head_on_a_Stick » 2015-06-23 18:50

Please post the output of:
Code: Select all
journalctl _PID=409

The PID may have changed since you posted so run `systemctl status systemd-modules-load.service` to check the PID of the failed unit and use that number in the above command.

You may need to add your user to the "systemd-journal" group to access `journalctl`
Code: Select all
# gpasswd -a lucas systemd-journal
# newgrp systemd-journal
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6804
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: failed to load module

Postby lucas » 2015-06-23 23:24

Hi,
Thank you for replying.
First: I think that the problem of freezing the GUI is caused by the radeon-card. Now I use to boot yaboot boot: Linux radeon.agpmode=-1 and the GUI is not freezing.

The error not loading:

Code: Select all
lucas@debian8-1:~$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Wed 2015-06-24 00:45:11 CEST; 18min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 390 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 390 (code=exited, status=1/FAILURE)
lucas@debian8-1:~$ sudo journalctl _PID=390
-- Logs begin at Wed 2015-06-24 00:45:03 CEST, end at Wed 2015-06-24 01:04:08 CEST. --
Jun 24 00:45:11 debian8-1 systemd-modules-load[390]: Failed to find module 'ppdev'
Jun 24 00:45:11 debian8-1 systemd-modules-load[390]: Failed to find module 'apm_emu'
lucas@debian8-1:~$


Journalctl: (a selection)

Code: Select all
Jun 24 00:45:03 debian8-1 kernel: time_init: decrementer frequency = 18.432000 MHz
Jun 24 00:45:03 debian8-1 kernel: time_init: processor frequency   = 1333.333330 MHz
Jun 24 00:45:03 debian8-1 kernel: clocksource: timebase mult[3640e38e] shift[24] registered
Jun 24 00:45:03 debian8-1 kernel: clockevent: decrementer mult[4b7f5a5] shift[32] cpu[0]
Jun 24 00:45:03 debian8-1 kernel: Console: colour dummy device 80x25
Jun 24 00:45:03 debian8-1 kernel: console [tty0] enabled
....
Jun 24 00:45:03 debian8-1 systemd-journal[147]: Journal started
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Inserted module 'lp'
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Failed to find module 'ppdev'
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Inserted module 'parport_pc'
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Inserted module 'fuse'
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Failed to find module 'apm_emu'
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Inserted module 'therm_adt746x'
Jun 24 00:45:03 debian8-1 systemd[1]: systemd-modules-load.service: main process exited, code=exited, status=
...
Jun 24 00:45:07 debian8-1 kernel: [drm] initializing kernel modesetting (RV350 0x1002:0x4E56 0x1002:0x4E56).
Jun 24 00:45:07 debian8-1 kernel: [drm] Forcing AGP to PCI mode
Jun 24 00:45:07 debian8-1 kernel: [drm] register mmio base: 0x90000000
Jun 24 00:45:07 debian8-1 kernel: [drm] register mmio size: 65536
Jun 24 00:45:07 debian8-1 kernel: radeon 0000:00:10.0: Invalid ROM contents
Jun 24 00:45:07 debian8-1 kernel: radeon 0000:00:10.0: Invalid ROM contents
Jun 24 00:45:07 debian8-1 kernel: [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
Jun 24 00:45:07 debian8-1 kernel: [drm] Using device-tree clock info
Jun 24 00:45:07 debian8-1 kernel: [drm] Generation 2 PCI interface, using max accessible memory
Jun 24 00:45:07 debian8-1 kernel: radeon 0000:00:10.0: VRAM: 128M 0x0000000098000000 - 0x000000009FFFFFFF (32
Jun 24 00:45:07 debian8-1 kernel: radeon 0000:00:10.0: GTT: 512M 0x0000000078000000 - 0x0000000097FFFFFF
Jun 24 00:45:07 debian8-1 kernel: [drm] Detected VRAM RAM=128M, BAR=128M
Jun 24 00:45:07 debian8-1 kernel: [drm] RAM width 64bits DDR
Jun 24 00:45:07 debian8-1 kernel: [TTM] Zone  kernel: Available graphics memory: 380658 kiB
Jun 24 00:45:07 debian8-1 kernel: [TTM] Zone highmem: Available graphics memory: 773874 kiB
Jun 24 00:45:07 debian8-1 kernel: [TTM] Initializing pool allocator
Jun 24 00:45:07 debian8-1 kernel: [drm] radeon: 32M of VRAM memory ready
Jun 24 00:45:07 debian8-1 kernel: [drm] radeon: 512M of GTT memory ready.
...
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Failed to find module 'ppdev'
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Inserted module 'parport_pc'
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Inserted module 'fuse'
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Failed to find module 'apm_emu'
Jun 24 00:45:03 debian8-1 systemd-modules-load[130]: Inserted module 'therm_adt746x'
Jun 24 00:45:03 debian8-1 systemd[1]: systemd-modules-load.service: main process exited, code=exited, status=
Jun 24 00:45:03 debian8-1 systemd[1]: Failed to start Load Kernel Modules.
Jun 24 00:45:03 debian8-1 systemd[1]: Unit systemd-modules-load.service entered failed state.
Jun 24 00:45:03 debian8-1 systemd[1]: Mounted Configuration File System.
...
 24 00:45:07 debian8-1 kernel: [drm] register mmio size: 65536
Jun 24 00:45:07 debian8-1 kernel: radeon 0000:00:10.0: Invalid ROM contents
Jun 24 00:45:07 debian8-1 kernel: radeon 0000:00:10.0: Invalid ROM contents
Jun 24 00:45:07 debian8-1 kernel: [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
Jun 24 00:45:07 debian8-1 kernel: [drm] Using device-tree clock info
Jun 24 00:45:07 debian8-1 kernel: [drm] Generation 2 PCI interface, using max accessible memory
Jun 24 00:45:07 debian8-1 kernel: radeon 0000:00:10.0: VRAM: 128M 0x0000000098000000 - 0x000000009FFFFFFF (32
Jun 24 00:45:07 debian8-1 kernel: radeon 0000:00:10.0: GTT: 512M 0x0000000078000000 - 0x0000000097FFFFFF
Jun 24 00:45:07 debian8-1 kernel: [drm] Detected VRAM RAM=128M, BAR=128M
Jun 24 00:45:07 debian8-1 kernel: [drm] RAM width 64bits DDR
...
un 24 00:45:10 debian8-1 kernel: b43-phy0: Broadcom 4318 WLAN found (core revision 9)
Jun 24 00:45:10 debian8-1 kernel: appletouch 2-2:1.0: Geyser mode initialized.
Jun 24 00:45:10 debian8-1 kernel: input: appletouch as /devices/pci0001:10/0001:10:1a.0/usb2/2-2/2-2:1.0/inpu
Jun 24 00:45:10 debian8-1 kernel: b43-phy0: Found PHY: Analog 3, Type 2 (G), Revision 7
Jun 24 00:45:10 debian8-1 kernel: b43-phy0 warning: 5 GHz band is unsupported on this PHY
Jun 24 00:45:10 debian8-1 kernel: usbcore: registered new interface driver appletouch
Jun 24 00:45:10 debian8-1 kernel: Broadcom 43xx driver loaded [ Features: PMNLS ]
Jun 24 00:45:10 debian8-1 kbd[246]: Setting console screen modes.
Jun 24 00:45:10 debian8-1 kernel: b43 ssb0:0: firmware: direct-loading firmware b43/ucode5.fw
...
Jun 24 00:45:11 debian8-1 systemd[1]: Activating swap /dev/disk/by-uuid/0b4c781f-fc30-460f-b70f-dc89c552dc5b.
Jun 24 00:45:11 debian8-1 systemd[1]: Starting system-systemd\x2drfkill.slice.
Jun 24 00:45:11 debian8-1 systemd-modules-load[390]: Failed to find module 'ppdev'
Jun 24 00:45:11 debian8-1 systemd-modules-load[390]: Failed to find module 'apm_emu'
Jun 24 00:45:11 debian8-1 systemd[1]: Created slice system-systemd\x2drfkill.slice.
Jun 24 00:45:11 debian8-1 systemd[1]: Starting Load/Save RF Kill Switch Status of rfkill1...
Jun 24 00:45:11 debian8-1 systemd[1]: Starting Load/Save RF Kill Switch Status of rfkill0...
Jun 24 00:45:11 debian8-1 systemd[1]: systemd-modules-load.service: main process exited, code=exited, status=
Jun 24 00:45:11 debian8-1 systemd[1]: Failed to start Load Kernel Modules.
Jun 24 00:45:11 debian8-1 systemd[1]: Unit systemd-modules-load.service entered failed state.
Jun 24 00:45:11 debian8-1 systemd-journal[147]: Runtime journal is using 4.0M (max allowed 30.2M, trying to l
Jun 24 00:45:11 debian8-1 systemd[1]: Started Trigger Flushing of Journal to Persistent Storage.
Jun 24 00:45:11 debian8-1 systemd[1]: Mounted Configuration File System.
...
Jun 24 00:45:16 debian8-1 bluetoothd[510]: Bluetooth daemon 5.23
Jun 24 00:45:17 debian8-1 mouseemu[551]: mouseemu 0.15 (C) Colin Leroy <colin@colino.net>
Jun 24 00:45:17 debian8-1 mouseemu[551]: using (0+68) as middle button, (0+87) as right button, (56) as scrol
Jun 24 00:45:17 debian8-1 mouseemu[526]: Starting mouse emulation daemon: mouseemu.
Jun 24 00:45:17 debian8-1 pbbuttonsd[541]: INFO: Initialized: SysFS Backlight Driver
Jun 24 00:45:17 debian8-1 ModemManager[513]: <info>  ModemManager (version 1.4.0) starting in system bus...
Jun 24 00:45:18 debian8-1 kernel: input: Mouseemu virtual keyboard as /devices/virtual/input/input7
Jun 24 00:45:18 debian8-1 mouseemu[567]: Trying to open /dev/uinput...
Jun 24 00:45:18 debian8-1 mouseemu[567]: ok.
Jun 24 00:45:18 debian8-1 mouseemu[567]: Trying to open /dev/uinput...
Jun 24 00:45:18 debian8-1 mouseemu[567]: ok.
Jun 24 00:45:18 debian8-1 kernel: input: Mouseemu virtual mouse as /devices/virtual/input/input8
Jun 24 00:45:18 debian8-1 kdm[523]: Starting K Display Manager: kdm.
Jun 24 00:45:22 debian8-1 pbbuttonsd[528]: Starting pbbuttonsd:ERROR: Can't attach card 'default': No such fi
Jun 24 00:45:22 debian8-1 pbbuttonsd[541]: ERROR: Can't attach card 'default': No such file or directory
Jun 24 00:45:22 debian8-1 pbbuttonsd[528]: ERROR: Can't open mixer device [/dev/mixer]. No such file or direc
Jun 24 00:45:22 debian8-1 pbbuttonsd[541]: ERROR: Can't open mixer device [/dev/mixer]. No such file or direc
Jun 24 00:45:22 debian8-1 pbbuttonsd[541]: INFO: Soundsystem requested: auto, detected: ALSA and at least act
Jun 24 00:45:22 debian8-1 pbbuttonsd[541]: INFO: saving of config enabled to /etc/pbbuttonsd.conf.
Jun 24 00:45:22 debian8-1 pbbuttonsd[528]: pbbuttonsd 0.7.9: iBook G4 (Jul 2005) - PMU version: 12
Jun 24 00:45:22 debian8-1 pbbuttonsd[528]: pbbuttonsd 0.7.9: iBook G4 (Jul 2005) - PMU version: 12
Jun 24 00:45:22 debian8-1 pbbuttonsd[817]: INFO: pbbuttonsd 0.7.9: iBook G4 (Jul 2005) - PMU version: 12
Jun 24 00:45:22 debian8-1 pbbuttonsd[528]: .
Jun 24 00:45:23 debian8-1 avahi-daemon[533]: Successfully called chroot().
Jun 24 00:45:23 debian8-1 avahi-daemon[533]
...
 24 00:45:23 debian8-1 NetworkManager[515]: <info> VPN: loaded org.freedesktop.NetworkManager.pptp
Jun 24 00:45:23 debian8-1 NetworkManager[515]: <info> VPN: loaded org.freedesktop.NetworkManager.vpnc
Jun 24 00:45:24 debian8-1 NetworkManager[515]: <info> VPN: loaded org.freedesktop.NetworkManager.openvpn
Jun 24 00:45:24 debian8-1 kernel: Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Jun 24 00:45:24 debian8-1 kernel: Bluetooth: BNEP filters: protocol multicast
Jun 24 00:45:24 debian8-1 kernel: Bluetooth: BNEP socket layer initialized
Jun 24 00:45:24 debian8-1 dbus[534]: [system] Activating via systemd: service name='org.freedesktop.hostname1
Jun 24 00:45:24 debian8-1 bluetoothd[510]: Bluetooth management interface 1.6 initialized
Jun 24 00:45:24 debian8-1 bluetoothd[510]: Sap driver initialization failed.
Jun 24 00:45:24 debian8-1 bluetoothd[510]: sap-server: Operation not permitted (1)
Jun 24 00:45:24 debian8-1 systemd[1]: Starting Hostname Service...
Jun 24 00:45:25 debian8-1 polkitd[836]: started daemon version 0.105 using authority implementation `local' v
Jun 24 00:45:25 debian8-1 dbus[534]: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
Jun 24 00:45:25 debian8-1 systemd[1]: Started Authenticate and Authorize Users to Run Privileged Tasks.
Jun 24 00:45:25 debian8-1 NetworkManager[515]: <info> init!
Jun 24 00:45:25 debian8-1 NetworkManager[515]: <info> update_system_hostname
Jun 24 00:45:25 debian8-1 NetworkManager[515]: <info>       interface-parser: parsing file /etc/network/inter
Jun 24 00:45:25 debian8-1 NetworkManager[515]: <info>       interface-parser: source line includes interfaces
Jun 24 00:45:25 debian8-1 NetworkManager[515]: <warn> interfaces file /etc/network/interfaces.d/* doesn't exi
Jun 24 00:45:25 debian8-1 NetworkManager[515]: <info>       interface-parser: finished parsing file /etc/netw
Jun 24 00:45:25 debian8-1 NetworkManager[515]: <info> management mode: unmanaged
Jun 24 00:45:25 debian8-1 NetworkManager[515]: <info> devices added (path: /sys/devices/pci0001:10/0001:10:12
...
Jun 24 00:45:33 debian8-1 NetworkManager[515]: <info> Activation (wlan0) Stage 5 of 5 (IPv6 Commit) complete.
Jun 24 00:45:33 debian8-1 dbus[534]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jun 24 00:45:33 debian8-1 systemd[1]: Started Network Manager Script Dispatcher Service.
Jun 24 00:45:33 debian8-1 nm-dispatcher[928]: Dispatching action 'up' for wlan0
Jun 24 00:45:39 debian8-1 kdm_greet[924]: Cannot load /usr/share/kde4/apps/kdm/faces/.default.face: No such f
Jun 24 00:45:41 debian8-1 ModemManager[513]: <warn>  (ttyPZ1): serial port closing_wait was reset!
Jun 24 00:45:41 debian8-1 ModemManager[513]: <warn>  (ttyPZ1): couldn't set serial port closing_wait to none:
Jun 24 00:45:41 debian8-1 ModemManager[513]: <warn>  (ttyPZ0): serial port closing_wait was reset!
Jun 24 00:45:41 debian8-1 ModemManager[513]: <warn>  (ttyPZ0): couldn't set serial port closing_wait to none:
Jun 24 00:45:41 debian8-1 ModemManager[513]: <warn>  (ttyPZ1): couldn't set serial port closing_wait to none:
Jun 24 00:45:41 debian8-1 ModemManager[513]: <warn>  (ttyPZ0): couldn't set serial port closing_wait to none:
Jun 24 00:45:47 debian8-1 ModemManager[513]: <warn>  (ttyPZ1): serial port closing_wait was reset!
Jun 24 00:45:47 debian8-1 ModemManager[513]: <warn>  (ttyPZ1): couldn't set serial port closing_wait to none:
Jun 24 00:45:47 debian8-1 ModemManager[513]: <warn>  (ttyPZ0): serial port closing_wait was reset!
Jun 24 00:45:47 debian8-1 ModemManager[513]: <warn>  (ttyPZ0): couldn't set serial port closing_wait to none:
Jun 24 00:45:47 debian8-1 ModemManager[513]: <info>  Creating modem with plugin 'Generic' and '2' ports
Jun 24 00:45:47 debian8-1 ModemManager[513]: <warn>  Could not grab port (tty/ttyPZ0): 'Cannot add port 'tty/
Jun 24 00:45:47 debian8-1 ModemManager[513]: <warn>  Could not grab port (tty/ttyPZ1): 'Cannot add port 'tty/
Jun 24 00:45:47 debian8-1 ModemManager[513]: <warn>  Couldn't create modem for device at '/sys/devices/pci000
Jun 24 00:45:52 debian8-1 kdm[901]: :0[901]: pam_unix(kdm:session): session opened for user lucas by (uid=0)
Jun 24 00:45:52 debian8-1 systemd[1]: Starting user-1000.slice.
Jun 24 00:45:52 debian8-1 systemd[1]: Created slice user-1000.slice.
Jun 24 00:45:52 debian8-1 systemd[1]: Starting User Manager for UID 1000...
Jun 24 00:45:52 debian8-1 systemd-logind[520]: New session 1 of user lucas.
Jun 24 00:45:52 debian8-1 systemd[1]: Starting Session 1 of user lucas.
Jun 24 00:45:52 debian8-1 systemd[1]: Started Session 1 of user lucas.
Jun 24 00:45:52 debian8-1 systemd[983]: pam_unix(systemd-user:session): session opened for user lucas by (uid
Jun 24 00:45:52 debian8-1 systemd[983]: Starting Paths.
...
Jun 24 01:12:49 debian8-1 su[1549]: + /dev/pts/0 lucas:root
Jun 24 01:12:49 debian8-1 su[1549]: pam_unix(su:session): session opened for user root by (uid=1000)
Jun 24 01:12:58 debian8-1 gpasswd[1551]: user lucas added by root to group systemd-journal
Jun 24 01:13:12 debian8-1 dhclient[925]: DHCPREQUEST on wlan0 to 192.168.178.1 port 67
Jun 24 01:13:13 debian8-1 dhclient[925]: DHCPACK from 192.168.178.1
Jun 24 01:13:13 debian8-1 NetworkManager[515]: <info> (wlan0): DHCPv4 state changed bound -> renew
Jun 24 01:13:13 debian8-1 NetworkManager[515]: <info>   address 192.168.178.21
Jun 24 01:13:13 debian8-1 NetworkManager[515]: <info>   plen 24 (255.255.255.0)
Jun 24 01:13:13 debian8-1 NetworkManager[515]: <info>   gateway 192.168.178.1
Jun 24 01:13:13 debian8-1 NetworkManager[515]: <info>   server identifier 192.168.178.1
Jun 24 01:13:13 debian8-1 NetworkManager[515]: <info>   lease time 3600
Jun 24 01:13:13 debian8-1 NetworkManager[515]: <info>   nameserver '212.54.40.25'
Jun 24 01:13:13 debian8-1 NetworkManager[515]: <info>   nameserver '212.54.44.54'
Jun 24 01:13:13 debian8-1 NetworkManager[515]: <info>   domain name 'dynamic.ziggo.nl'
Jun 24 01:13:13 debian8-1 dbus[534]: [system] Activating via systemd: service name='org.freedesktop.nm_dispat
Jun 24 01:13:13 debian8-1 systemd[1]: Starting Network Manager Script Dispatcher Service...
Jun 24 01:13:13 debian8-1 dhclient[925]: bound to 192.168.178.21 -- renewal in 1439 seconds.
Jun 24 01:13:13 debian8-1 dbus[534]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jun 24 01:13:13 debian8-1 systemd[1]: Started Network Manager Script Dispatcher Service.
Jun 24 01:13:13 debian8-1 nm-dispatcher[1556]: Dispatching action 'dhcp4-change' for wlan0
Jun 24 01:13:24 debian8-1 newgrp[1561]: user 'root' (login 'lucas' on pts/0) switched to group 'systemd-journ
Jun 24 01:17:02 debian8-1 CRON[1568]: pam_unix(cron:session): session opened for user root by (uid=0)
Jun 24 01:17:02 debian8-1 CRON[1569]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Jun 24 01:17:02 debian8-1 CRON[1568]: pam_unix(cron:session): session closed for user root
lines 1051-1073/1073 (END)


Cheers, Lucas
You'll see it once you get it
lucas
 
Posts: 27
Joined: 2014-09-27 10:56
Location: Amsterdam

Re: failed to load module

Postby Head_on_a_Stick » 2015-06-24 06:14

Post the content of /etc/modules and any files in /etc/modules-load.d and the output of:
Code: Select all
aptitude search linux-headers linux-image
uname -a
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6804
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: failed to load module

Postby lucas » 2015-06-24 09:59

Hi "Head ...",

content of /etc/modules:
Code: Select all
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

apm_emu
therm_adt746x


files in /etc/modules-load.d:
    lucas@debian8-1:~$ cd /etc/modules-load.d
    lucas@debian8-1:/etc/modules-load.d$ ls -a
    . .. cups-filters.conf modules.conf
    lucas@debian8-1:/etc/modules-load.d$

output
aptitude search linux-headers linux-image
uname -a

Code: Select all
lucas@debian8-1:~$ aptitude search linux-headers linux-image
p   linux-headers-3.16.0-4-all      - All header files for Linux 3.16 (meta-pack
p   linux-headers-3.16.0-4-all-powe - All header files for Linux 3.16 (meta-pack
p   linux-headers-3.16.0-4-common   - Common header files for Linux 3.16.0-4   
p   linux-headers-3.16.0-4-powerpc  - Header files for Linux 3.16.0-4-powerpc   
p   linux-headers-3.16.0-4-powerpc- - Header files for Linux 3.16.0-4-powerpc-sm
p   linux-headers-3.16.0-4-powerpc6 - Header files for Linux 3.16.0-4-powerpc64
p   linux-headers-powerpc           - Header files for Linux powerpc configurati
p   linux-headers-powerpc-smp       - Header files for Linux powerpc-smp configu
p   linux-headers-powerpc64         - Header files for Linux powerpc64 configura
i A linux-image-3.16.0-4-powerpc    - Linux 3.16 for uniprocessor 32-bit PowerPC
p   linux-image-3.16.0-4-powerpc-sm - Linux 3.16 for multiprocessor 32-bit Power
p   linux-image-3.16.0-4-powerpc64  - Linux 3.16 for 64-bit PowerPC             
i   linux-image-powerpc             - Linux for uniprocessor 32-bit PowerPC (met
p   linux-image-powerpc-smp         - Linux for multiprocessor 32-bit PowerPC (m
p   linux-image-powerpc64           - Linux for 64-bit PowerPC (meta-package)   
lucas@debian8-1:~$ uname -a
Linux debian8-1 3.16.0-4-powerpc #1 Debian 3.16.7-ckt11-1 (2015-05-24) ppc GNU/Linux
lucas@debian8-1:~$



Thanks,
Lucas
You'll see it once you get it
lucas
 
Posts: 27
Joined: 2014-09-27 10:56
Location: Amsterdam

Re: failed to load module

Postby Head_on_a_Stick » 2015-06-24 18:17

lucas wrote:content of /etc/modules:
Code: Select all
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

apm_emu
therm_adt746x

Do you know why those modules are listed in this file?

I don't use a PPC so I don't know if this is a default setting for that architecture.

Try removing (or commenting out) the "apm_emu" line and also look in the files in /etc/modprobe.d for any lines relating to the "ppdev" module and remove (or comment out) those as well.

You could also try loading the headers for your kernel.
Code: Select all
# apt-get install linux-headers-powerpc

(Or whichever header matches your specific architecture)
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6804
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: failed to load module

Postby lucas » 2015-06-25 21:27

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

apm_emu
therm_adt746x


Do you know why those modules are listed in this file?


No, I don't know. Module apm_emu is not on the system.
I've apm_emu comment out.
therm_adt746x is on the system as a macintosh driver.
When I comment it out, after boot the GUI is freezing.
So I've removed the #.

In the files in modprobe.d I have not found a relation with ppdev.

Code: Select all
lucas@debian8-1:~$ cd /etc/modprobe.d
lucas@debian8-1:/etc/modprobe.d$ ls
fbdev-blacklist.conf  modesetting.conf
lucas@debian8-1:/etc/modprobe.d$ nano fbdev-blacklist.conf
lucas@debian8-1:/etc/modprobe.d$ sudo nano  modesetting.conf
lucas@debian8-1:/etc/modprobe.d$ cd
lucas@debian8-1:~$ locate  therm_adt746x
/lib/modules/3.16.0-4-powerpc/kernel/drivers/macintosh/therm_adt746x.ko
lucas@debian8-1:~$


after boot:
Code: Select all
lucas@debian8-1:~$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Thu 2015-06-25 23:12:47 CEST; 7min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 483 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 483 (code=exited, status=1/FAILURE)

Jun 25 23:12:47 debian8-1 systemd[1]: Starting Load Kernel Modules...
Jun 25 23:12:47 debian8-1 systemd[1]: systemd-modules-load.service: main pr...RE
Jun 25 23:12:47 debian8-1 systemd[1]: Failed to start Load Kernel Modules.
Jun 25 23:12:47 debian8-1 systemd[1]: Unit systemd-modules-load.service ent...e.
Hint: Some lines were ellipsized, use -l to show in full.
lucas@debian8-1:~$


Cheers, Lucas
Last edited by lucas on 2015-06-25 21:34, edited 1 time in total.
You'll see it once you get it
lucas
 
Posts: 27
Joined: 2014-09-27 10:56
Location: Amsterdam

Re: failed to load module

Postby Head_on_a_Stick » 2015-06-25 21:34

Does `journalctl _PID=483` just show "ppdev" as the failed module now?

What is the output of:
Code: Select all
grep ppdev /etc/modprobe.d/*
locate ppdev
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6804
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: failed to load module

Postby lucas » 2015-06-25 21:40

Nothing:

Code: Select all
ucas@debian8-1:~$ grep ppdev /etc/modprobe.d/*
lucas@debian8-1:~$
lucas@debian8-1:~$


Lucas
Last edited by lucas on 2015-06-26 07:03, edited 1 time in total.
You'll see it once you get it
lucas
 
Posts: 27
Joined: 2014-09-27 10:56
Location: Amsterdam

Re: failed to load module

Postby Head_on_a_Stick » 2015-06-25 21:49

What is the output of:
Code: Select all
grep ppdev /boot/System.map-$(uname -r)
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6804
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: failed to load module

Postby lucas » 2015-06-26 07:04

The output, alsoo from locate ppdev
Code: Select all
lucas@debian8-1:~$ grep ppdev /etc/modprobe.d/*
lucas@debian8-1:~$ locate ppdev
/usr/include/linux/ppdev.h
/usr/src/linux-headers-3.16.0-4-common/include/uapi/linux/ppdev.h
lucas@debian8-1:~$ grep ppdev /boot/System.map-$(uname -r)
lucas@debian8-1:~$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Fri 2015-06-26 08:09:46 CEST; 50min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 479 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 479 (code=exited, status=1/FAILURE)

Jun 26 08:09:46 debian8-1 systemd-modules-load[479]: Failed to find module 'p...
Jun 26 08:09:46 debian8-1 systemd[1]: systemd-modules-load.service: main pr...RE
Jun 26 08:09:46 debian8-1 systemd[1]: Failed to start Load Kernel Modules.
Jun 26 08:09:46 debian8-1 systemd[1]: Unit systemd-modules-load.service ent...e.
Hint: Some lines were ellipsized, use -l to show in full.
lucas@debian8-1:~$


Lucas
You'll see it once you get it
lucas
 
Posts: 27
Joined: 2014-09-27 10:56
Location: Amsterdam

Re: failed to load module

Postby Head_on_a_Stick » 2015-06-26 07:07

OK, try blacklisting the module then:
Code: Select all
# echo "blacklist ppdev" > /etc/modprobe.d/ppdev.conf

If this causes problems, just delete /etc/modprobe.d/ppdev.conf
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6804
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: failed to load module

Postby lucas » 2015-06-26 07:27

No difference.
rebooting, and still de failed to ... message
Lucas
You'll see it once you get it
lucas
 
Posts: 27
Joined: 2014-09-27 10:56
Location: Amsterdam

Re: failed to load module

Postby danrleywillyan » 2017-08-25 07:43

To get a complete log from the service, you can also use
journalctl -u systemd-modules-load.service

So presumably you have something in /etc/modules (or possibly
/etc/modules-load.d/) which refers to a nonexisting or broken module?

Removing it from /etc/modules will solve your issue.

:D

https://bugs.debian.org/cgi-bin/bugrepo ... bug=784636
danrleywillyan
 
Posts: 1
Joined: 2017-08-25 07:38


Return to Beginners Questions

Who is online

Users browsing this forum: Capitain_Jack and 8 guests

fashionable