problem ragarding apt-get upgrade

New to Debian (Or Linux in general)? Ask your questions here!

Re: problem ragarding apt-get upgrade

Postby kiyop » 2015-08-13 08:22

I am not familiar with apache2.
Do you need apache2 and web server?
Have you upgraded your debian from wheezy to jessie?
If so, have you read https://www.debian.org/releases/stable/ ... pd-incomat ?

Try also
Code: Select all
journalctl -xn

and post the results and wait reply from the other persons.
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: problem ragarding apt-get upgrade

Postby tr64 » 2015-08-13 08:48

no,I'm not using apache2 .
I'm using debian jessie (8.1)
tr64
 
Posts: 23
Joined: 2015-08-12 10:27

Re: problem ragarding apt-get upgrade

Postby kiyop » 2015-08-13 08:57

tr64 wrote:no,I'm not using apache2

:?: :? I am confused.
If you don't need apache2, how about removing apache2 packages?
Code: Select all
apt-get -s remove apache2

But, I am not familiar with apache2. And so, removing apache2 may harm your debian.
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: problem ragarding apt-get upgrade

Postby tr64 » 2015-08-13 09:02

sorry
I don't have a web server .
I'm simply using debian 8.1 with no server or anything such
after upgrading .this error just apeared.
tr64
 
Posts: 23
Joined: 2015-08-12 10:27

Re: problem ragarding apt-get upgrade

Postby kiyop » 2015-08-13 09:04

Execute
Code: Select all
dpkg -l|grep apache|grep ^i

and post the results.
Last edited by kiyop on 2015-08-13 09:05, edited 1 time in total.
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: problem ragarding apt-get upgrade

Postby tr64 » 2015-08-13 09:04

root@zx:/home/qwerty# apt-get -s remove apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
apache2
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Remv apache2 [2.4.10-10+deb8u1]
Conf ldap-account-manager (4.7.1-1 Debian:8.1/stable [all])
tr64
 
Posts: 23
Joined: 2015-08-12 10:27

Re: problem ragarding apt-get upgrade

Postby kiyop » 2015-08-13 09:10

tr64 wrote:The following packages will be REMOVED:
apache2

apache2 package is installed in the debian of yours.
Maybe apache2 was installed because it was required by some other package which you installed, before you were aware of it.
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: problem ragarding apt-get upgrade

Postby kiyop » 2015-08-13 09:12

How about trying to remove apache2?
Code: Select all
apt-get remove apache2

and then, check what packages may be removed by "autoremove":
Code: Select all
apt-get -s autoremove
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: problem ragarding apt-get upgrade

Postby tr64 » 2015-08-13 09:15

yes,I guess apache2 was a dependency or just was installed by default.
I asked the guy you intruduced to help me ,may he helps.
root@zx:/home/qwerty# dpkg -l|grep apache
ii apache2 2.4.10-10+deb8u1 amd64 Apache HTTP Server
ii apache2-bin 2.4.10-10+deb8u1 amd64 Apache HTTP Server (modules and other binary files)
ii apache2-data 2.4.10-10+deb8u1 all Apache HTTP Server (common files)
ii apache2-dev 2.4.10-10+deb8u1 amd64 Apache HTTP Server (development headers)
ii apache2-doc 2.4.10-10+deb8u1 all Apache HTTP Server (on-site documentation)
ii apache2-suexec 2.4.10-10+deb8u1 amd64 transitional package for apache2-suexec-pristine
ii apache2-suexec-custom 2.4.10-10+deb8u1 amd64 Apache HTTP Server configurable suexec program for mod_suexec
ii apache2-suexec-pristine 2.4.10-10+deb8u1 amd64 Apache HTTP Server standard suexec program for mod_suexec
ii apache2-utils 2.4.10-10+deb8u1 amd64 Apache HTTP Server (utility programs for web servers)
ii apache2.2-bin 2.4.10-10+deb8u1 amd64 Transitional package for apache2-bin
rc apache2.2-common 2.4.10-10+deb8u1 amd64 Transitional package for apache2
ii apachedex 1.6.2-1 all Compute APDEX from Apache-style logs
ii apachetop 0.12.6-16 amd64 Realtime Apache monitoring tool
ii libapache-logformat-compiler-perl 0.30-1 all Perl module to pre-compile a LogFormat string
ii libapache-pom-java 10-2 all Maven metadata for all Apache Software projects
ii libapache2-mod-dnssd 0.6-3.1 amd64 Zeroconf support for Apache 2 via avahi
rc libapache2-mod-nss 1.0.10-3 amd64 NSS-based SSL module for Apache2
rc libapache2-mod-php5 5.6.9+dfsg-0+deb8u1 amd64 server-side, HTML-embedded scripting language (Apache 2 module)
ii libapache2-mod-upload-progress 0.2-2 amd64 upload progress support for the Apache web server
rc libapache2-mpm-itk 2.4.7-02-1.1 amd64 multiuser module for Apache
ii libbatik-java 1.7+dfsg-5 all xml.apache.org SVG Library
root@zx:/home/qwerty#

**********************************************************************************

root@zx:/home/qwerty# apt-get -s autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Conf ldap-account-manager (4.7.1-1 Debian:8.1/stable [all])
root@zx:/home/qwerty#
tr64
 
Posts: 23
Joined: 2015-08-12 10:27

Re: problem ragarding apt-get upgrade

Postby tr64 » 2015-08-13 09:46

root@zx:/home/qwerty# dpkg -l|grep apache|grep ^i
ii apache2 2.4.10-10+deb8u1 amd64 Apache HTTP Server
ii apache2-bin 2.4.10-10+deb8u1 amd64 Apache HTTP Server (modules and other binary files)
ii apache2-data 2.4.10-10+deb8u1 all Apache HTTP Server (common files)
ii apache2-dev 2.4.10-10+deb8u1 amd64 Apache HTTP Server (development headers)
ii apache2-doc 2.4.10-10+deb8u1 all Apache HTTP Server (on-site documentation)
ii apache2-suexec 2.4.10-10+deb8u1 amd64 transitional package for apache2-suexec-pristine
ii apache2-suexec-custom 2.4.10-10+deb8u1 amd64 Apache HTTP Server configurable suexec program for mod_suexec
ii apache2-suexec-pristine 2.4.10-10+deb8u1 amd64 Apache HTTP Server standard suexec program for mod_suexec
ii apache2-utils 2.4.10-10+deb8u1 amd64 Apache HTTP Server (utility programs for web servers)
ii apache2.2-bin 2.4.10-10+deb8u1 amd64 Transitional package for apache2-bin
ii apachedex 1.6.2-1 all Compute APDEX from Apache-style logs
ii apachetop 0.12.6-16 amd64 Realtime Apache monitoring tool
ii libapache-logformat-compiler-perl 0.30-1 all Perl module to pre-compile a LogFormat string
ii libapache-pom-java 10-2 all Maven metadata for all Apache Software projects
ii libapache2-mod-dnssd 0.6-3.1 amd64 Zeroconf support for Apache 2 via avahi
ii libapache2-mod-upload-progress 0.2-2 amd64 upload progress support for the Apache web server
ii libbatik-java 1.7+dfsg-5 all xml.apache.org SVG Library
root@zx:/home/qwerty#
tr64
 
Posts: 23
Joined: 2015-08-12 10:27

Re: problem ragarding apt-get upgrade

Postby kiyop » 2015-08-13 13:51

Indeed, a lot of packages relevant to apache2 are installed.
How about trying what is on my last post?
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: problem ragarding apt-get upgrade

Postby stevepusser » 2015-08-13 20:45

Can you force the removal of ldap-account-manager with dpkg?

Code: Select all
su -c 'dpkg -r --force-all ldap-account-manager'
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Notepadqq 1.2.0, Pale Moon 27.8.3, KeePassXC 2.3.1, Calligra 3.1, VLC 3.0.1, Firefox 59.0.2, Shotwell 28.2
User avatar
stevepusser
 
Posts: 9432
Joined: 2009-10-06 05:53

Re: problem ragarding apt-get upgrade

Postby tr64 » 2015-08-13 22:14

root@zx:/home/qwerty# su -c 'dpkg -r --force-all ldap-account-manager'
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: package is in a very bad inconsistent state; you should
reinstall it before attempting a removal
(Reading database ... 363916 files and directories currently installed.)
Removing ldap-account-manager (4.7.1-1) ...
Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript apache2, action "reload" failed.
dpkg: error processing package ldap-account-manager (--remove):
subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
ldap-account-manager
root@zx:/home/qwerty# apt-get remove apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
apache2
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/10.7 MB of archives.
After this operation, 518 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 363916 files and directories currently installed.)
Removing apache2 (2.4.10-10+deb8u1) ...
Processing triggers for man-db (2.7.0.2-5) ...
dpkg: error processing package ldap-account-manager (--configure):
package ldap-account-manager is not ready for configuration
cannot configure (current status `half-installed')
Errors were encountered while processing:
ldap-account-manager
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@zx:/home/qwerty# apt-get -s autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Conf ldap-account-manager (4.7.1-1 Debian:8.1/stable [all])
root@zx:/home/qwerty
tr64
 
Posts: 23
Joined: 2015-08-12 10:27

Re: problem ragarding apt-get upgrade

Postby stevepusser » 2015-08-13 22:47

Boy, that's annoying. How about

Code: Select all
su -c 'apt-get --purge remove ldap-account-manager'
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Notepadqq 1.2.0, Pale Moon 27.8.3, KeePassXC 2.3.1, Calligra 3.1, VLC 3.0.1, Firefox 59.0.2, Shotwell 28.2
User avatar
stevepusser
 
Posts: 9432
Joined: 2009-10-06 05:53

Re: problem ragarding apt-get upgrade

Postby fireExit » 2015-08-13 22:56

Code: Select all
dpkg-reconfigure ldap-account-manager

AFAIK debconf didn't configure lam properly first time it was installed.
User avatar
fireExit
 
Posts: 559
Joined: 2014-11-20 11:22

PreviousNext

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable