E: Unable to locate package php5-tidy

New to Debian (Or Linux in general)? Ask your questions here!

E: Unable to locate package php5-tidy

Postby webspilka » 2017-03-16 13:05

hi
how to install php5-tidy?
I try
Code: Select all
sudo apt-get install php5-tidy
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5-tidy


I have :
Debian 8 x64 (jessie)
linux-image-3.16.0-4-amd64 (3.16.39-1+deb8u2)
Code: Select all
php -v
PHP 5.6.30-0+deb8u1 (cli) (built: Feb  8 2017 08:50:21)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
webspilka
 
Posts: 3
Joined: 2017-03-16 13:01

Re: E: Unable to locate package php5-tidy

Postby arochester » 2017-03-16 13:11

Miss out the 5?
Code: Select all
sudo apt install php-tidy
arochester
 
Posts: 829
Joined: 2010-12-07 19:55

Re: E: Unable to locate package php5-tidy

Postby GarryRicketson » 2017-03-16 13:14

---edited----
https://packages.debian.org/jessie/php5-tidy
Package: php5-tidy (5.6.30+dfsg-0+deb8u1)

Looks like it is there.

What does your /etc/apt/sources.list file have in it ?
Please show us that.
User avatar
GarryRicketson
 
Posts: 3658
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: E: Unable to locate package php5-tidy

Postby webspilka » 2017-03-16 14:15

my source list :
Code: Select all
tail /etc/apt/sources.list

deb http://http.us.debian.org/debian/ jessie main
deb-src http://http.us.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://http.us.debian.org/debian/ jessie-updates main
deb-src http://http.us.debian.org/debian/ jessie-updates main


I also try apt-cache search 'php.*tidy'
Code: Select all
php-horde-text-filter-csstidy - Horde Text Filter API
php5-tidy - tidy module for php5
universalindentgui - GUI frontend for several code beautifiers

my lsb_release -a
Code: Select all
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux 8.7 (jessie)
Release:   8.7
Codename:   jessie
webspilka
 
Posts: 3
Joined: 2017-03-16 13:01

Re: E: Unable to locate package php5-tidy

Postby arochester » 2017-03-16 15:48

Compare yours
Code: Select all
deb http://security.debian.org/ jessie/updates main
with (for AMD64)
Code: Select all
deb http://security.debian.org/debian-security jessie/updates main
- https://packages.debian.org/jessie/amd6 ... y/download
arochester
 
Posts: 829
Joined: 2010-12-07 19:55

Re: E: Unable to locate package php5-tidy

Postby webspilka » 2017-03-17 10:26

Thanks arochester,
arochester wrote:deb http://security.debian.org/debian-security jessie/updates main

it's work for me well :D
webspilka
 
Posts: 3
Joined: 2017-03-16 13:01


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable