Sound card settings resetting on reboot [SOLVED]

New to Debian (Or Linux in general)? Ask your questions here!

Sound card settings resetting on reboot [SOLVED]

Postby Lysander » 2017-04-24 21:19

I have noticed than whenever I reboot my sound setting have gone back to what I assume is default. I have an X-FI Platinum music sound card and whenever I reboot I notice that the sound panel has gone back to headphone setting, sound notifications have been enabled and the sound input device has changed. Is there any way I can save the settings? Here's some info about the audio from inxi:

Code: Select all
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Cypress HDMI Audio [Radeon HD 5800 Series]
           driver: snd_hda_intel
           Card-2 Creative Labs SB X-Fi driver: snd_ctxfi
           Card-3 Intel 82801JI (ICH10 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Last edited by Lysander on 2017-04-30 13:43, edited 1 time in total.
Lysander
 
Posts: 72
Joined: 2017-02-23 10:07

Re: Sound settings resetting on reboot

Postby phenest » 2017-04-25 07:32

What version of Debian are you using? And what software are you using to change the settings?
Dell XPS 17 L702X i7 2860QM 2.5GHz - 32GB RAM - 4G WWAN - Pioneer TD05-BDR
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS P8P67 EVO i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1441
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Sound settings resetting on reboot

Postby Lysander » 2017-04-25 07:54

phenest wrote:What version of Debian are you using? And what software are you using to change the settings?


Sorry, I should have said. I'm on 8.7. I don't know what the software is that I'm changing the setting in, but I do it via the Sound function in Settings.
Lysander
 
Posts: 72
Joined: 2017-02-23 10:07

Re: Sound settings resetting on reboot

Postby Lysander » 2017-04-29 18:31

I have an update on this, it's clear that it's the default Pulse audio settings that need to be changed, since this is what Sound in the Settings menu related to. Is there any way to set them?

EDIT: solved

Code: Select all
pacmd list-cards
to get the profile/index of my sound card

then

Code: Select all
pacmd set-card-profile 2 output:analog-stereo


then added this to the end of /etc/pulse/default.pa

Code: Select all
set-card-profile 2  output:analog-stereo
set-default-sink 2


then rebooted.
Lysander
 
Posts: 72
Joined: 2017-02-23 10:07


Return to Beginners Questions

Who is online

Users browsing this forum: bigrigdriver, JonPaul and 7 guests

fashionable