[Abandoned] Dell vostro 2420 wifi is not working

New to Debian (Or Linux in general)? Ask your questions here!

[Abandoned] Dell vostro 2420 wifi is not working

Postby dannyhmui » 2017-05-10 20:47

New to linux,new to debian, fresh installed debian, but wifi is not working.
Tried apt-get install bcmwl-kernek-source
Then modprobe wl
Doesn't work, it shows
Modprobe: Fatal: module wl not found.

Please help.
Last edited by dannyhmui on 2017-05-12 05:57, edited 1 time in total.
dannyhmui
 
Posts: 31
Joined: 2017-05-10 20:41

Re: Dell vostro 2420 wifi is not working

Postby arochester » 2017-05-10 20:52

Open a Terminal

Issue this command: lspci |grep Network

What is the output? Copy and Paste here so we can see...
"Something to be aware of: Debian is a core or source distribution. This means there are many Debian-based distributions. THEY ARE NOT DEBIAN."
arochester
 
Posts: 1080
Joined: 2010-12-07 19:55

Re: Dell vostro 2420 wifi is not working

Postby stevepusser » 2017-05-10 21:04

Tried apt-get install bcmwl-kernek-source


That's also a (mistyped) Ubuntu-specific command, and won't do a thing on Debian. The Debian wiki has a guide for installing the correct packages for Broadcom wi-fi chipsets, but for some it's quite difficult without any Net connection. So we'll need to know if you have a connection, and what hardware it actually is, per the preceding post.

I do have a prebuilt "wl" driver deb for the stock 64-bit Jessie 3.16 kernel available in my Google drive that does an end-run around all that stuff, though, if that's what your chipset requires: https://drive.google.com/open?id=0BxE7w ... UlrYjVNMU0
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8900
Joined: 2009-10-06 05:53

Re: Dell vostro 2420 wifi is not working

Postby dannyhmui » 2017-05-11 08:02

In fedora was quite easy to fix this, just
dnf install Broadcom-wl kernel-devel
Su akmod wl
Modprobe -a wl
Then it will solve, anyway, I gave up and installed debian on another virtual machine
dannyhmui
 
Posts: 31
Joined: 2017-05-10 20:41


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable