[Abandoned] Dell vostro 2420 wifi is not working

New to Debian (Or Linux in general)? Ask your questions here!

[Abandoned] Dell vostro 2420 wifi is not working

Postby dannyhmui » 2017-05-10 20:47

New to linux,new to debian, fresh installed debian, but wifi is not working.
Tried apt-get install bcmwl-kernek-source
Then modprobe wl
Doesn't work, it shows
Modprobe: Fatal: module wl not found.

Please help.
Last edited by dannyhmui on 2017-05-12 05:57, edited 1 time in total.
dannyhmui
 
Posts: 2
Joined: 2017-05-10 20:41

Re: Dell vostro 2420 wifi is not working

Postby arochester » 2017-05-10 20:52

Open a Terminal

Issue this command: lspci |grep Network

What is the output? Copy and Paste here so we can see...
Debian Users Forum - for questions specific to the Debian official distribution (stable, testing, or unstable); if you are using a derivative of Debian (e.g. Mint, Ubuntu, Kali, etc), then please use that distribution’s forum.
arochester
 
Posts: 908
Joined: 2010-12-07 19:55

Re: Dell vostro 2420 wifi is not working

Postby stevepusser » 2017-05-10 21:04

Tried apt-get install bcmwl-kernek-source


That's also a (mistyped) Ubuntu-specific command, and won't do a thing on Debian. The Debian wiki has a guide for installing the correct packages for Broadcom wi-fi chipsets, but for some it's quite difficult without any Net connection. So we'll need to know if you have a connection, and what hardware it actually is, per the preceding post.

I do have a prebuilt "wl" driver deb for the stock 64-bit Jessie 3.16 kernel available in my Google drive that does an end-run around all that stuff, though, if that's what your chipset requires: https://drive.google.com/open?id=0BxE7w ... UlrYjVNMU0
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.4, Pale Moon 27.3.0, Liquorix kernel 4.11-4, mpv 0.25.0, Kodi 17.1, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8228
Joined: 2009-10-06 05:53

Re: Dell vostro 2420 wifi is not working

Postby dannyhmui » 2017-05-11 08:02

In fedora was quite easy to fix this, just
dnf install Broadcom-wl kernel-devel
Su akmod wl
Modprobe -a wl
Then it will solve, anyway, I gave up and installed debian on another virtual machine
dannyhmui
 
Posts: 2
Joined: 2017-05-10 20:41


Return to Beginners Questions

Who is online

Users browsing this forum: bigrigdriver, JonPaul and 6 guests

fashionable