Sie haben zurückgehaltene defekte Pakete

New to Debian (Or Linux in general)? Ask your questions here!

Sie haben zurückgehaltene defekte Pakete

Postby vikozo » 2017-06-20 10:04

hello
i have this error
Code: Select all
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libssl-dev : Hängt ab von: libssl1.0.0 (= 1.0.1t-1+deb8u6) aber 1.0.2k-1~bpo8+1 soll installiert werden
 E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

the second part say there is a broken paket, how to resolve this Problem
apt-get install -f
apt-get autoremove
apt-get autoclean

all did not help
any idea
vikozo
 
Posts: 27
Joined: 2016-03-06 10:55
Location: suisse

Re: Sie haben zurückgehaltene defekte Pakete

Postby Hallvor » 2017-06-20 17:40

Try uninstalling libssl-dev and proceed with the upgrade. Then reinstall libssl-dev later.
Intel Core i5 3320-M CPU @ 2.60 GHz, 6 GB RAM, Intel HD 4000 graphics, 300 GB HDD, Debian Stretch (KDE)
User avatar
Hallvor
 
Posts: 739
Joined: 2009-04-16 18:35
Location: Norway

Re: Sie haben zurückgehaltene defekte Pakete

Postby vikozo » 2017-08-25 04:34

thanks for your feedbackt this did not help
when doing the Update i got 3 error
i put theme there http://wombat3.kozo.ch/j/linux-list/9722
have a nice day
vinc
vikozo
 
Posts: 27
Joined: 2016-03-06 10:55
Location: suisse

Re: Sie haben zurückgehaltene defekte Pakete

Postby debiman » 2017-08-26 20:37

you need to show us in english.
please prepend each command with LC_ALL=C, for example like this:
Code: Select all
LC_ALL=C apt update
and post the output here, between code tags.

you need to show us some proof everytime you say "didn't help" or "didn't work".
thank you.

also, have you tried what was previously suggested?

have a nice day.
User avatar
debiman
 
Posts: 1633
Joined: 2013-03-12 07:18

Re: Sie haben zurückgehaltene defekte Pakete

Postby vikozo » 2017-08-28 06:41

hello @debiman
i never saw this (LC_ALL=C apt ) before

LC_ALL=C apt install libssl-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libssl-dev : Depends: libssl1.0.0 (= 1.0.1t-1+deb8u6) but 1.0.2l-1~bpo8+1 is to be installed
Recommends: libssl-doc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
vikozo
 
Posts: 27
Joined: 2016-03-06 10:55
Location: suisse

Re: Sie haben zurückgehaltene defekte Pakete

Postby deborah-and-ian » 2017-08-28 07:48

Are you using Stretch? Then there is no libssl1.0.0 , that's the old version that's not supposed to be used anymore. Of course, some external debian packages still depend on it. You can manually install libssl1.0.0 from Jessie -- this works for now, but I wouldn't recommend that, since you might end up with a Frankendebian in the future (it works for now, but it's not the way it's supposed to be). The best approach would be to tell the maintainer of the software you want to install to bump the dependency to 1.0.2 or better yet 1.1.

Examples of such software: Viber
Debian GNU/Linux 9 Stretch w/Gnome 3.22

Acer Aspire E5-521G
AMD A8-6410 APU
4 GB RAM
integrated AMD Mullins
dedicated AMD Hainan Radeon R5 M240 2 GB
240 GB Toshiba Q300 SSD
Realtek RTL8111/8168/8411 ethernet
Qualcomm Atheros QCA9565 wireless
deborah-and-ian
 
Posts: 173
Joined: 2016-07-13 08:40


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable