Debian won't update - package updater error

New to Debian (Or Linux in general)? Ask your questions here!

Debian won't update - package updater error

Postby ayarrington73 » 2017-07-09 16:02

Package Updater says "no network connection was detected", although internet works fine(wireless) and I'm on it right now writing this post......any ideas? I'm a disabled i.t. pro, so I'm not hesitant to try ideas...
T.I.A.
-Al
ayarrington73
 
Posts: 55
Joined: 2017-02-02 18:38

Re: Debian won't update - package updater error

Postby arochester » 2017-07-09 16:07

If you open a Terminal ans input (AS ROOT)
Code: Select all
apt update
--what does it say?
arochester
 
Posts: 971
Joined: 2010-12-07 19:55

Re: Debian won't update - package updater error

Postby ayarrington73 » 2017-07-09 19:06

arochester wrote:If you open a Terminal ans input (AS ROOT)
Code: Select all
apt update
--what does it say?

I use the "sudo" prefix in terminal and it spits out screens of output but doesn't appear to update anything...if you want, I can paste some/all of the output here, but I don't want to be spammy unless requested....
T!
ayarrington73
 
Posts: 55
Joined: 2017-02-02 18:38

Re: Debian won't update - package updater error

Postby stevepusser » 2017-07-09 19:11

Paste away (in a code box). That probably shows what's going wrong.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8416
Joined: 2009-10-06 05:53

Re: Debian won't update - package updater error

Postby ayarrington73 » 2017-07-09 19:13

also, I just noticed in 'package updater, that it shows several updates behind the message that "no updates are available"...

here'es the output:
dad@dadlinux:~$ apt update
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
dad@dadlinux:~$ sudo apt update
[sudo] password for dad:
Ign http://dl.google.com stable InRelease
Hit http://dl.google.com stable Release.gpg
Ign http://http.us.debian.org squeeze InRelease
Hit http://dl.google.com stable Release
Ign http://http.us.debian.org squeeze Release.gpg
Ign http://http.us.debian.org squeeze Release
Get:1 http://security.debian.org jessie/updates InRelease [63.1 kB]
Ign http://ftp.us.debian.org jessie InRelease
Ign http://security.debian.org squeeze/updates InRelease
Ign http://security.debian.org squeeze/updates Release.gpg
Get:2 http://ftp.us.debian.org jessie-updates InRelease [145 kB]
Ign http://security.debian.org squeeze/updates Release
Ign http://security.debian.org squeeze/updates/main i386 Packages/DiffIndex
Ign http://security.debian.org squeeze/updates/contrib i386 Packages/DiffIndex
Ign http://security.debian.org squeeze/updates/non-free i386 Packages/DiffIndex
Hit http://ftp.us.debian.org jessie Release.gpg
Hit http://ftp.us.debian.org jessie Release
Get:3 http://security.debian.org jessie/updates/main Sources [210 kB]
Get:4 http://ftp.us.debian.org jessie-updates/main Sources [15.7 kB]
Get:5 http://security.debian.org jessie/updates/main i386 Packages [416 kB]
Get:6 http://ftp.us.debian.org jessie-updates/main i386 Packages/DiffIndex [8,392 B]
Hit http://security.debian.org jessie/updates/main Translation-en
Get:7 http://ftp.us.debian.org jessie-updates/main Translation-en/DiffIndex [3,196 B]
Err http://http.us.debian.org squeeze/main i386 Packages
404 Not Found [IP: 2610:148:1f10:3::89 80]
Err http://http.us.debian.org squeeze/contrib i386 Packages
404 Not Found [IP: 2610:148:1f10:3::89 80]
Ign http://security.debian.org squeeze/updates/contrib Translation-en_US
Err http://http.us.debian.org squeeze/non-free i386 Packages
404 Not Found [IP: 2610:148:1f10:3::89 80]
Ign http://security.debian.org squeeze/updates/contrib Translation-en
Ign http://security.debian.org squeeze/updates/main Translation-en_US
Ign http://http.us.debian.org squeeze/contrib Translation-en_US
Ign http://security.debian.org squeeze/updates/main Translation-en
Ign http://security.debian.org squeeze/updates/non-free Translation-en_US
Ign http://security.debian.org squeeze/updates/non-free Translation-en
Ign http://http.us.debian.org squeeze/contrib Translation-en
Err http://security.debian.org squeeze/updates/main i386 Packages
404 Not Found [IP: 2607:ea00:101:3c0b::1deb:215 80]
Err http://security.debian.org squeeze/updates/contrib i386 Packages
404 Not Found [IP: 2607:ea00:101:3c0b::1deb:215 80]
Ign http://http.us.debian.org squeeze/main Translation-en_US
Err http://security.debian.org squeeze/updates/non-free i386 Packages
404 Not Found [IP: 2607:ea00:101:3c0b::1deb:215 80]
Ign http://http.us.debian.org squeeze/main Translation-en
Ign http://http.us.debian.org squeeze/non-free Translation-en_US
Ign http://http.us.debian.org squeeze/non-free Translation-en
Get:8 http://ftp.us.debian.org jessie/main Sources [7,055 kB]
Get:9 http://ftp.us.debian.org jessie/main i386 Packages [6,793 kB]
Get:10 http://ftp.us.debian.org jessie/main Translation-en [4,583 kB]
Fetched 861 kB in 24s (35.6 kB/s)
W: There is no public key available for the following key IDs:
1397BC53640DB551
W: Failed to fetch http://dl.google.com/linux/chrome/deb/d ... le/Release Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://http.us.debian.org/debian/dists/ ... 6/Packages 404 Not Found [IP: 2610:148:1f10:3::89 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/ ... 6/Packages 404 Not Found [IP: 2610:148:1f10:3::89 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/ ... 6/Packages 404 Not Found [IP: 2610:148:1f10:3::89 80]

W: Failed to fetch http://security.debian.org/dists/squeez ... 6/Packages 404 Not Found [IP: 2607:ea00:101:3c0b::1deb:215 80]

W: Failed to fetch http://security.debian.org/dists/squeez ... 6/Packages 404 Not Found [IP: 2607:ea00:101:3c0b::1deb:215 80]

W: Failed to fetch http://security.debian.org/dists/squeez ... 6/Packages 404 Not Found [IP: 2607:ea00:101:3c0b::1deb:215 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
dad@dadlinux:~$
ayarrington73
 
Posts: 55
Joined: 2017-02-02 18:38

Re: Debian won't update - package updater error

Postby ayarrington73 » 2017-07-09 19:18

thanks for your help in advance...I hope something sticks out to you from all that verbage :)
ayarrington73
 
Posts: 55
Joined: 2017-02-02 18:38

Re: Debian won't update - package updater error

Postby arochester » 2017-07-09 19:42

Your source list must be in a mess.

The current Stable is Stretch

You have Stable, Squeeze and Jessie.

If things can't be sorted out you might be better with a fresh install.

A stretch sources list should look something like
Code: Select all
deb  http://deb.debian.org/debian stretch main contrib non-free
deb  http://deb.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
arochester
 
Posts: 971
Joined: 2010-12-07 19:55

Re: Debian won't update - package updater error

Postby ayarrington73 » 2017-07-09 19:44

i tried a temporary workaround that doesn't really solve the root of the problem, but did enable me to d/l updates.....found it here:https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=819847. I'd swear I tried this before, but didn't have any luck...mebbe b/c I had closed terminal last time after issuing the command before trying updater?
ayarrington73
 
Posts: 55
Joined: 2017-02-02 18:38

Re: Debian won't update - package updater error

Postby ayarrington73 » 2017-07-09 19:48

arochester wrote:Your source list must be in a mess.

The current Stable is Stretch

You have Stable, Squeeze and Jessie.

If things can't be sorted out you might be better with a fresh install.

A stretch sources list should look something like
Code: Select all
deb  http://deb.debian.org/debian stretch main contrib non-free
deb  http://deb.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free

Interesting idea......Not a viable option for this thing, though...a netbook I bought off ebay without any cd dock or anything. this is, though, the second time I've run into a problem with this thing after buying it and someone floated the idea of a fresh install.....out of curiosity, is ther an install image I could use a flash drive for? I do have flash drives, but no cd dock
ayarrington73
 
Posts: 55
Joined: 2017-02-02 18:38

Re: Debian won't update - package updater error

Postby ayarrington73 » 2017-07-09 19:52

I remember, for example, it arrived from ebay being unable to browse the wireless/internet.....through some troubleshooting, I found that it had 2 gateways defined, so it was trying to use the ethernet(not connected) as a gateway......Not a horribly difficult fix, but a pain nonetheless.....guess that's why it was only $40 :shock:
ayarrington73
 
Posts: 55
Joined: 2017-02-02 18:38

Re: Debian won't update - package updater error

Postby GarryRicketson » 2017-07-09 20:08

I don't think that has much or anything to do with it,
your sources.list file does, though.

... without any cd dock or anything

Does not have anything to do with why your /apt/etc/sources.list
includes , squeeze , stable, and jessie, This is something you have done, ???
And now nothing works.

https://wiki.debian.org/DontBreakDebian
and this :
http://forums.debian.net/viewtopic.php?f=20&t=114130

is ther an install image I could use a flash drive for?

Yes there is , actually you can use any image on a USB drive, try reading
a little documentation on Keywords:
Code: Select all
 Methods of installing Debian

https://www.debian.org/doc/manuals/debian-faq/ch-getting.en.html
OR
Code: Select all
How to install Debian using a USB stick

https://wiki.debian.org/BootUsb
==========
https://www.debian.org/releases/stable/i386/ch04s03.html.en
Last edited by GarryRicketson on 2017-07-09 20:15, edited 1 time in total.
User avatar
GarryRicketson
 
Posts: 4067
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Debian won't update - package updater error

Postby arochester » 2017-07-09 20:09

You CAN install Debian from a USB flash drive.

You need to find out if your computer is 32bit or 64bit to download the correct IS0.

The use of Netbootin to write the ISO is NOT advised.

Look at something, like, Etcher instead.

Alternatively you can write the ISO to the USB flash drive using the dd command https://www.debian.org/CD/faq/#write-usb
arochester
 
Posts: 971
Joined: 2010-12-07 19:55

Re: Debian won't update - package updater error

Postby Wheelerof4te » 2017-07-09 20:09

That install is broken, install Stretch fresh and keep sources.list as mentioned earlier. It doesn't matter with what it came installed from e-bay. Just backup your data and reinstall.
Please read:
Choosing a Debian distribution
and
Dont Break Debian

When in doubt, choose Debian Stable :)
User avatar
Wheelerof4te
 
Posts: 327
Joined: 2015-08-30 20:14

Re: Debian won't update - package updater error

Postby ayarrington73 » 2017-07-09 20:11

here's the sources.list that is on there...
#

deb http://ftp.us.debian.org/debian/ jessie main
deb-src http://ftp.us.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ jessie-updates main
deb-src http://ftp.us.debian.org/debian/ jessie-updates main

deb http://http.us.debian.org/debian squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free
ayarrington73
 
Posts: 55
Joined: 2017-02-02 18:38

Re: Debian won't update - package updater error

Postby arochester » 2017-07-09 20:32

Change it to this
Code: Select all
deb  http://deb.debian.org/debian jessie main contrib non-free
deb  http://deb.debian.org/debian jessie-updates main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free


Try to update. It may not...
arochester
 
Posts: 971
Joined: 2010-12-07 19:55

Next

Return to Beginners Questions

Who is online

Users browsing this forum: dvdljns, Zill and 6 guests

fashionable