[Solved] wireless is not working

New to Debian (Or Linux in general)? Ask your questions here!

[Solved] wireless is not working

Postby Agvaniot » 2017-07-26 15:57

i just installed debian and wireless is not working.
i tried to apt-get firmware-iwlwifi
and linux-firmware-nonfree.
but still no wifi access my iwconfig is looking like this.

lo no wireless extensions.

enp3s0 no wireless extensions.

wlp2s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

my lspci wireless card is : intel corporation wireless 3165
Agvaniot
 
Posts: 42
Joined: 2017-07-26 13:07

Re: wireless is not working

Postby Hallvor » 2017-07-26 16:18

Please post the output of:

Code: Select all
lspci -v | grep Network
Intel Core i5 3320-M CPU @ 2.60 GHz, 6 GB RAM, Intel HD 4000 graphics, 300 GB HDD, Debian Stretch (KDE)
User avatar
Hallvor
 
Posts: 739
Joined: 2009-04-16 18:35
Location: Norway

Re: wireless is not working

Postby Agvaniot » 2017-07-26 16:30

Hallvor wrote:Please post the output of:

Code: Select all
lspci -v | grep Network


02:00.0 Network controller: Intel Corporation Wireless 3165 (rev 79)
Agvaniot
 
Posts: 42
Joined: 2017-07-26 13:07

Re: wireless is not working

Postby Hallvor » 2017-07-26 16:40

It looks like it is detected. I guess we need more details.

https://wiki.debian.org/WiFi/HowToUse
Intel Core i5 3320-M CPU @ 2.60 GHz, 6 GB RAM, Intel HD 4000 graphics, 300 GB HDD, Debian Stretch (KDE)
User avatar
Hallvor
 
Posts: 739
Joined: 2009-04-16 18:35
Location: Norway

Re: wireless is not working

Postby Agvaniot » 2017-07-26 16:42

Hallvor wrote:It looks like it is detected. I guess we need more details.

https://wiki.debian.org/WiFi/HowToUse

i tried the wicd section because thats what comes out of my debian box but sadly
im still unable to use the wireless card
Agvaniot
 
Posts: 42
Joined: 2017-07-26 13:07

Re: wireless is not working

Postby Hallvor » 2017-07-26 16:48

I haven't used Wicd for a long time, but open preferences to find this:
Image

Then try changing wlan0 to wlp2s0.
Intel Core i5 3320-M CPU @ 2.60 GHz, 6 GB RAM, Intel HD 4000 graphics, 300 GB HDD, Debian Stretch (KDE)
User avatar
Hallvor
 
Posts: 739
Joined: 2009-04-16 18:35
Location: Norway

Re: wireless is not working

Postby stevepusser » 2017-07-26 16:50

You have a Debian version that comes with wicd preinstalled instead of network-manager? What version is this?

The last I tried it, wicd also required you to manually add the wireless interface to manage into its preferences before you could use it. That might be at the root of your problem.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8822
Joined: 2009-10-06 05:53

Re: wireless is not working

Postby Agvaniot » 2017-07-26 16:54

i using version 9.1.
Agvaniot
 
Posts: 42
Joined: 2017-07-26 13:07

Re: wireless is not working

Postby Agvaniot » 2017-07-27 05:10

Ok i instlled network-manager and change the config to 'true'
restart the pc and the wireless is now working.
thanks for the help
Agvaniot
 
Posts: 42
Joined: 2017-07-26 13:07


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable