Wifi Issue

New to Debian (Or Linux in general)? Ask your questions here!

Wifi Issue

Postby Trakyan » 2017-07-28 11:52

I've recently (finally) had some success with getting Linux running on my Intel Atom Baytrail device. I've managed to get the latest live image working for some reason I've been unable to get a proper install working. I end up with a text only interface at various stages of stuck, most recently due to a timeout waiting for 'root device'.

I've spent a couple of days researching and trying to get this to work, new USBs (I spent a long time trying to get some distro to work on this and have since realized the USB I was using was corrupted and causing the issue, since the same distros now boot fine from a new USB), both the free and non free firmware images, neither seeming to be any different in terms of getting the device working, as well as looking through the forums here and elsewhere.
However, I got the live image with gnome working and was stoked. Until I realized the wifi wasn't working. I've gone through the troubleshooter from the help menu but didn't get far. nmcli returns
lo: unmanaged
loopback(unknown), 00:00:00:00:00:00, sw, mtu 65536

while lshw -C returns command not found.

I also found this https://wiki.debian.org/InstallingDebia ... IBY/jessie which is installing jessie onto the same device I'm using. It mentions WIFI takes special configuration which involves saving a series of files to /mnt and I'm not entirely sure how to do that. I tried looking through the files on the usb after burning the image onto there but there was no /mnt file. I'm aware /mnt is a directory and have tried typing it into the terminal but do not know where to go from there.

Sorry if this is really stupid or obvious, I don't really have any experience with Linux other than many past (failed) attempts to have it replace windows, but never even getting this far.

Thanks in advance for any help!
Posts: 7
Joined: 2017-06-05 02:26

Re: Wifi Issue

Postby wizard10000 » 2017-07-28 12:09

I have a Bay Trail tablet; you're probably not gonna get there with Debian until the 4.12 kernel is released.

But - there is hope. Check out linuxium's blog - he's been doing custom *buntu and Neon respins for Bay Trail and Cherry Trail devices.


I ran one of his respins with Kubuntu 16.04, Ubuntu's 4.11rc6 mainline kernel and the drivers and goodies linuxium provided in the respin. All hardware worked - wireless, bluetooth and sound; the only gotcha I had was that I couldn't get a modesetting video driver to run on the thing so xrandr refused to rotate the screen, which is a dealbreaker for me on a tablet.

The live images should let you know whether what you want to do is possible, but it'd be a major pain to do it with Debian right now.

Good luck -
we see things not as they are, but as we are.
-- anais nin
User avatar
Posts: 1281
Joined: 2011-05-09 20:02
Location: everywhere i go, there i am!

Re: Wifi Issue

Postby Trakyan » 2017-07-29 05:19

Thanks for the link! I've seen some other attempts to get linux on atom baytrail but not that one. The live image is working pretty well, wifi is working but sound seems a bit iffy, it didn't work the first time I booted it up but works the second go around. Same sort of issue with Youtube, it's working now. It's a bit slow right now (probably from being run off USB) but I'll try the Lubuntu iso he has as well.

Thanks a bunch though, I've finally got (completely) sick of windows after it's slowly been eating away at my very limited 32gb 'hard drive' on my netbook. That and a particularly sassy forced update message. That and I've been bitten by the open source bug haha, though hardware is more my forte.
Posts: 7
Joined: 2017-06-05 02:26

Re: Wifi Issue

Postby Jordan Morris » 2017-08-01 15:16

thanks for sharing the info i also like linux OS but was hesitant to work with it but now thanks to you i will try it once more
Jordan Morris
Posts: 2
Joined: 2017-07-27 15:47

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests