Can't install "vim"

New to Debian (Or Linux in general)? Ask your questions here!

Can't install "vim"

Postby banderas20 » 2017-08-02 12:59

Hello,

it's a little sad, but I have setup a fresh install of Debian8, and I am unable to install vim (and other packages).

I issue
Code: Select all
ap-get update
and it succeeds. So I have my network correctly configured.

However, when I issue

Code: Select all
apt-get install vim


It yields

Code: Select all
"The following package has unmet dependencies"

.... bla, bla...
Code: Select all
"E: Unable to correct problems. You have held broken packages".


1- ¿How do I run apt-get install and automatically installing all required dependencies?
2- Where the hell can I fin additional repositories so I can add them to sources.list? https://www.debian.org/mirror/list is full of links to directories and large files, but i cannot find the urls of the repos.

Thanks!
banderas20
 
Posts: 37
Joined: 2016-11-10 15:30

Re: Can't install "vim"

Postby arochester » 2017-08-02 13:36

"E: Unable to correct problems. You have held broken packages".
Where does this message appear? Before or after you try to install Vim?

Have you run
Code: Select all
apt-get install -f
in an attempt to fix broken packages?
"Something to be aware of: Debian is a core or source distribution. This means there are many Debian-based distributions. THEY ARE NOT DEBIAN."
arochester
 
Posts: 1112
Joined: 2010-12-07 19:55

Re: Can't install "vim"

Postby banderas20 » 2017-08-02 15:25

arochester wrote:
"E: Unable to correct problems. You have held broken packages".
Where does this message appear? Before or after you try to install Vim?

After.
arochester wrote:Have you run
Code: Select all
apt-get install -f
in an attempt to fix broken packages?


Yes. Without success. I have solved it by purging the old dependency and reinstalling the new version.

However, I'm having trouble with "aptitude install mysql-server".

Code: Select all
The following package has unmet dependencies>
and something about virtual packages.

but now

Code: Select all
The following actions will resolve these dependencies
Keep the following packages at their current version
(packages...) [Not installed]


I accept, and nothing happens.
banderas20
 
Posts: 37
Joined: 2016-11-10 15:30

Re: Can't install "vim"

Postby Bulkley » 2017-08-02 15:37

. . . fresh install of Debian8 . . .


Post your /etc/apt/sources.list.
Bulkley
 
Posts: 5365
Joined: 2006-02-11 18:35

Re: Can't install "vim"

Postby RU55EL » 2017-08-02 15:42

A Debian 9 (Stretch) sources.list should look something like:
Code: Select all
russel@NUC-G:~$ cat /etc/apt/sources.list
deb  http://deb.debian.org/debian stretch main
# deb-src  http://deb.debian.org/debian stretch main

deb  http://deb.debian.org/debian stretch-updates main
# deb-src  http://deb.debian.org/debian stretch-updates main

deb http://security.debian.org/ stretch/updates main
# deb-src http://security.debian.org/ stretch/updates main

Here is some good reading material concerning sources.list

Important note!
The example above is for Debian 9 (Stretch)

An example for Debian 8 (Jessie) should look something like:

Code: Select all
deb  http://deb.debian.org/debian jessie main
# deb-src  http://deb.debian.org/debian jessie main

deb  http://deb.debian.org/debian jessie-updates main
# deb-src  http://deb.debian.org/debian jessie-updates main

deb http://security.debian.org/ jessie/updates main
# deb-src http://security.debian.org/ jessie/updates main
Last edited by RU55EL on 2017-08-03 16:12, edited 4 times in total.
User avatar
RU55EL
 
Posts: 336
Joined: 2014-04-07 03:42
Location: /home/russel

Re: Can't install "vim"

Postby GarryRicketson » 2017-08-02 15:50

I thought "vim" is included by default, are you sure it is not all ready installed ?
=== edited ===
apparently it is not , so my apology:
https://sanctum.geek.nz/arabesque/vim-as-debian-default/
The default text editor in installations of Debian and its derivatives is Nano, largely because it’s a simple and small editor. If you’re a Vim user, you might find it a little jarring to be

That is sad, you would think they would include it in the install.
============================== end edit ===

Post by banderas20 » 2017-08-02 06:59
Hello,

it's a little sad, but I have setup a fresh install of Debian8, and I am unable to install vim (and other packages).

@Post by RU55EL » 2017-08-02 09:42
sources.list should look something like:
NO NO NO, do not do that,... Debian 8 is NOT Debian 9 (strectch)
"What we expect you have already Done"

Before doing anything, read the Debian documentation:
Debian Documentation
How to ask the smart way
Debian Foro Español
======================
For the Birds
User avatar
GarryRicketson
 
Posts: 4463
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Can't install "vim"

Postby banderas20 » 2017-08-02 16:34

Debian8 has "vi" by default, but not "vim".

¿Anything about the other issues concerning mysql dependencies?

Thanks!!!
banderas20
 
Posts: 37
Joined: 2016-11-10 15:30

Re: Can't install "vim"

Postby Bulkley » 2017-08-02 16:40

Where did you get your Debian 8?

Again, let's see your sources.list.
Bulkley
 
Posts: 5365
Joined: 2006-02-11 18:35

Re: Can't install "vim"

Postby arochester » 2017-08-02 16:44

"Something to be aware of: Debian is a core or source distribution. This means there are many Debian-based distributions. THEY ARE NOT DEBIAN."
arochester
 
Posts: 1112
Joined: 2010-12-07 19:55

Re: Can't install "vim"

Postby stevepusser » 2017-08-02 16:52

Something's missing from your sources.list. This is very common for a variety of reasons, often involving non-free firmware. If you would just post the contents, we'd be able to spot it right off.

Also, is there any reason for you to be using the oldstable version of Debian instead of the current release?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8938
Joined: 2009-10-06 05:53

Re: Can't install "vim"

Postby banderas20 » 2017-08-02 17:33

stevepusser wrote:Something's missing from your sources.list. This is very common for a variety of reasons, often involving non-free firmware. If you would just post the contents, we'd be able to spot it right off.

Also, is there any reason for you to be using the oldstable version of Debian instead of the current release?


I am using Debian8 because I tried Debian9 in a Virtual Machine and it crashed several times during installation process, and I don't know why yet.

Tomorrow I will post my sources.list.

Thank you all!!
banderas20
 
Posts: 37
Joined: 2016-11-10 15:30

Re: Can't install "vim"

Postby banderas20 » 2017-08-03 06:48

Hello all.

Here is the contents of my sources.list file:

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

deb http://ftp.debian.org/debian/ jessie-updates main
deb-src http://ftp.debian.org/debian/ jessie-updates main


Thanks!
banderas20
 
Posts: 37
Joined: 2016-11-10 15:30

Re: Can't install "vim"

Postby None1975 » 2017-08-03 12:43

Hello. Your sources list is incomplete. Your sources list file should look like this
Code: Select all
#------------------------------------------------------------------------------#
#                   OFFICIAL DEBIAN REPOS                   
#------------------------------------------------------------------------------#

###### Debian Main Repos
deb http://deb.debian.org/debian/ oldstable main
deb-src http://deb.debian.org/debian/ oldstable main

deb http://deb.debian.org/debian/ oldstable-updates main
deb-src http://deb.debian.org/debian/ oldstable-updates main

deb http://deb.debian.org/debian-security oldstable/updates main
deb-src http://deb.debian.org/debian-security oldstable/updates main
OS: Debian 9.2 / WM: Stumpwm
Debian Wiki | DontBreakDebian, Stumpwm
User avatar
None1975
 
Posts: 225
Joined: 2015-11-29 18:23
Location: Lithuania

Re: Can't install "vim"

Postby banderas20 » 2017-08-03 15:04

None1975 wrote:Hello. Your sources list is incomplete. Your sources list file should look like this


Thanks a million.

Anyway, I still have unmet dependencies:

Code: Select all
Depends: libsnmp15 (>=5.4.3~dfsg) but it is not installable
Recommends: snmpd but it is not going to be installed
E: unable to correct problems, you have held broken packages


:roll:
banderas20
 
Posts: 37
Joined: 2016-11-10 15:30

Re: Can't install "vim"

Postby RU55EL » 2017-08-03 16:07

GarryRicketson wrote:[...]
@Post by RU55EL » 2017-08-02 09:42
sources.list should look something like:
NO NO NO, do not do that,... Debian 8 is NOT Debian 9 (strectch)


Thanks for pointing this out Garry! Duh, sometimes I wonder if I need glasses! You are absolutely correct, I added a note to my other post.
User avatar
RU55EL
 
Posts: 336
Joined: 2014-04-07 03:42
Location: /home/russel

Next

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable