libavcodec vulnerable/not supported, can't play audio

New to Debian (Or Linux in general)? Ask your questions here!

libavcodec vulnerable/not supported, can't play audio

Postby aNoobInSweden » 2017-08-08 20:36

I have got the problem that when I try to listen to audio on SoundCloud, Firefox tells me that libavcodec may be vulnerable or not supported and should be updated, and I can't play it. I try the updates, but it says that all programs are up-to-date. I tried the package handler and switch to the "extra" version of the supported version of libavcodec (53), but to no avail. There seems to be a newer version (55), but it is not supported by this operating system (no Debian logo in the column where those are).

Maybe I should upgrade the distribution, would that help? I'm running Wheezy, I've been putting it off, first out of laziness and "it works, why fiddle with it?", and recently because I can't find my back-up program CD, and I want to take a backup first. I should burn a new one anyway, so that I can take a new backup (as one should regularly...*cough*), but would upgrading to Stretch (I suppose is the one to upgrade to now) fix this issue?

Please remember I'm just a noob. I started using Debian in 2013 with no Linux experience, and exploring its inner workings is unfortunately not my highest priority, simply because of lack of time.
aNoobInSweden
 
Posts: 25
Joined: 2014-06-21 20:16

Re: libavcodec vulnerable/not supported, can't play audio

Postby stevepusser » 2017-08-08 22:14

Wheezy support from Debian will be ending in May 2018, so you should start thinking about upgrading.

That said, libavcodec55 is available in the wheezy-backports repository (see backports.org), and libavcodec56 has also been backported for MEPIS 12/MX 14 repositories (that I know, having done the backporting). Currently, the latest version in any Debian is libavcodec57-3.3.3.

What version of Firefox are you using, anyway? Wheezy was still using the Iceweasel rebranding...and doesn't Firefox still use the gstreamer libraries for multimedia playback, or did they, like Pale Moon, switch to the libav* libraries?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8535
Joined: 2009-10-06 05:53

Re: libavcodec vulnerable/not supported, can't play audio

Postby aNoobInSweden » 2017-08-09 19:16

OK, but would upgrading also update the libavcodec? I suppose it would, since it's a backport for Wheezy, but I ask just to be sure.

If upgrading works, I'll have no need to use the backport, and since upgrading will be needed sooner or later anyway, that is my first option.

Yes it was called Iceweasel, but now it's Firefox ESR. The version is 52.2.0 (64-bit). I have no idea what it uses (told you, I'm a noob...), but since it complains that it's vulnerable or not supported and the audio won't play, my guess is that it uses it in some way anyway.


Thanks
aNoobInSweden
 
Posts: 25
Joined: 2014-06-21 20:16

Re: libavcodec vulnerable/not supported, can't play audio

Postby stevepusser » 2017-08-09 20:45

Upgrading to oldstable Jessie will get you libavcodec56 as standard, while Stretch has libavcodec57.

OK, I remember that when Debian switched back to Firefox, they pushed firefox-esr into the Wheezy repos to replace Iceweasel.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8535
Joined: 2009-10-06 05:53

Re: libavcodec vulnerable/not supported, can't play audio

Postby aNoobInSweden » 2017-08-12 18:38

And those are not "vulnerable or not supported" ?
aNoobInSweden
 
Posts: 25
Joined: 2014-06-21 20:16

Re: libavcodec vulnerable/not supported, can't play audio

Postby stevepusser » 2017-08-12 18:47

aNoobInSweden wrote:And those are not "vulnerable or not supported" ?


I'm not sure exactly which versions you're referring to.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8535
Joined: 2009-10-06 05:53

Re: libavcodec vulnerable/not supported, can't play audio

Postby debiman » 2017-08-13 17:08

ok, here's a shot in the dark:

a few days ago i installed debian wheezy on some old hardware, and was surprised to see that it had the same (or almost the same) firefox version as stretch.
i guess it's part of the security updates that wheezy is still receiving.
but maybe some of its install recommends (like media codecs) do not receive updates anymore - hence firefox balking.
User avatar
debiman
 
Posts: 1086
Joined: 2013-03-12 07:18

Re: libavcodec vulnerable/not supported, can't play audio

Postby stevepusser » 2017-08-13 19:58

Hmmm---I know that Firefox 52 in Jessie and Stretch requires gstreamer1.0 plugins and gstreamer1.0-libav for good HTML5 playback. Those are only available for Wheezy users in the wheezy-backports repository. Maybe if you installed the good, bad, and ugly plugin packages from there, as well as the -libav one, that could get it working. That won't upgrade libavcodec, though....if I were in your situation, I'd just upgrade to a newer Debian and stop trying to bend over backwards to satisfy websites.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8535
Joined: 2009-10-06 05:53

Re: libavcodec vulnerable/not supported, can't play audio

Postby aNoobInSweden » 2017-08-22 16:59

stevepusser wrote:
aNoobInSweden wrote:And those are not "vulnerable or not supported" ?


I'm not sure exactly which versions you're referring to.


56 and 57, as you wrote.
aNoobInSweden
 
Posts: 25
Joined: 2014-06-21 20:16

Re: libavcodec vulnerable/not supported, can't play audio

Postby stevepusser » 2017-08-22 17:55

I don't use Spotify, but have not received any messages that you refer to on a Jessie base. Debian is still pushing security fixes to the libavcodec packages in Wheezy and Jessie...
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8535
Joined: 2009-10-06 05:53

Re: libavcodec vulnerable/not supported, can't play audio

Postby Wheelerof4te » 2017-08-22 18:35

OP should upgrade to Jessie, since Wheezy is about to lose support next year. If he doesn't want to run Jessie, there are alternatives. See the link in my signature.
User avatar
Wheelerof4te
 
Posts: 362
Joined: 2015-08-30 20:14


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable