Can't install steam :/ FIXED

New to Debian (Or Linux in general)? Ask your questions here!

Can't install steam :/ FIXED

Postby CorpseInCharge » 2017-09-01 16:38

Getting this when trying to install steam....any ideas on how to fix?

Code: Select all
aptitude install steam
Note: selecting "steam:i386" instead of the virtual package "steam"
The following NEW packages will be installed:
  gcc-6-base:i386{a} libbsd0:i386{a} libc6:i386{a} libdrm-amdgpu1:i386{a}
  libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} libdrm-radeon1:i386{a}
  libdrm2:i386{a} libedit2:i386{a} libelf1:i386{a} libexpat1:i386{ab}
  libffi6:i386{a} libgcc1:i386{a} libgcrypt20:i386{ab}
  libgl1-mesa-dri:i386{a} libgl1-mesa-glx:i386{a} libglapi-mesa:i386{a}
  libgpg-error0:i386{a} libgpm2:i386{a} libllvm3.9:i386{a}
  libncurses5:i386{a} libpciaccess0:i386{a} libsensors4:i386{a}
  libstdc++6:i386{a} libtinfo5:i386{a} libtxc-dxtn-s2tc:i386{a}
  libudev1:i386{a} libx11-6:i386{a} libx11-xcb1:i386{a} libxau6:i386{a}
  libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} libxcb-glx0:i386{a}
  libxcb-present0:i386{a} libxcb-sync1:i386{a} libxcb1:i386{a}
  libxdamage1:i386{a} libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a}
  libxinerama1:i386{a} libxshmfence1:i386{a} libxss1:i386{a}
  libxxf86vm1:i386{a} steam:i386 zlib1g:i386{a}
0 packages upgraded, 46 newly installed, 0 to remove and 0 not upgraded.
Need to get 26.0 MB of archives. After unpacking 201 MB will be used.
The following packages have unmet dependencies:
 libexpat1 : Breaks: libexpat1:i386 (!= 2.2.0-2+deb9u1) but 2.2.0-2 is to be installed
 libexpat1:i386 : Breaks: libexpat1 (!= 2.2.0-2) but 2.2.0-2+deb9u1 is installed
 libgcrypt20 : Breaks: libgcrypt20:i386 (!= 1.7.6-2+deb9u2) but 1.7.6-2+deb9u1 is to be installed
 libgcrypt20:i386 : Breaks: libgcrypt20 (!= 1.7.6-2+deb9u1) but 1.7.6-2+deb9u2 is installed
open: 7; closed: 806; defer: 0; conflict: 0                                    .The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libexpat1:i386 [Not Installed]                     
2)     libgcrypt20:i386 [Not Installed]                   
3)     libgl1-mesa-dri:i386 [Not Installed]               
4)     libgl1-mesa-glx:i386 [Not Installed]               
5)     steam:i386 [Not Installed]                         

     Leave the following dependencies unresolved:         
6)     libgl1-mesa-glx:i386 recommends libgl1-mesa-dri:i386



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Last edited by CorpseInCharge on 2017-09-01 19:07, edited 1 time in total.
CorpseInCharge
 
Posts: 2
Joined: 2017-09-01 16:36


Re: Can't install steam :/ fixed

Postby CorpseInCharge » 2017-09-01 19:07

Weird issue. I'd followed the wiki on steam install but still got broken packages

Downloaded the latest debian netinst and installed that: worked fine.
CorpseInCharge
 
Posts: 2
Joined: 2017-09-01 16:36


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable