Spotify launcher

New to Debian (Or Linux in general)? Ask your questions here!

Spotify launcher

Postby Deblib » 2017-09-02 09:59

Hello, I have installed spotify-client in Debian 9 following this tutorial: https://www.comoinstalarlinux.com/instalar-spotify-debian-9-stretch/ At first the launcher appeared but it has disappeared and I have to start it by terminal. How can I solve that? Thank you.
Deblib
 
Posts: 43
Joined: 2016-05-14 14:41

Re: Spotify launcher

Postby Lysander » 2017-09-02 10:19

Spotify is the one thing that has given me more trouble than anything else to install in Debian. Having said that, I've done it enough times now to know how to do it.

The Debian Wiki is the most useful resources on this issue [on 99% of issues]. You should always check there before going to another site.

Here:

https://wiki.debian.org/spotify

The issue you are having sounds like the exact same issue I had in Jessie which could only be solved through Flatpak. However, you are using Stretch and it's a lot easier to make Spotify work on Stretch. I would purge your install and start again using the Debian wiki.
User avatar
Lysander
 
Posts: 313
Joined: 2017-02-23 10:07
Location: London

Re: Spotify launcher

Postby Deblib » 2017-09-02 15:16

Thank you Lysander! It worked great! With participants in forums like you it is even more enjoyable to use Debian! :D
Deblib
 
Posts: 43
Joined: 2016-05-14 14:41

Re: Spotify launcher

Postby pylkko » 2017-09-02 17:19

I have listened to spotify using the addon to mopidy, an mpd-like music program that is in the official Debian repository and never had any problems.
User avatar
pylkko
 
Posts: 1045
Joined: 2014-11-06 19:02

Re: Spotify launcher

Postby Deblib » 2017-09-10 13:41

I used the Debian wiki (after purging the previous installation) and after several days the problem reappeared: no icon in the Gnome classic launcher.
Code: Select all
$ spotify
Gtk-Message: Failed to load module "canberra-gtk-module"
[0910/161539:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak
[0910/161539:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak
[0910/161539:ERROR:nss_util.cc(809)] After loading Root Certs, loaded==false: NSS error code: -8018
Deblib
 
Posts: 43
Joined: 2016-05-14 14:41


Return to Beginners Questions

Who is online

Users browsing this forum: golinux and 5 guests

fashionable