PCI Passthrough Help

New to Debian (Or Linux in general)? Ask your questions here!

PCI Passthrough Help

Postby gooseacat » 2017-09-12 16:19

Hi, I'm fairly new to Linux and I really want to make the switch from Windows to Linux. However, I am a big time gamer and Wine really isn't the final solution for me when it comes to some of the games I want to keep playing. I've been dual booting Debian for the past couple of months, and after reading up on and watching several videos about virtual machines and pci passthrough, I have decided that it may finally be the time for me to make the switch.

Here is where I am having an issue, I have two identical nvidia graphics cards, and while I know there are guides for both Fedora and Arch showing you how to unbind a single identical card, there appears to nothing I can follow as a Debian user. I don't know enough about Linux or Debain yet to solve this issue myself, so instead of posting here first, I attempted to see if passthrough was even possible on my setup. Using Arch, since it had the most documentation for my exact problem, I was able to verify that it is indeed possible with my PC's hardware. However my experience with Arch just reinforced my belief that Debian is the OS for me. After about two days of dealing with one issue after another (most of them not even related to my original problem or the virtual machine), I was finally able to pass one of my gtx 960s into my windows 10 vm. My joy quickly turned to horror though, when I realized that if I couldn't replicate this on Debian, I might be forced to stick with Arch or go back to dual booting.... So please help me, I don't want to do either of those things!

What I've done so far:

Created this script here: /sbin/vfio-pci-override.sh
#!/bin/sh

DEVS="0000:04:00.0 0000:04:00.1"

for DEV in $DEVS; do
echo "vfio-pci" > /sys/bus/pci/devices/$DEV/driver_override
done

modprobe -i vfio-pci


Created this file here: /etc/modprobe.d/vfio.conf
install vfio-pci /sbin/vfio-pci-override.sh


Added the following to my modules file here: /etc/initramfs-tools/modules
vfio
vfio_iommu_type1
vfio_pci
vfio_virqfd


With all of this being done, how do I get these two files working? "/etc/modprobe.d/vfio.conf" "/sbin/vfio-pci-override.sh"
On a vfio blog, I found an Ubuntu user in the comments who said you need to make a script in the hooks folder to load those files, but I haven't got a clue how to do that... so anyways,

Thanks for reading this wall of text, and hopefully one of you can help me with this problem. :D
gooseacat
 
Posts: 1
Joined: 2017-09-12 14:45

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable