Time it takes to generate certificate for strongswan

New to Debian (Or Linux in general)? Ask your questions here!

Time it takes to generate certificate for strongswan

Postby aliweb » 2017-09-15 10:19

Hi,

I am trying to install Strongswan on a VPS by following this tutorial:
https://gist.github.com/andrewlkho/3134 ... 368e6280a8

I am at this command to generate certificate but nothing happens. When I run this command the control is not returned so I don't know if the system is still generating certificate or not. I thought may be because I am trying to generate 4096 bit on 512MB (1 CPU) VPS so I closed putty, connected again and this time I tried 2048 bit but it has same problem.

Is there a way to check if it is still working and not hanged after running this command?

Code: Select all
root@myvps:~# cd /etc/ipsec.d
root@myvps:/etc/ipsec.d# ipsec pki --gen --type rsa --size 2048 --outform pem > private/ca.pem
aliweb
 
Posts: 23
Joined: 2017-08-04 05:54

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable