[SOLVED] WiFi not working Lenovo 100S rtl8723bs

New to Debian (Or Linux in general)? Ask your questions here!

[SOLVED] WiFi not working Lenovo 100S rtl8723bs

Postby Meneer » 2017-10-01 19:08

I have successfully installed Debian 9 Stretch from the non-free/cd-including-firmware/

This is 64 bit system with 32 bit UEFI firmware. Therefore, a multi-arch installer is necessary. This is only available as a netinst image. The Debian installer, unfortunately fails to automatically detect the WiFi network hardware. Given that the computer has no other network interface, this is an issue with a netinst. I managed to find an old USB ethernet adaptor to get everything installed.

However, still no WiFi. I have tried following the instructions here, see WiFi > Firmware / WPA supplicant:
https://wiki.debian.org/InstallingDebianOn/Lenovo/100S-11IBY/jessie

I have also tried:
https://github.com/hadess/rtl8723bs/wiki/RTL8723BS-module-building-instruction-for-Debian-GNU-Linux#make-and-install-the-module

Error at:
Code: Select all
modprobe r8723bs

Module r8723bs not found in directory /lib/modules


NB:
Code: Select all
uname -r

4.9.0-3-amd64

Any pointers apprtecied, thanks in advance.
Last edited by Meneer on 2017-10-12 08:04, edited 1 time in total.
Meneer
 
Posts: 5
Joined: 2016-01-12 16:57

Re: WiFi not working Lenovo 100S rtl8723bs

Postby stevepusser » 2017-10-01 21:35

The Debian wiki instructions say to use the i386 kernel, yet you are running the amd64. However, that may not make a difference. The 8732bs driver source on github may just not build on a 4.9 kernel; you no doubt received an error message somewhere in your attempt to follow the instructions, but we can't say where.

The instructions on the github package also says that the driver is included in the 4.12 kernel as a staging driver, but it may not be enabled in the Debian 4.12 kernel. It is enabled in the 4.12 Liquorix kernel, but will also need the firmware.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8937
Joined: 2009-10-06 05:53

Re: WiFi not working Lenovo 100S rtl8723bs

Postby n_hologram » 2017-10-06 18:08


Since you said you tried this, I assume you followed steps 1 - 4 to successfully build and install a working driver. With that being said, I wonder why your modprobe error reads that the driver is not found; I find that especially curious because the installation instructions include apt, so it seems the author wrote this for a Debian-based system (or, maybe, Debian itself). I have two suggestions:

1) that your driver might be installed in a location outside of /lib/modules. If that is the case, it would be trivial to run a find command as root (something like: find / -name '*r8723bs*') and either copy to /lib/modules, or create a symlink (of the same name as the module) in that module directory.

If that doesn't solve the issue, my only other guess would be:
2) that you either didn't create the driver, or the compilation process failed somewhere.

Let us know what you discover.
bester69 wrote:There is nothing to install in linux, from time to time i go to google searching for something fresh to install in linux, but, there is nothing
n_hologram
 
Posts: 255
Joined: 2013-06-16 00:10

Re: WiFi not working Lenovo 100S rtl8723bs

Postby Meneer » 2017-10-12 07:57

Huge thanks to stevepusser and n_hologram. I think that stevepusser's guess is probably correct, the driver either does not build, or perhaps it builds, but it simply does not work with the 4.9 amd64 kernel.

In answer to n_hologram, the driver was definitely present in a subdirectory of /lib/modules/ - I tried moving it to a couple of different locations under /lib/modules/ to see if that made any difference but without success.

On stevepusser's suggestion, the solution was to install the Liquorix kernel, following the instructions here:
http://www.instructables.com/id/Install ... sed-Linux/

I already had the firmware in the correct location, after following the previous instructions:
https://wiki.debian.org/InstallingDebia ... IBY/jessie
Code: Select all
/lib/firmware/rtlwifi/rtl8723bs_nic.bin
/lib/firmware/rtlwifi/rtl8723bs_wowlan.bin

...As a result everything worked perfectly on the first restart after installing the new kernel.

For anyone else with the same issue, exactly what I did is pasted below. Obviously, this is no solution for free software purists. The lesson there is to choose your hardware very carefully before you buy, if you wish to be purist about free software.

Code: Select all
printf "# Liquorix kernel containing non-free drivers \ndeb http://liquorix.net/debian sid main" | sudo tee /etc/apt/sources.list.d/liquorix.list

sudo apt-get update
sudo apt get install apt-transport-https
sudo apt-get install liquorix-keyring
sudo apt-cache search liquorix
sudo apt-get install linux-headers-liquorix-amd64
sudo apt-get install linux-image-liquorix-amd64
sudo update-grub
sudo shutdown -r now

...After re-boot the WiFi worked perfectly with this kernel, no additional messing around necessary.

I am not sure whether update-grub is necessary, but I thought that Grub would probably need to know about a new kernel?

For anyone else with a similar laptop/netbook, note that sound/audio still does not work...
https://wiki.debian.org/InstallingDebia ... IBY/jessie
...suggests that this person never got sound to work.
Meneer
 
Posts: 5
Joined: 2016-01-12 16:57


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable