[SOLVED] Having trouble installing anything

New to Debian (Or Linux in general)? Ask your questions here!

[SOLVED] Having trouble installing anything

Postby czeekaj » 2018-01-10 11:33

I tried to install open vpn on 9.3.0 Debian
Code: Select all
apt-get install openvpn

said I do not have the packagemanager libpkcs11-helper1
I try to install that and it says it's obsoleted or is not there. Can't figure out the dependencies to manage files like open VPN
I can install the .git file directly from git hub, not sure how to open a git as I can't install Git or Git-core for same reason as above. But with different dependencies liberror-perl

What should I do? I also want FireJail.
I got updates and upgrade, however I have not configured repositories? It's a clean install I not sure on Jessie I just type
apt-get install openvpn and it will be in my /etc/openvpn. Than I install Pia access and it just works.
Last edited by czeekaj on 2018-01-16 01:13, edited 2 times in total.
czeekaj
 
Posts: 16
Joined: 2018-01-09 10:18

Re: Having trouble installing anything

Postby pawRoot » 2018-01-10 11:39

Maybe post your sources.list?

For me openvpn installs fine (Stretch)
User avatar
pawRoot
 
Posts: 509
Joined: 2016-12-28 18:26
Location: Poland

Re: Having trouble installing anything

Postby arochester » 2018-01-10 11:56

Have you recently done an upgrade? AS ROOT
Code: Select all
apt update
apt full-upgrade
apt install openvpn
arochester
 
Posts: 1271
Joined: 2010-12-07 19:55

Re: (Solved) Having trouble installing anything

Postby czeekaj » 2018-01-15 04:22

I figured out what my problem was. It's working fine now :) I had the CD still in as my source, I just had to hash it and update the sources list everything is OK now.
Thanks for the help setting me on right track.
czeekaj
 
Posts: 16
Joined: 2018-01-09 10:18


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable