Spotify - can't play any song (ALSA error)

New to Debian (Or Linux in general)? Ask your questions here!

Spotify - can't play any song (ALSA error)

Postby pawRoot » 2018-01-11 16:29

Hi

Just installed Spotify through snap, and Spotify launch without problem, but when i try to play some song, i get this in terminal:

snap run spotify
ALSA lib conf.c:3750:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default


Ideas? :?
User avatar
pawRoot
 
Posts: 509
Joined: 2016-12-28 18:26
Location: Poland

Re: Spotify - can't play any song (ALSA error)

Postby bw123 » 2018-01-11 17:58

alsa setup is very easy once you've done it. just install alsa-utils, I usually reboot for the heck of it, then run alsactl init (as root), then as regular user, alsamixer for vol and channel setup, and then alsactl store *as root) once everything works the way I want. If something is wrong I use speaker-test to see if i get a hint.

They all have decent man pages, but really pretty simple and reliable tools.
User avatar
bw123
 
Posts: 3182
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Spotify - can't play any song (ALSA error)

Postby pawRoot » 2018-01-11 18:08

The thing is that i have sound in browser, only not in spotify (snap).
I have alsa-utils installed aswell.
User avatar
pawRoot
 
Posts: 509
Joined: 2016-12-28 18:26
Location: Poland

Re: Spotify - can't play any song (ALSA error)

Postby bw123 » 2018-01-11 18:20

pawRoot wrote:The thing is that i have sound in browser, only not in spotify (snap).
I have alsa-utils installed aswell.


Never heard of snap as a music app, is this some kind of ubuntu thing? you've been around long enough to know better.

Debian Package Tracking System - snap
snap location of genes from DNA sequence with hidden markov model [IMG] packages.qa.debian.org/s/snap.html
User avatar
bw123
 
Posts: 3182
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Spotify - can't play any song (ALSA error)

Postby pawRoot » 2018-01-11 19:08

the package is called "snapd"

Install, configure, refresh and remove snap packages. Snaps are 'universal' packages that work across many different Linux systems, enabling secure distribution of the latest apps and utilities for cloud, servers, desktops and the internet of things.


https://snapcraft.io/
User avatar
pawRoot
 
Posts: 509
Joined: 2016-12-28 18:26
Location: Poland

Re: Spotify - can't play any song (ALSA error)

Postby debiman » 2018-01-11 19:13

the error message from post #1 looks some sort of ALSA/pulseaudio conflict.
which is your current soundarchitecture, and which one does spotify require?
User avatar
debiman
 
Posts: 2579
Joined: 2013-03-12 07:18

Re: Spotify - can't play any song (ALSA error)

Postby bw123 » 2018-01-11 19:17

pawRoot wrote:the package is called "snapd"

Install, configure, refresh and remove snap packages. Snaps are 'universal' packages that work across many different Linux systems, enabling secure distribution of the latest apps and utilities for cloud, servers, desktops and the internet of things.


https://snapcraft.io/


I see. Well if your sound setup is working correctly in every other way, then maybe you should file a bugreport against the spotify app and show them the permissions on the alsa.conf it can't open?

Code: Select all
$ ls -l /usr/share/alsa/alsa.conf
-rw-r--r-- 1 root root 9663 Feb 13  2017 /usr/share/alsa/alsa.conf


okay, i did a websearch, looks like this is the idea you're going to have to get:
https://docs.snapcraft.io/reference/confinement

I hope it's worth it, be careful, make backups and don't expose any important data or information.
User avatar
bw123
 
Posts: 3182
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Spotify - can't play any song (ALSA error)

Postby Wheelerof4te » 2018-01-11 22:50

Do you have pulseaudio installed? Maybe it is required for Spotify. Also, check if relevant gstreamer plugins are installed.
User avatar
Wheelerof4te
 
Posts: 1068
Joined: 2015-08-30 20:14

Re: Spotify - can't play any song (ALSA error)

Postby pawRoot » 2018-01-12 05:20

For audio i have these packages installed: pulseaudio pavucontrol alsa-utils

Adding flags classic or devmode isn't helping.

I also found this thread:
https://forum.snapcraft.io/t/spotify-do ... audio/3266
User avatar
pawRoot
 
Posts: 509
Joined: 2016-12-28 18:26
Location: Poland


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable