Booting mounting Samba drive on boot

New to Debian (Or Linux in general)? Ask your questions here!

Booting mounting Samba drive on boot

Postby bengo » 2018-01-14 21:59

Good evening everyone. I recently got a Tinkerboard so I can try and mess around with Linux and try and learn some things. I installed TinkerOS which I believe is Debian with no problems and got the everything logged in. I am trying to mount a share from my NAS on boot but am having some issues. This is what I have in /etc/fstab
Code: Select all
//10.1.9.50/Plex /media/pwiiq cifs credentials=/home/pat/.smbcred,rw,_netdev,gid=1000,uid=1001,file_mode=0777,dir_mode=0777 0 0


When I reboot it doesnt mount automatically. It shows up on the left side of the file browser but when I click on it it says "Only system administators have the permission to do this". I then run sudo mount -a and everything works fine. Im not sure what I am doing wrong. I did chown the /media/pwiiq folder to be owned by my user.
bengo
 
Posts: 1
Joined: 2018-01-14 21:46

Re: Booting mounting Samba drive on boot

Postby makh » 2018-01-28 12:59

Hi

Please go to:
https://tinkerboarding.co.uk/forum/index.php

This is debian forum. The derived distros are different, thats why their names are also different.

Thankyou
HP Probook 440 G2: Arch, Debian Stable
Server: none
Past: Debian, Centos, Ubuntu, Opensuse
GUI: Openbox, Cinnamon
Chroot: Debian, Ubuntu, Fedora
VM: Devuan

Employing the best:
Arabic
Debian
Homeopathic

For new: Try Linux Mint
User avatar
makh
 
Posts: 613
Joined: 2011-10-09 09:16


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable