Terminal command- sudo lshw, not working.

New to Debian (Or Linux in general)? Ask your questions here!

Terminal command- sudo lshw, not working.

Postby l000p » 2018-01-23 20:09

Hello guys, what I did yesterday was to install fresh Debian 9.0 on my Windows 10 Laptop- Lenovo V310, which didn't went that smoothly as I am a total newb to Linux OSs. What happened during installation was that my network wireless adapter wasn't recognized so it didn't installed. I've tried to solve the problem with some Googling, but didn't went too far. What I was supposed to do was to run the terminal and then utilize this command: sudo lshw, which worked charm the first time I did it. It displayed my wireless adapter so I googled for drivers of some sort, however I had to abort the search as I had some work to do. So after few hours I restarted the system and did the same command- sudo lshw, which led to nothing... Now the terminal says: bash: sudo: command not found. Can someone help me out as I am getting really frustrated here as I am so new to the system. Thanks.
l000p
 
Posts: 9
Joined: 2018-01-23 19:55

Re: Terminal command- sudo lshw, not working.

Postby arochester » 2018-01-23 20:14

Debian doesn't use sudo by default, though you can add it if you want.

To become Root input
Code: Select all
su


lshw should be run as Root
arochester
 
Posts: 1327
Joined: 2010-12-07 19:55

Re: Terminal command- sudo lshw, not working.

Postby bw123 » 2018-01-23 20:28

l000p wrote:...I am getting really frustrated here as I am so new to the system.


Yeah i know I am frustrated a lot too it kind of gets easier to accept after a little while.

...my network wireless adapter wasn't recognized so it didn't install...


lshw is ok if it is included in your install, people like inxi too. But there are other ways to ID your hardware.

try this https://wiki.debian.org/WiFi it shows how to use really simple tools to ID different devices. Follow the links
https://wiki.debian.org/HowToIdentifyADevice/PCI
https://wiki.debian.org/HowToIdentifyADevice/USB
User avatar
bw123
 
Posts: 3404
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Terminal command- sudo lshw, not working.

Postby l000p » 2018-01-23 20:32

arochester wrote:Debian doesn't use sudo by default, though you can add it if you want.

To become Root input
Code: Select all
su


lshw should be run as Root

I did that too + apt-get install lshw, which led to unrecognised command. Root input doesn't help eighter.
l000p
 
Posts: 9
Joined: 2018-01-23 19:55

Re: Terminal command- sudo lshw, not working.

Postby dotlj » 2018-01-23 20:48

You don't need to run lshw to find your wireless card.
As a non root user run
Code: Select all
lspci

It will show something like this, with more lines
Code: Select all
02:00.0 Network controller: Intel Corporation Wireless 3165 (rev 81)
03:00.0 Ethernet controller: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller (rev 10)
04:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a804

The line with wireless or wifi is the one you want, so you can grep for that, but showing the whole output of the pci devices is useful.
There are non-free drivers for each type of wireless card, so you can have the driver on another USB disk and install that driver during the installation.

As I have an Intel wireless card, I check for a non-free Intel Wireless driver.
I find firmware-iwlwifi and can install that if I want to. (I haven't as I don't use wireless.) :D
Your wireless card maybe realtek, broadcom or something else.
User avatar
dotlj
 
Posts: 599
Joined: 2009-12-25 17:21

Re: Terminal command- sudo lshw, not working.

Postby arochester » 2018-01-23 21:02

Run this command in a Terminal
Code: Select all
lspci | grep Network
arochester
 
Posts: 1327
Joined: 2010-12-07 19:55

Re: Terminal command- sudo lshw, not working.

Postby l000p » 2018-01-24 11:20

Thanks for the help! The lspci command worked fine, I got: Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31).
Now I have to figure out how to install the driver for it, I've opened a new thread, if you can give me a hand on the topic please do, thanks again !
l000p
 
Posts: 9
Joined: 2018-01-23 19:55

Re: Terminal command- sudo lshw, not working.

Postby dotlj » 2018-01-24 20:25

Code: Select all
aptitude search atheros
p   firmware-atheros                                   - Binary firmware for Atheros wireless cards


You have Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31, so

Code: Select all
aptitude show firmware-atheros | grep 9377
 * Qualcomm Atheros QCA9377 rev 1.0 board configuration, version 1 (ath10k/QCA9377/hw1.0/board.bin)
 * Qualcomm Atheros QCA9377 rev 1.0 board configuration, version 2 (ath10k/QCA9377/hw1.0/board-2.bin)
 * Qualcomm Atheros QCA9377 rev 1.0 firmware, version WLAN.TF.1.0-00267-1 (ath10k/QCA9377/hw1.0/firmware-5.bin)


So as root,
Code: Select all
apt-get install firmware-atheros
User avatar
dotlj
 
Posts: 599
Joined: 2009-12-25 17:21

Re: Terminal command- sudo lshw, not working.

Postby pendrachken » 2018-01-25 18:06

arochester wrote:Debian doesn't use sudo by default, though you can add it if you want.

To become Root input
Code: Select all
su


lshw should be run as Root



Does the installer not let you do a rootless install anymore? If the rootless install is checked / enabled in the installer the user is supposed to be set up with sudo installed and configured to use the users password for root authentications.

I haven't had to use the installer for quite some time, so I'm asking if that option was removed...
fortune -o
Your love life will be... interesting.
:twisted: How did it know?

The U.S. uses the metric system too, we have tenths, hundredths and thousandths of inches :-P
pendrachken
 
Posts: 1325
Joined: 2007-03-04 21:10
Location: U.S.A. - WI.


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable