unmet dependencies when installing 'gstreamer1.0-plugins-*'

New to Debian (Or Linux in general)? Ask your questions here!

unmet dependencies when installing 'gstreamer1.0-plugins-*'

Postby puertas12 » 2018-04-08 13:21

I executed this command in Debian 9:
Code: Select all
sudo apt-get install gstreamer1.0-plugins-*


The installation didn't succeed because these unmet dependecies:
The following packages have unmet dependencies:
gstreamer1.0-plugins-bad-dbg : Depends: gstreamer1.0-plugins-bad (= 1.10.4-1) but 1:1.10.4-dmo2 is to be installed
gstreamer1.0-plugins-ugly-dbg : Depends: gstreamer1.0-plugins-ugly (= 1.10.4-1) but 1:1.10.4-dmo1 is to be installed


Then I executed:
Code: Select all
sudo apt-get install gstreamer1.0-plugins-bad

and
Code: Select all
sudo apt-get install gstreamer1.0-plugins-ugly


But the dependencies are still not meet.

Note: I did a sear for these plugins:
Code: Select all
sudo find / -iname "*gstreamer1.0-plugins-bad*"

/usr/share/doc/gstreamer1.0-plugins-bad
/var/cache/apt/archives/gstreamer1.0-plugins-bad_1%3a1.10.4-dmo2_amd64.deb
/var/lib/dpkg/info/gstreamer1.0-plugins-bad:amd64.list
/var/lib/dpkg/info/gstreamer1.0-plugins-bad:amd64.md5sums

and
Code: Select all
sudo find / -iname "gstreamer1.0-plugins-ugly*"

/usr/share/doc/gstreamer1.0-plugins-ugly
/var/cache/apt/archives/gstreamer1.0-plugins-ugly_1%3a1.10.4-dmo1_amd64.deb
/var/lib/dpkg/info/gstreamer1.0-plugins-ugly:amd64.list
/var/lib/dpkg/info/gstreamer1.0-plugins-ugly:amd64.md5sums


Any ideas on how to install the 'gstreamer1.0-plugins-*'?
puertas12
 
Posts: 4
Joined: 2017-10-24 06:09

Re: unmet dependencies when installing 'gstreamer1.0-plugins

Postby peter_irich » 2018-04-08 16:41

Try do not use a packages not from the official repository. For example, gstreamer1.0-plugins-bad is in Debian Stretch too.
i.e turn off deb-multimedia, remove packages from it and try again.

Peter.
peter_irich
 
Posts: 1228
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: unmet dependencies when installing 'gstreamer1.0-plugins

Postby puertas12 » 2018-04-08 16:49

The deb-multimedia is removed.

Then I executed:
Code: Select all
sudo apt-get install gstreamer1.0-plugins-*

However:
gstreamer1.0-plugins-bad-dbg : Depends: gstreamer1.0-plugins-bad (= 1.10.4-1) but 1:1.10.4-dmo2 is to be installed
gstreamer1.0-plugins-ugly-dbg : Depends: gstreamer1.0-plugins-ugly (= 1.10.4-1) but 1:1.10.4-dmo1 is to be installed


What are these dmo's?
puertas12
 
Posts: 4
Joined: 2017-10-24 06:09

Re: unmet dependencies when installing 'gstreamer1.0-plugins

Postby puertas12 » 2018-04-08 17:10

peter_irich wrote:Try do not use a packages not from the official repository. For example, gstreamer1.0-plugins-bad is in Debian Stretch too.
i.e turn off deb-multimedia, remove packages from it and try again.

Peter.


Thanks you got the answer after removing the packages I could install the gstreamer plugins!

Thanks
puertas12
 
Posts: 4
Joined: 2017-10-24 06:09

Re: unmet dependencies when installing 'gstreamer1.0-plugins

Postby peter_irich » 2018-04-08 19:10

puertas12 wrote:
peter_irich wrote:Try do not use a packages not from the official repository. For example, gstreamer1.0-plugins-bad is in Debian Stretch too.
i.e turn off deb-multimedia, remove packages from it and try again.

Peter.


Thanks you got the answer after removing the packages I could install the gstreamer plugins!

Thanks

Excuse me, I wanted to say "from the unofficial", but you understood.

Peter.
peter_irich
 
Posts: 1228
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: unmet dependencies when installing 'gstreamer1.0-plugins

Postby stevepusser » 2018-04-08 21:09

"dmo" indicates that it's a "deb-multimedia.org" package. Those have caused problems for many people, as you have just discovered.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.2, Pale Moon 27.9.3, wine-staging 3.11, QuiteRSS 0.18.11, Linux kernel 4.17, Krita 4.1.0
User avatar
stevepusser
 
Posts: 9718
Joined: 2009-10-06 05:53


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable