Wifi Adapter Detected, Sees Networks, but Can't Connect

New to Debian (Or Linux in general)? Ask your questions here!

Wifi Adapter Detected, Sees Networks, but Can't Connect

Postby DavoStory » 2018-04-15 18:02

Hello there~
I'm running Debian 9.4 through VirtualBox and trying to connect my USB wireless adapter to it. I'm using an Alfa AWUS036NHA wireless adapter that has an Atheros AR9271 Chipset https://www.amazon.com/Alfa-AWUS036NHA-Wireless-USB-Adaptor/dp/B004Y6MIXS.

I have downloaded the firmware-atheros package as specified in the Debian Wiki https://wiki.debian.org/ath9k_htc#supported so that Debian now recognizes the wifi adapter and I am able to see the available wireless networks to connect to. The problem now lies in the fact that I can't connect to the networks. And before you ask, yes, I did quadruple check to make sure I typed in the correct passcode :? .


I've used this wireless adapter on a Kali virtual image where all the drivers and firmware were already pre-configured so everything worked.

I've also tried installing the open-firmware as specified here: (https://wiki.debian.org/ath9k_htc/open_firmware), but it yielded the same results.

Here are some stats I've seen people post in other fourms to try to give more info about their system:
dmesg|grep -Ei 'wlan|firmw|dhc'
Code: Select all
[ 5185.316771] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[ 5185.316821] usb 1-1: firmware: direct-loading firmware ath9k_htc/htc_9271-1.4.0.fw
[ 5186.488756] ath9k_htc 1-1:1.0 wlx00c0ca96bfea: renamed from wlan0

Code: Select all
Bus 001 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n

lsmod | grep ath
Code: Select all
ath9k_htc              65536  0
ath9k_common           32768  1 ath9k_htc
ath9k_hw              458752  2 ath9k_htc,ath9k_common
ath                    32768  3 ath9k_htc,ath9k_hw,ath9k_common
mac80211              671744  1 ath9k_htc
cfg80211              589824  4 ath9k_htc,mac80211,ath,ath9k_common
usbcore               253952  6 ath9k_htc,usbhid,ehci_hcd,ohci_pci,ohci_hcd,ehci_pci

I've run out of things to try. If you need more information, please let me know and I'll get it to you. Any type of help would be much appreciated. Thank you.
Posts: 1
Joined: 2018-04-15 14:51

Re: Wifi Adapter Detected, Sees Networks, but Can't Connect

Postby pylkko » 2018-04-19 08:31

There is one clue here, and that is that Kali (where it worked) is based on future testing packages of Debian that will be released in 2019 (or possibly never, since they will likely be superseded before that date). The page that you link says that the open firmware does not have support for your devices currently but that the testing version does have it. So, in essence Kali is using a package that does not exist in Debian yet. You coud try to backport it or even just use the testing package as is (because it is likely to not depend on specific library versions and will just work).

can you see the device in
Code: Select all
User avatar
Posts: 1365
Joined: 2014-11-06 19:02

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 4 guests