SOLVED : Wifi Card not loading / Debian Wheezy

New to Debian (Or Linux in general)? Ask your questions here!

SOLVED : Wifi Card not loading / Debian Wheezy

Postby Laurent22 » 2018-04-20 13:56

Bonjour,

This is my first post here, I'm new to Linux and Debian, did a lot of research to fix this, can't find a solution, I hope someone can help.

I'm trying to set up a PC for use as a CNC controller with LinuxCnc. The people at LinuxCnc have packaged a Live/Install ISO file, from which I installed my system. It is running with a real-time version of the Kernel : 3.4-9-RTAI-686-pae. Install of the system was easy and fast.

Now, I'm trying to add a Wifi card to this machine, for I won't have a wired connection option where I'm going to use it. I've installed a TP-Link TL-WN881ND v.2 PCIe card, and can't get it to work. AFAIK, the chipset is "Realtek 8192E PCI WiFi"

Excerpt from dmesg :
Code: Select all
[ 0.000000] Linux version 3.4-9-rtai-686-pae (Debian 3.4.55-4linuxcnc) () (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP PREEMPT Debian 3.4.55-4linuxcnc

Code: Select all
> lspci -v
[ excerpt....]
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 818b
Subsystem: Realtek Semiconductor Co., Ltd. Device 8196
Flags: bus master, fast devsel, latency 0, IRQ 5
I/O ports at cc00
Memory at fe7fc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>


So it seems that there is no Kernel driver loaded for the card.

I've tried :
Code: Select all
> sudo apt-get update
> sudo apt-get install firmware-realtek


and I get :
Code: Select all
"...firmware-realtek is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 368 not upgraded"


I've also tried to download and compile the driver available on TP-Link, but compilation failed with this error message :
Code: Select all
incompatible types when assigning to type 'struct wiphy_wowlan_support' from type 'const struct wiphy_wowlan_support'


To check that the card was working, I booted the machine on a USB drive with an image of Ubuntu. This worked fine, and I could get the Wifi card recognized and working.

Your help is appreciated :?
Last edited by Laurent22 on 2018-04-22 15:59, edited 1 time in total.
Laurent22
 
Posts: 3
Joined: 2018-04-20 12:31

Re: Wifi Card not loading / Debian Wheezy, OK / Ubuntu ?

Postby arochester » 2018-04-20 14:09

Not Debian then?

LinuxCNC Forum >>> https://forum.linuxcnc.org/
arochester
 
Posts: 1349
Joined: 2010-12-07 19:55

Re: Wifi Card not loading / Debian Wheezy

Postby Wheelerof4te » 2018-04-20 14:15

Wheezy has 3.2 kernel...
If you need Debian, then current Stable, Stretch is recommended.
User avatar
Wheelerof4te
 
Posts: 1134
Joined: 2015-08-30 20:14

Re: Wifi Card not loading / Debian Wheezy

Postby Laurent22 » 2018-04-20 14:28

I'm a little confused here, so please bear with me.

In /etc/issue file : I have :
Code: Select all
Debian GNU/Linux 7 \n \l

and in debian_version :
Code: Select all
7.11


I know that the kernel version used in the LinuxCnc ISO might not be the latest one, I think there is some issue with the way real-time mode has changed in more up to date versions.
I got the install files from http://linuxcnc.org/docs/2.7/html/getting-started/getting-linuxcnc.html normal download. It's called Linuxcnc-2.7-wheezy.iso
Laurent22
 
Posts: 3
Joined: 2018-04-20 12:31

Re: Wifi Card not loading / Debian Wheezy

Postby GarryRicketson » 2018-04-20 16:16

I think you would be better off trying to ask about this here:
https://lists.sourceforge.net/lists/listinfo/emc-users
=======
http://linuxcnc.org/docs/html/getting-started/about-linuxcnc.html

You might find some one with experience with this on that mailing list.
If you don't want to join the mailing list, you can browse :
https://sourceforge.net/p/emc/mailman/emc-users/
They have a search engine:
https://sourceforge.net/p/emc/mailman/search/?q=++Wifi+Card+not+loading+%2F+Debian+Wheezy
How ever, it would be better to join, post with details on your situation, what
kind of machines, etc,....just browsing the list would be very tedious, and not likely to find anything for your specific situation.
User avatar
GarryRicketson
 
Posts: 5193
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Wifi Card not loading / Debian Wheezy

Postby 4D696B65 » 2018-04-20 16:54

Another option is to find an older wifi card/usb that is supported by deb 7 (wheezy).
User avatar
4D696B65
 
Posts: 2220
Joined: 2009-06-28 06:09

Re: Wifi Card not loading / Debian Wheezy

Postby stevepusser » 2018-04-20 17:01

It seems the driver from TP Link is not compatible with the 3.4 kernel. Perhaps you can build the driver from Realtek's support page, or find a github repo that has modified the source to be compatible. In the worst case, if you have a USB port, you could use an external adapter that's know to work on Wheezy.

Often you have to add a .conf file for Realtek devices to disable automatic powersaving, too, or suffer unexplained connection loss.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10279
Joined: 2009-10-06 05:53

Re: Wifi Card not loading / Debian Wheezy

Postby andre@home » 2018-04-22 09:11

TP Link is even under Windows 7 a problem. Better check the compatibility lists for the chipsets that have the best chance of being supported.
andre@home
 
Posts: 282
Joined: 2011-10-02 08:00

Re: Wifi Card not loading / Debian Wheezy

Postby Laurent22 » 2018-04-22 15:59

Thank you to all the people who offered suggestions and support here.

This issue is now SOLVED, thanks to ozzyrob in the LinuxCNC forum (thread here : https://forum.linuxcnc.org/9-installing-linuxcnc/34414-wifi-pci-card-not-running-with-basic-linuxcnc-install?start=10#109432)

From what I understood, it's related to the fact that the kernel version (3.4-9-RTAI-686-pae) used in the LinuxCNC basic distribution still uses the older WEXT API, replaced later by cfg80211. So, the solution was to edit the Makefile in the driver source provided by TP Link on its site :
CONFIG_IOCTL_CFG80211=y
to
CONFIG_IOCTL_CFG80211=n
so that the driver could be compiled.
I did that, installed, reboot, and everything works !

Again, thank you for your help, I think I will love my journey with Linux and Debian
Laurent22
 
Posts: 3
Joined: 2018-04-20 12:31


Return to Beginners Questions

Who is online

Users browsing this forum: sswcharlie, stevepusser and 2 guests

fashionable