Issue with libbz2-1.0

New to Debian (Or Linux in general)? Ask your questions here!

Issue with libbz2-1.0

Postby valgio » 2018-04-25 13:45

Hello i'm new here and new with debian. I have used ubuntu and archlinux. My problem is the libbz2-1.0. I was doing an upgrade
Code: Select all
sudo apt-get update
sudo apt-get upgrade


when i got

Code: Select all
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 bzip2 : Depends: libbz2-1.0 (= 1.0.6-8.1) but 1.0.5-6 is installed
E: Unmet dependencies. Try using -f.

:?: :?: :?:
so i ran
Code: Select all
sudo apt-get -f install


and i got:
Code: Select all
Reading changelogs... Done
Selecting previously deselected package libbz2-1.0.
(Reading database ... 33010 files and directories currently installed.)
Preparing to replace libbz2-1.0 1.0.5-6 (using .../libbz2-1.0_1.0.6-8.1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libbz2-1.0_1.0.6-8.1_i386.deb (--unpack):
 triggers ci file contains unknown directive `activate-noawait'
configured to not write apport reports
                                      Errors were encountered while processing:
 /var/cache/apt/archives/libbz2-1.0_1.0.6-8.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

8)

What can i do to solve this? Have you got any suggests?
Thank you :D :)
valgio
 
Posts: 3
Joined: 2018-04-25 13:34

Re: Issue with libbz2-1.0

Postby None1975 » 2018-04-25 14:38

Post your sources list here.
User avatar
None1975
 
Posts: 703
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius

Re: Issue with libbz2-1.0

Postby valgio » 2018-04-25 14:58

Code: Select all
deb http://deb.debian.org/debian/ stable main contrib non-free
deb-src http://deb.debian.org/debian/ stable main contrib non-free

deb http://deb.debian.org/debian/ stable-updates main contrib non-free
deb-src http://deb.debian.org/debian/ stable-updates main contrib non-free

deb http://deb.debian.org/debian-security stable/updates main
deb-src http://deb.debian.org/debian-security stable/updates main

deb http://ftp.debian.org/debian stretch-backports main
deb-src http://ftp.debian.org/debian stretch-backports main


that is :D
I updated it this morning
valgio
 
Posts: 3
Joined: 2018-04-25 13:34

Re: Issue with libbz2-1.0

Postby bw123 » 2018-04-25 15:33

...
bzip2 : Depends: libbz2-1.0 (= 1.0.6-8.1) but 1.0.5-6 is installed
...


That's like, pretty old ver installed, maybe squeeze?
User avatar
bw123
 
Posts: 3580
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Issue with libbz2-1.0

Postby stevepusser » 2018-04-25 16:42

Yes, you should change "stable" in your sources to "stretch" or you'll get an interesting surprise when Buster becomes stable.

And you have to tell us the history of your install. That old, old library just didn't magically install itself on a Stretch system.

AS for fixing it, using aptitude and its multiple solutions to install libbz2-dev usually does the trick.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10279
Joined: 2009-10-06 05:53

Re: Issue with libbz2-1.0

Postby valgio » 2018-04-25 18:18

That is a virtual machine i took from internet. I wanted to install radare2 but git crashed. On google i read a possible solution is downgrading libcurl3-gnutls from 7.21.6-3 to 7.21.0-1. So i tried and i got

Code: Select all
libcurl3-gnutls is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 bzip2 : Depends: libbz2-1.0 (= 1.0.6-8.1) but 1.0.5-6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


I updated and upgraded everything and here we are.
I'll try with aptitude. (Could you suggest me how to you it please?) :?

by now thank you very much. I hope to solve
Unlucky i'm very new in debian (today it's my first day XD ) .
valgio
 
Posts: 3
Joined: 2018-04-25 13:34

Re: Issue with libbz2-1.0

Postby stevepusser » 2018-04-25 18:46

Did they give you the user or root passwords for the install?

Is it using sudo, root, or both?

Anyway, install aptitude as root or with sudo

apt install aptitude


Then with sudo or as root

Code: Select all
aptitude install libbz2-dev


If it says no, it can't, hit the "n" key for "NO" to try another solution. Continue until it gives a solution that upgrades libbz2-1.0 to the newer version.

Don't accept solutions that want to remove many, many packages, or critical ones. This means your system is probably even more damaged than you know.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10279
Joined: 2009-10-06 05:53

Re: Issue with libbz2-1.0

Postby pendrachken » 2018-04-30 04:31

stevepusser wrote:Did they give you the user or root passwords for the install?

Is it using sudo, root, or both?

Anyway, install aptitude as root or with sudo

apt install aptitude


Then with sudo or as root

Code: Select all
aptitude install libbz2-dev


If it says no, it can't, hit the "n" key for "NO" to try another solution. Continue until it gives a solution that upgrades libbz2-1.0 to the newer version.

Don't accept solutions that want to remove many, many packages, or critical ones. This means your system is probably even more damaged than you know.



Uhh, Steve....

Preparing to replace libbz2-1.0 1.0.5-6 (using .../libbz2-1.0_1.0.6-8.1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libbz2-1.0_1.0.6-8.1_i386.deb (--unpack):
triggers ci file contains unknown directive `activate-noawait'



It's not APT throwing the error, it's actually dpkg failing. Aptitude won't help with this. It's either a corrupt download / file, or it's a badly written install script that MAY be able to be force installed if absolutely necessary.
fortune -o
Your love life will be... interesting.
:twisted: How did it know?

The U.S. uses the metric system too, we have tenths, hundredths and thousandths of inches :-P
pendrachken
 
Posts: 1332
Joined: 2007-03-04 21:10
Location: U.S.A. - WI.


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable