No internet after installing on a laptop

New to Debian (Or Linux in general)? Ask your questions here!

No internet after installing on a laptop

Postby turnabout » 2018-05-19 22:41

I just finished installing Debian on an old laptop I got. During the installation, it prompted for some .ucode files, which I transfered on a USB drive and plugged in my laptop. Everything went alright during the installation.

Now that it's installed, I don't have access to the internet. I can't install packages, can't ping anything including my router, etc. I'm not sure what it is I'm missing. I don't know if it's important but I also didn't select a Desktop Environment during the installation (I just want a WM).

I looked around a bit and found perhaps I need a network manager? But if I enter

Code: Select all
service network-manager start


I get

Code: Select all
Failed to start network-manager.service: Unit network-manager.service not found.


I looked to download the package from my desktop and manually transfer it to my laptop via USB, but the package also has a bunch of dependencies, some of which have a bunch of dependencies... so I'm not sure what to do.
turnabout
 
Posts: 1
Joined: 2018-05-19 22:13

Re: No internet after installing on a laptop

Postby dilberts_left_nut » 2018-05-19 23:02

AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4886
Joined: 2009-10-05 07:54
Location: enzed

Re: No internet after installing on a laptop

Postby bw123 » 2018-05-19 23:26

Take your time, this is good too.

https://www.debian.org/doc/manuals/debi ... own_legacy

Should be a lot of threads on here, search for 'minimal install' or something like that.
User avatar
bw123
 
Posts: 3411
Joined: 2011-05-09 06:02
Location: TN_USA

Re: No internet after installing on a laptop

Postby p.H » 2018-05-20 05:36

NetworkManager is optional and installed by default only if you install some desktop environments which depend on it.

Do you use a wireless or ethernet connection to the router ?
Can you post the output of the following commands :
Code: Select all
lspci
cat /etc/network/interfaces
cat /etc/network/interfaces.d/*
cat /etc/resolv.conf
ip addr
ip route
p.H
 
Posts: 602
Joined: 2017-09-17 07:12

Re: No internet after installing on a laptop

Postby None1975 » 2018-05-21 13:21

Hello. Try (as root)
Code: Select all
#systemctl stop dhcpcd
#systemctl start dhcpcd
OS: Debian 9.5 / WM: Xmonad
Debian Wiki | DontBreakDebian, My config files in github
Linux User #607425
User avatar
None1975
 
Posts: 654
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius

Re: No internet after installing on a laptop

Postby Wheelerof4te » 2018-05-21 13:29

turnabout wrote:During the installation, it prompted for some .ucode files,

Kinda important for which files it prompted, but I'm going by a wild guess and I say Wi-Fi non-free firmware.
We will have to see the output of lspci p.H asked for first.
If you have LAN cable, plug it in (maybe take it from the desktop) and install the correstonding firmware.
Since you got no DE, network config will have to be managed though CLI. There are some tools for that, google around. Or just config everything with LAN and get your Wi-Fi set after.
User avatar
Wheelerof4te
 
Posts: 1134
Joined: 2015-08-30 20:14


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable