vi does not beep when switching to command mode.

New to Debian (Or Linux in general)? Ask your questions here!

vi does not beep when switching to command mode.

Postby stf92 » 2018-06-03 15:08

Hi: when switching from insert to command mode vi used to beep the loudspeaker (bell char, 0x07). The loudspeaker in my machine works fine. However it is muted all the editing session through. This is Debian 9. There is one thing. If I issued 'vi --version' I get VIM - Vi IMproved 8.0. Somehow vi seems to be linked to vim. In fact
Code: Select all
semoi@debian:/almacen/soft$ whereis vi
vi: /usr/bin/vi /usr/share/man/man1/vi.1.gz
semoi@debian:/almacen/soft$ ls -l /usr/bin/vi
lrwxrwxrwx 1 root root 20 May 30 14:52 /usr/bin/vi -> /etc/alternatives/vi
semoi@debian:/almacen/soft$ ls -l /etc/alternatives/vi
lrwxrwxrwx 1 root root 18 Jun  2 16:52 /etc/alternatives/vi -> /usr/bin/vim.basic
semoi@debian:/almacen/soft$

How do you explain this?
stf92
 
Posts: 41
Joined: 2018-05-27 20:16

Re: vi does not beep when switching to command mode.

Postby bw123 » 2018-06-03 15:39

User avatar
bw123
 
Posts: 3532
Joined: 2011-05-09 06:02
Location: TN_USA

Re: vi does not beep when switching to command mode.

Postby debiman » 2018-06-04 05:30

does anything beep in your terminal???
User avatar
debiman
 
Posts: 3027
Joined: 2013-03-12 07:18

Re: vi does not beep when switching to command mode.

Postby stf92 » 2018-06-04 13:09

Well, when I plug the battery cord into the jack the speaker beeps (or when I unplug it, don't remember well).
stf92
 
Posts: 41
Joined: 2018-05-27 20:16

Re: vi does not beep when switching to command mode.

Postby debiman » 2018-06-04 20:23

stf92 wrote:Well, when I plug the battery cord into the jack the speaker beeps (or when I unplug it, don't remember well).

interesting.
i'm sure it has nothing to do with your terminal/shell/vi.
User avatar
debiman
 
Posts: 3027
Joined: 2013-03-12 07:18


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable