HPLIP Plugin problem

New to Debian (Or Linux in general)? Ask your questions here!

HPLIP Plugin problem

Postby Danfinn » 2018-06-04 21:16

Just done a fresh install of Jessie and afaik it is fully updated. When trying to use my HP Laserjet P1102W it thows up a HPLIP plug in error and stops. I have tried it shared, plugged in direct using usb, but still no joy. However, my HP C6200 multifunction printer works perfectly. This is sitting on the ethernet with a fixed ip. I have been to the package manager thinking HPLIP was missing but it is there. :?

Any ideas folks. It all works perfectly on my Wheezy pc, which I was advised to update :(
User avatar
Danfinn
 
Posts: 18
Joined: 2015-09-03 18:02

Re: HPLIP Plugin problem

Postby Lysander » 2018-06-04 21:21

Why are you not using Stretch? For one, they use different versions of the plugin (3.14.6-1+deb8u1 vs 3.16.11+repack0-3) respectively and secondly, you were advised to update to Stretch, not Jessie. I mean, you could backport the Stretch plugin in Jessie, but that would be weird, to say the least.
User avatar
Lysander
 
Posts: 557
Joined: 2017-02-23 10:07
Location: London

Re: HPLIP Plugin problem

Postby stevepusser » 2018-06-05 00:53

Though jessie-backports has 3.16.11 too, the stock Jessie version should support it:

Code: Select all
HPLIP 3.10.5 - This release has the following changes:
Significant Changes:
Added support for the following new Printers:

- HP Photosmart D110 Series Printer
- HP LaserJet Professional P1102w Printer
- HP Laserjet Professional P1102 Printer
- HP LaserJet Professional M1132 Multifunction Printer
- HP LaserJet Professional M1212nf Multifunction Printer
- HP LaserJet Professional P1566
- HP LaserJet Professional P1606dn Printer
- HP Officejet 4000 K210 Printer
- HP Officejet 4400 K410 All-in-One Printer
- HP LaserJet M5039 Multifunction Printer



Many HP printers require that you download a PPD file for your printer through the HP GUI. Have you tried this yet?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: mvp 0.29.0, Pale Moon 27.9.4, wine-staging 3.13, MPC-QT 18.03, Linux kernel 4.17.8, ffmpeg 4.0.2
User avatar
stevepusser
 
Posts: 9791
Joined: 2009-10-06 05:53


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable